aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/aircrack-ng
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-05-27 07:31:26 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-05-27 07:31:26 +0000
commita0897d9beadd477aa953b037393703ac16be4b1b (patch)
treee5c6f1fbd5f579a36c2e900ae37b30f08056cc32 /net-mgmt/aircrack-ng
parent5da9f948645b730401bc1d2f9106af273eb43abe (diff)
downloadports-a0897d9beadd477aa953b037393703ac16be4b1b.tar.gz
ports-a0897d9beadd477aa953b037393703ac16be4b1b.zip
Notes
Diffstat (limited to 'net-mgmt/aircrack-ng')
-rw-r--r--net-mgmt/aircrack-ng/Makefile42
-rw-r--r--net-mgmt/aircrack-ng/distinfo3
-rw-r--r--net-mgmt/aircrack-ng/pkg-descr9
-rw-r--r--net-mgmt/aircrack-ng/pkg-message9
4 files changed, 63 insertions, 0 deletions
diff --git a/net-mgmt/aircrack-ng/Makefile b/net-mgmt/aircrack-ng/Makefile
new file mode 100644
index 000000000000..10e0bfc5586a
--- /dev/null
+++ b/net-mgmt/aircrack-ng/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: aircrack-ng
+# Date created: 2006-05-25
+# Whom: Lars Engels <lars.engels@0x20.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aircrack-ng
+PORTVERSION= 0.5
+CATEGORIES= net-mgmt
+MASTER_SITES= http://download.aircrack-ng.org/ \
+ http://bsd-geek.de/FreeBSD/distfiles/
+
+MAINTAINER= lars.engels@0x20.net
+COMMENT= Aircrack-ng is the next generation of aircrack
+
+ALL_TARGET= aircrack-ng airdecap-ng arpforge-ng ivstools kstats
+
+PLIST_FILES= bin/aircrack-ng bin/airdecap-ng bin/arpforge-ng bin/ivstools \
+ bin/kstats
+MAN1= aircrack-ng.1 airdecap-ng.1 arpforge-ng.1 ivstools.1
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/aircrack-ng ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/airdecap-ng ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/arpforge-ng ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/ivstools ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/kstats ${PREFIX}/bin
+.for manpage in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/manpages/${manpage} ${PREFIX}/man/man1
+.endfor
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/aircrack-ng/distinfo b/net-mgmt/aircrack-ng/distinfo
new file mode 100644
index 000000000000..592cdc230fd3
--- /dev/null
+++ b/net-mgmt/aircrack-ng/distinfo
@@ -0,0 +1,3 @@
+MD5 (aircrack-ng-0.5.tar.gz) = 303daa6f1b030f8f9a2f00542051b96c
+SHA256 (aircrack-ng-0.5.tar.gz) = 09c6959671e2e96315d161cf34084461c194e5ab0a3007631cddf8bc3efe7f2e
+SIZE (aircrack-ng-0.5.tar.gz) = 131156
diff --git a/net-mgmt/aircrack-ng/pkg-descr b/net-mgmt/aircrack-ng/pkg-descr
new file mode 100644
index 000000000000..12272b0f5159
--- /dev/null
+++ b/net-mgmt/aircrack-ng/pkg-descr
@@ -0,0 +1,9 @@
+aircrack is an 802.11 WEP and WPA-PSK keys cracking program that can
+recover this keys once enough encrypted packets have been captured.
+It implements the standard FMS attack along with some optimizations
+like KoreK attacks, thus making the attack much faster compared to
+other WEP cracking tools. In fact aircrack is a set of tools for
+auditing wireless networks.
+
+Author: Lars Engels <lars.engels@0x20.net>
+WWW: http://http://www.aircrack-ng.org
diff --git a/net-mgmt/aircrack-ng/pkg-message b/net-mgmt/aircrack-ng/pkg-message
new file mode 100644
index 000000000000..b5838290c6d7
--- /dev/null
+++ b/net-mgmt/aircrack-ng/pkg-message
@@ -0,0 +1,9 @@
+======================================================================
+Currently only airdecap-ng, arpforge-ng, aircrack-ng, ivstools and
+kstats can be compiled as aireplay-ng, airomon-ng and airodump-ng
+are too Linux-specific to be built on FreeBSD.
+However aircrack-ng can read Kismet's dumpfile.
+
+If you manage to patch the port so that the missing tools can be built
+on FreeBSD, please contact the port maintainer.
+======================================================================