aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/airport
diff options
context:
space:
mode:
authorNick Sayer <nsayer@FreeBSD.org>2001-05-22 03:56:36 +0000
committerNick Sayer <nsayer@FreeBSD.org>2001-05-22 03:56:36 +0000
commit6ce45ccb99e7fbca3f40d560efb2e0ca4452c1e7 (patch)
treea8b80b3e3baabbb571e7260bd91f1d2311d59927 /net-mgmt/airport
parent84c32fb24c1b9778801ad157d9ee899e9ac17110 (diff)
downloadports-6ce45ccb99e7fbca3f40d560efb2e0ca4452c1e7.tar.gz
ports-6ce45ccb99e7fbca3f40d560efb2e0ca4452c1e7.zip
Notes
Diffstat (limited to 'net-mgmt/airport')
-rw-r--r--net-mgmt/airport/Makefile12
-rw-r--r--net-mgmt/airport/distinfo2
-rw-r--r--net-mgmt/airport/files/airport22
-rw-r--r--net-mgmt/airport/pkg-descr4
-rw-r--r--net-mgmt/airport/pkg-plist4
5 files changed, 40 insertions, 4 deletions
diff --git a/net-mgmt/airport/Makefile b/net-mgmt/airport/Makefile
index ffb6585bcfa9..a2d95bb05364 100644
--- a/net-mgmt/airport/Makefile
+++ b/net-mgmt/airport/Makefile
@@ -7,10 +7,12 @@
PORTNAME= airport
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net java
MASTER_SITES= http://edge.mcs.drexel.edu/GICL/people/sevy/airport/
-DISTFILES= configurator_${PORTVERSION:S/.//}${EXTRACT_SUFX}
+DISTFILES= configurator_${PORTVERSION:S/.//}${EXTRACT_SUFX} \
+ link_monitor_${LINKMONVERSION:S/.//}${EXTRACT_SUFX} \
+ host_monitor_${HOSTMONVERSION:S/.//}${EXTRACT_SUFX}
MAINTAINER= nsayer@freebsd.org
@@ -18,12 +20,16 @@ RUN_DEPENDS= ${LOCALBASE}/jdk${JDK_VERSION}/bin/java:${PORTSDIR}/java/jdk \
${LOCALBASE}/share/java/classes/jfc-${JFC_VERSION}/swingall.jar:${PORTSDIR}/java/jfc \
${LOCALBASE}/bin/javavm:${PORTSDIR}/java/javavmwrapper
+EXTRACT_BEFORE_ARGS= -q -o
+
USE_ZIP= YES
NO_WRKSUBDIR= YES
JDK_VERSION= 1.1.8
JFC_VERSION= 1.1.1
+LINKMONVERSION= 1.1
+HOSTMONVERSION= 1.0
NO_BUILD= yes
@@ -43,5 +49,7 @@ do-install:
-e s/%%JDK_VERSION%%/${JDK_VERSION}/ \
< ${FILESDIR}/airport > ${PREFIX}/bin/airport; \
${CHMOD} a+x ${PREFIX}/bin/airport
+ ${LN} ${PREFIX}/bin/airport ${PREFIX}/bin/hostmon
+ ${LN} ${PREFIX}/bin/airport ${PREFIX}/bin/linkmon
.include <bsd.port.post.mk>
diff --git a/net-mgmt/airport/distinfo b/net-mgmt/airport/distinfo
index a2c24450b115..7c701666edf2 100644
--- a/net-mgmt/airport/distinfo
+++ b/net-mgmt/airport/distinfo
@@ -1 +1,3 @@
MD5 (configurator_14.zip) = b9dbbf78e7a69e358a0237def72cad32
+MD5 (link_monitor_11.zip) = e6837268e0edcdfd1566dec35b09deb7
+MD5 (host_monitor_10.zip) = 8f413a9a283c28d3e7ba461b79da1b45
diff --git a/net-mgmt/airport/files/airport b/net-mgmt/airport/files/airport
index 2ae406c629cb..5d0084f0287b 100644
--- a/net-mgmt/airport/files/airport
+++ b/net-mgmt/airport/files/airport
@@ -1,9 +1,27 @@
#! /bin/sh
+case $0 in
+ *airport)
+ class=AirportBaseStationConfigurator
+ file=AirportBaseStationConfigurator
+ ;;
+ *hostmon)
+ class=HostMonitor
+ file=HostMonitor
+ ;;
+ *linkmon)
+ class=LinkMonitor
+ file=LinkMonitor
+ ;;
+ *)
+ echo "Unknown command"
+ exit 1
+esac
+
# Use this one for JDK 1.2 and beyond:
-# exec %%PREFIX%%/bin/javavm -jar %%PREFIX%%/share/java/AirportBaseStationConfig.jar
+# exec %%PREFIX%%/bin/javavm -jar %%PREFIX%%/share/java/${file}.jar
# Use this one for the default installation -- JDK 1.1.x + JFC:
-exec %%PREFIX%%/bin/javavm -classpath "%%PREFIX%%/jdk%%JDK_VERSION%%/lib/classes.zip:%%PREFIX%%/share/java/classes/jfc-%%JFC_VERSION%%/swingall.jar:%%PREFIX%%/share/java/AirportBaseStationConfig.jar" AirportBaseStationConfigurator
+exec %%PREFIX%%/bin/javavm -classpath "%%PREFIX%%/jdk%%JDK_VERSION%%/lib/classes.zip:%%PREFIX%%/share/java/classes/jfc-%%JFC_VERSION%%/swingall.jar:%%PREFIX%%/share/java/${file}.jar" $class
exit 1
diff --git a/net-mgmt/airport/pkg-descr b/net-mgmt/airport/pkg-descr
index 42cc9b7a5ba3..d2ae916d0ff5 100644
--- a/net-mgmt/airport/pkg-descr
+++ b/net-mgmt/airport/pkg-descr
@@ -5,4 +5,8 @@ The Airport and Lucent RG-1000 are the same, except for one detail:
On the RG-1000 the net name cannot be changed and is overridden by
the hex number on the label on the bottom.
+This port also installs the Link Monitor and Host Monitor utilities.
+It doesn't install the modem utility because there's no version numbered
+distfile available.
+
WWW: http://edge.mcs.drexel.edu/GICL/people/sevy/airport/index.html
diff --git a/net-mgmt/airport/pkg-plist b/net-mgmt/airport/pkg-plist
index cbfeb33023f9..4f76b119a17f 100644
--- a/net-mgmt/airport/pkg-plist
+++ b/net-mgmt/airport/pkg-plist
@@ -1,5 +1,9 @@
bin/airport
+bin/hostmon
+bin/linkmon
share/java/AirportBaseStationConfig.jar
+share/java/HostMonitor.jar
+share/java/LinkMonitor.jar
share/doc/airport/AUTHORS
share/doc/airport/COPYING
share/doc/airport/helpdocs/ReadMe.txt