aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/alertmanager/Makefile
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2017-08-20 15:22:01 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2017-08-20 15:22:01 +0000
commit111cb50adfd7c66b2bad0a424c0282b653457b67 (patch)
tree578518d6c22b598ae97b69cec8cc968505ca0e28 /net-mgmt/alertmanager/Makefile
parent6ea747469e4df8e017cd1b48decc7df3b1ccbcce (diff)
downloadports-111cb50adfd7c66b2bad0a424c0282b653457b67.tar.gz
ports-111cb50adfd7c66b2bad0a424c0282b653457b67.zip
Notes
Diffstat (limited to 'net-mgmt/alertmanager/Makefile')
-rw-r--r--net-mgmt/alertmanager/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-mgmt/alertmanager/Makefile b/net-mgmt/alertmanager/Makefile
index 8898bd4875dd..6d1c68eb1247 100644
--- a/net-mgmt/alertmanager/Makefile
+++ b/net-mgmt/alertmanager/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= alertmanager
-PORTVERSION= 0.5.1
-PORTREVISION= 1
+PORTVERSION= 0.8.0
DISTVERSIONPREFIX= v
CATEGORIES= net-mgmt
@@ -11,6 +10,7 @@ MAINTAINER= michal@hanu.la
COMMENT= Alert routing for prometheus
LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
USES= go gmake
USE_GITHUB= yes
@@ -24,13 +24,16 @@ USERS= alertmanager
GROUPS= alertmanager
PLIST_FILES= bin/alertmanager \
+ bin/amtool \
etc/alertmanager/alertmanager.yml.sample
do-build:
(cd ${GO_WRKSRC}/cmd/alertmanager ; ${SETENV} ${GO_ENV} go install)
+ (cd ${GO_WRKSRC}/cmd/amtool ; ${SETENV} ${GO_ENV} go install)
do-install:
${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/alertmanager ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/amtool ${STAGEDIR}${PREFIX}/bin
${MKDIR} ${STAGEDIR}${PREFIX}/etc/alertmanager
${INSTALL_DATA} ${WRKSRC}/doc/examples/simple.yml ${STAGEDIR}${PREFIX}/etc/alertmanager/alertmanager.yml.sample