aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/annextools
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-14 22:19:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-14 22:19:04 +0000
commit9039c58ffb8b468fe3ab9fa0ae223fbb20c76375 (patch)
tree5c7dd442517a371f553efa48db0029eebea94679 /net-mgmt/annextools
parentdd4d840974cd0180cfa1dfcd272e05439b47a3bc (diff)
downloadports-9039c58ffb8b468fe3ab9fa0ae223fbb20c76375.tar.gz
ports-9039c58ffb8b468fe3ab9fa0ae223fbb20c76375.zip
Notes
Diffstat (limited to 'net-mgmt/annextools')
-rw-r--r--net-mgmt/annextools/Makefile8
-rw-r--r--net-mgmt/annextools/files/patch-erpcd::acp_policy.c10
-rw-r--r--net-mgmt/annextools/files/patch-erpcd::acp_tcp.c11
-rw-r--r--net-mgmt/annextools/files/patch-erpcd::acplint.c20
-rw-r--r--net-mgmt/annextools/files/patch-erpcd::ch_passwd.c21
-rw-r--r--net-mgmt/annextools/files/patch-erpcd::tms.c11
-rw-r--r--net-mgmt/annextools/files/patch-erpcd::tms_dbm.c18
-rw-r--r--net-mgmt/annextools/files/patch-libannex::socket_layer.c19
8 files changed, 109 insertions, 9 deletions
diff --git a/net-mgmt/annextools/Makefile b/net-mgmt/annextools/Makefile
index b096dae2f5ae..d048a1dd6971 100644
--- a/net-mgmt/annextools/Makefile
+++ b/net-mgmt/annextools/Makefile
@@ -5,21 +5,21 @@
# $FreeBSD$
#
-PORTNAME= annextools
+PORTNAME= annextools
PORTVERSION= 10.0
PORTREVISION= 0
-CATEGORIES= net-mgmt
+CATEGORIES= net-mgmt
MASTER_SITES= ftp://www142.nortelnetworks.com/pub/swcode/remacc/microannex_xl/
DISTNAME= R10.0B-R2.3
EXTRACT_SUFX= .tar.Z
DIST_SUBDIR= microannex_xl
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= BSD tools for the MicroAnnex-XL Terminal Server
WRKSRC= ${WRKDIR}/src
-EXTRACT_AFTER_ARGS= | ${TAR} -xf - src
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - src
post-extract:
${FIND} ${WRKDIR}/src -type d -exec ${CHMOD} u+w \{\} \;
diff --git a/net-mgmt/annextools/files/patch-erpcd::acp_policy.c b/net-mgmt/annextools/files/patch-erpcd::acp_policy.c
new file mode 100644
index 000000000000..8c1637926bcf
--- /dev/null
+++ b/net-mgmt/annextools/files/patch-erpcd::acp_policy.c
@@ -0,0 +1,10 @@
+--- erpcd/acp_policy.c.orig Thu Dec 14 13:12:21 2006
++++ erpcd/acp_policy.c Thu Dec 14 13:14:18 2006
+@@ -333,6 +333,7 @@
+ char *Pass, int prompt,
+ int max_retries, char *Message,
+ ARQ_PROFILE *opt_info));
++static int map_mask_to_code(int);
+
+ #ifdef _WIN32
+ int syslog( int pri, const char *format, ...);
diff --git a/net-mgmt/annextools/files/patch-erpcd::acp_tcp.c b/net-mgmt/annextools/files/patch-erpcd::acp_tcp.c
new file mode 100644
index 000000000000..0782a2627166
--- /dev/null
+++ b/net-mgmt/annextools/files/patch-erpcd::acp_tcp.c
@@ -0,0 +1,11 @@
+--- erpcd/acp_tcp.c.orig Thu Dec 14 13:16:58 2006
++++ erpcd/acp_tcp.c Thu Dec 14 13:17:32 2006
+@@ -139,7 +139,7 @@
+ #endif /* _WIN32 */
+
+ /* Forward Routine Declarations */
+-int type_of_req();
++static int type_of_req();
+ #define DOMAIN_DELIMIT '@'
+ #define TLD_DELIMIT '.'
+ #define REQ_TYPE_DROP 0
diff --git a/net-mgmt/annextools/files/patch-erpcd::acplint.c b/net-mgmt/annextools/files/patch-erpcd::acplint.c
new file mode 100644
index 000000000000..348911ad0d68
--- /dev/null
+++ b/net-mgmt/annextools/files/patch-erpcd::acplint.c
@@ -0,0 +1,20 @@
+--- erpcd/acplint.c.orig Thu Dec 14 13:27:34 2006
++++ erpcd/acplint.c Thu Dec 14 13:29:12 2006
+@@ -60,7 +60,8 @@
+ #endif
+
+ void uprof_dump();
+-
++static void usage();
++
+ char *err_text[] = {
+ "ACPU_ESUCCESS",
+ "ACPU_ESKIP",
+@@ -87,7 +88,6 @@
+ int opt, flags = 0;
+ Uprof uprof;
+ Access access;
+- static void usage();
+ struct environment_spec env, *env_p = &env;
+
+
diff --git a/net-mgmt/annextools/files/patch-erpcd::ch_passwd.c b/net-mgmt/annextools/files/patch-erpcd::ch_passwd.c
new file mode 100644
index 000000000000..e4daf66f1946
--- /dev/null
+++ b/net-mgmt/annextools/files/patch-erpcd::ch_passwd.c
@@ -0,0 +1,21 @@
+--- erpcd/ch_passwd.c.orig Mon Jul 21 19:51:16 1997
++++ erpcd/ch_passwd.c Thu Dec 14 13:40:15 2006
+@@ -65,6 +65,9 @@
+ #endif
+ #endif
+
++#include <stdlib.h>
++#include <string.h>
++
+ char *strcpy();
+ char *crypt();
+ char *getpass();
+@@ -87,6 +90,8 @@
+ static DBM *open_dbm();
+ static void unlock_database();
+ #endif
++
++static int matches_password(char *, char *);
+
+ static int
+ alldigits(str)
diff --git a/net-mgmt/annextools/files/patch-erpcd::tms.c b/net-mgmt/annextools/files/patch-erpcd::tms.c
new file mode 100644
index 000000000000..fc4a7ba337c4
--- /dev/null
+++ b/net-mgmt/annextools/files/patch-erpcd::tms.c
@@ -0,0 +1,11 @@
+--- erpcd/tms.c.orig Thu Dec 14 13:19:53 2006
++++ erpcd/tms.c Thu Dec 14 13:20:07 2006
+@@ -50,7 +50,7 @@
+ /*
+ * forwards
+ */
+-int tms_request();
++static int tms_request();
+ #define REQUEST_INIT 1
+ #define REQUEST_TERM 2
+
diff --git a/net-mgmt/annextools/files/patch-erpcd::tms_dbm.c b/net-mgmt/annextools/files/patch-erpcd::tms_dbm.c
new file mode 100644
index 000000000000..f93661baa0cd
--- /dev/null
+++ b/net-mgmt/annextools/files/patch-erpcd::tms_dbm.c
@@ -0,0 +1,18 @@
+--- erpcd/tms_dbm.c.orig Thu Dec 14 13:25:31 2006
++++ erpcd/tms_dbm.c Thu Dec 14 13:27:08 2006
+@@ -1505,13 +1505,14 @@
+ *
+ ************************************************************/
+
++static char ctoh();
++
+ static int
+ parse_addmod(argc, argv, adding)
+ int argc;
+ char **argv;
+ int adding;
+ {
+- char ctoh();
+ static char inv_val[] = "Invalid %s value \"%s\"\n";
+
+ static struct kw_entry {
diff --git a/net-mgmt/annextools/files/patch-libannex::socket_layer.c b/net-mgmt/annextools/files/patch-libannex::socket_layer.c
index 58f62727d159..39b6fb996089 100644
--- a/net-mgmt/annextools/files/patch-libannex::socket_layer.c
+++ b/net-mgmt/annextools/files/patch-libannex::socket_layer.c
@@ -1,5 +1,5 @@
---- libannex/socket_layer.c.orig Thu Aug 4 15:58:59 1994
-+++ libannex/socket_layer.c Thu Sep 18 20:10:32 2003
+--- libannex/socket_layer.c.orig Thu Aug 4 16:58:59 1994
++++ libannex/socket_layer.c Thu Dec 14 13:09:21 2006
@@ -74,6 +74,8 @@
#include <ctype.h>
#include <errno.h>
@@ -9,7 +9,16 @@
#include "../inc/config.h"
#include "../inc/slip/slip_user.h"
-@@ -189,7 +191,7 @@
+@@ -168,6 +170,8 @@
+ static struct sockinf *sockinf_bynumber();
+ static struct sockinf *sockinf_byport();
+
++static int trivial_alarm_handler(int);
++
+
+ struct protoent *GETPROTOBYNAME(name)
+ char *name;
+@@ -189,7 +193,7 @@
int protocol; /* IPPROTO_UDP only */
{
struct sockinf *s;
@@ -18,7 +27,7 @@
int i;
/* Check arguments */
-@@ -260,7 +262,7 @@
+@@ -260,7 +264,7 @@
{
struct sockinf *t, *u;
int port;
@@ -27,7 +36,7 @@
if(!(t = sockinf_bynumber(s, FALSE))) {
errno = EBADF;
-@@ -300,7 +302,7 @@
+@@ -300,7 +304,7 @@
{
struct sockinf *t, *u;
int port;