aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ap-utils
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-01 14:10:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-01 14:10:20 +0000
commit0e14ad63e894b0f120e139f7d54138456ec56f07 (patch)
tree2a2d16c50feec615fa0fb30b9dd5a5ec7ee30c51 /net-mgmt/ap-utils
parent2f9d1b9af377c7c79d74d1f0397bfa0142016b3c (diff)
downloadports-0e14ad63e894b0f120e139f7d54138456ec56f07.tar.gz
ports-0e14ad63e894b0f120e139f7d54138456ec56f07.zip
Notes
Diffstat (limited to 'net-mgmt/ap-utils')
-rw-r--r--net-mgmt/ap-utils/Makefile52
-rw-r--r--net-mgmt/ap-utils/distinfo3
-rw-r--r--net-mgmt/ap-utils/files/patch-aa10
-rw-r--r--net-mgmt/ap-utils/pkg-descr10
-rw-r--r--net-mgmt/ap-utils/pkg-plist14
5 files changed, 89 insertions, 0 deletions
diff --git a/net-mgmt/ap-utils/Makefile b/net-mgmt/ap-utils/Makefile
new file mode 100644
index 000000000000..289df01b81d6
--- /dev/null
+++ b/net-mgmt/ap-utils/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: ap-utils
+# Date created: 2002/07/10
+# Whom: Jerry A! <jerry@thehutt.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ap-utils
+PORTVERSION= 1.4.1
+PORTREVISION= 2
+CATEGORIES= net-mgmt
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A set of utilities to configure and monitor wireless access points
+
+DEPRECATED= Does not work with gcc4.2; appears to be abandoned
+EXPIRATION_DATE= 2008-04-07
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_BZIP2= yes
+CONFIGURE_ENV= LDFLAGS="-lintl -L${LOCALBASE}/lib"
+MAN8= ap-trapd.8 ap-mrtg.8 ap-config.8
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+BROKEN= Does not build without gettext
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|_nl_domain_bindings|libintl_nl_domain_bindings|' ${WRKSRC}/configure
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/Documentation && \
+ ${INSTALL_DATA} FAQ Ovislink-HOWTO.html HARDWARE-NOTES README.ap-gl ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/ap-utils/distinfo b/net-mgmt/ap-utils/distinfo
new file mode 100644
index 000000000000..90d9c3d05a3c
--- /dev/null
+++ b/net-mgmt/ap-utils/distinfo
@@ -0,0 +1,3 @@
+MD5 (ap-utils-1.4.1.tar.bz2) = 15b3ee8ae8f5e501ffa6dd8ced9c528d
+SHA256 (ap-utils-1.4.1.tar.bz2) = 2fc07e0603d745f169b686ddb5101b31942dc6aa0a2f994f2685e5e249ef0f26
+SIZE (ap-utils-1.4.1.tar.bz2) = 348746
diff --git a/net-mgmt/ap-utils/files/patch-aa b/net-mgmt/ap-utils/files/patch-aa
new file mode 100644
index 000000000000..905bb9385afa
--- /dev/null
+++ b/net-mgmt/ap-utils/files/patch-aa
@@ -0,0 +1,10 @@
+--- lib/ap_search.c.orig Tue May 4 11:18:09 2004
++++ lib/ap_search.c Fri Jul 30 22:29:37 2004
+@@ -34,6 +34,7 @@
+ #include <sys/socket.h>
+ #endif
+
++#include <sys/socket.h>
+ #include <net/if.h>
+ #include <sys/time.h>
+ #include <errno.h>
diff --git a/net-mgmt/ap-utils/pkg-descr b/net-mgmt/ap-utils/pkg-descr
new file mode 100644
index 000000000000..4328230240a2
--- /dev/null
+++ b/net-mgmt/ap-utils/pkg-descr
@@ -0,0 +1,10 @@
+A set of utilities to configure and monitor several popular
+wireless access points using SNMP. Among other things, they
+allow access restrictions, MAC authorization and WEP encryption
+for access points and "wireless gateways" by Linksys, Netgear,
+SMC, and D-Link.
+
+WWW: http://ap-utils.polesye.net/
+
+ -- Dan Pelleg
+daniel+aputils@pelleg.org
diff --git a/net-mgmt/ap-utils/pkg-plist b/net-mgmt/ap-utils/pkg-plist
new file mode 100644
index 000000000000..3964ed1dc7bc
--- /dev/null
+++ b/net-mgmt/ap-utils/pkg-plist
@@ -0,0 +1,14 @@
+bin/ap-config
+bin/ap-mrtg
+bin/ap-gl
+sbin/ap-trapd
+%%NLS%%share/locale/fr/LC_MESSAGES/ap-utils.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/ap-utils.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/ap-utils.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/ap-utils.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/ap-utils.mo
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/Ovislink-HOWTO.html
+%%PORTDOCS%%%%DOCSDIR%%/HARDWARE-NOTES
+%%PORTDOCS%%%%DOCSDIR%%/README.ap-gl
+%%PORTDOCS%%@dirrm %%DOCSDIR%%