aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/argus-monitor/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-12-01 16:02:07 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-12-01 16:02:07 +0000
commit6f70979b76a18244d54618146b5bc06d5a70cd19 (patch)
treef88d5b50a11d0ac537075ebe4bc8f851d5716f02 /net-mgmt/argus-monitor/Makefile
parent4aac1c43e00d6478a1286fba889b8df91dcd1836 (diff)
downloadports-6f70979b76a18244d54618146b5bc06d5a70cd19.tar.gz
ports-6f70979b76a18244d54618146b5bc06d5a70cd19.zip
Notes
Diffstat (limited to 'net-mgmt/argus-monitor/Makefile')
-rw-r--r--net-mgmt/argus-monitor/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-mgmt/argus-monitor/Makefile b/net-mgmt/argus-monitor/Makefile
new file mode 100644
index 000000000000..9cc3257d6489
--- /dev/null
+++ b/net-mgmt/argus-monitor/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: argus-monitor
+# Date created: 18 November 2006
+# Whom: brock@cotcomsol.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= argus-monitor
+PORTVERSION= 20060722
+CATEGORIES= net-mgmt
+MASTER_SITES= http://www.tcp4me.com/code/argus-archive/
+DISTNAME= argus-dev-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= brock@cotcomsol.com
+COMMENT= Argus - The All Seeing System and Network Monitoring Software
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+USE_PERL5= yes
+USE_RC_SUBR= argusd
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= Configure
+CONFIGURE_ARGS= --bin_dir=${PREFIX}/bin --sbin_dir=${PREFIX}/sbin \
+ --lib_dir=${PREFIX}/lib/argus-monitor --data_dir=${PREFIX}/etc/argus-monitor
+
+OPTIONS= QPAGE "qpage support" Off \
+ FPING "fping support" Off \
+ GD "GD graphics support" On
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_QPAGE)
+RUN_DEPENDS+= qpage:${PORTSDIR}/comms/qpage
+BUILD_DEPENDS+= qpage:${PORTSDIR}/comms/qpage
+.endif
+
+.if defined(WITH_FPING)
+RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
+BUILD_DEPENDS+= fping:${PORTSDIR}/net/fping
+.endif
+
+.if !defined(WITHOUT_GD)
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
+.endif
+
+.include <bsd.port.post.mk>