aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/argus3-clients/Makefile
diff options
context:
space:
mode:
authorJulien Laffaye <jlaffaye@FreeBSD.org>2011-06-16 16:53:21 +0000
committerJulien Laffaye <jlaffaye@FreeBSD.org>2011-06-16 16:53:21 +0000
commit8bb213a6682083f2e8f7e9b8f90148c171bb5054 (patch)
treef7231b36dd4ff3109478ba37208df98746c6b435 /net-mgmt/argus3-clients/Makefile
parent354b186247a7943e9eec0d566c8e946d74b22316 (diff)
downloadports-8bb213a6682083f2e8f7e9b8f90148c171bb5054.tar.gz
ports-8bb213a6682083f2e8f7e9b8f90148c171bb5054.zip
Notes
Diffstat (limited to 'net-mgmt/argus3-clients/Makefile')
-rw-r--r--net-mgmt/argus3-clients/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/net-mgmt/argus3-clients/Makefile b/net-mgmt/argus3-clients/Makefile
index 148f6e73a9a8..9bc394a659af 100644
--- a/net-mgmt/argus3-clients/Makefile
+++ b/net-mgmt/argus3-clients/Makefile
@@ -34,6 +34,9 @@ CONFIGURE_ARGS+= --with-sasl=${LOCALBASE}
.if defined(WITH_MYSQL)
USE_MYSQL= yes
+PLIST_SUB+= MYSQL=""
+.else
+PLIST_SUB+= MYSQL="@comment "
.endif
.if defined(WITH_GEOIP)
@@ -51,10 +54,15 @@ MAN8= radium.8
do-install:
.for i in ra rabins racluster racount radump rafilteraddr \
rahisto ralabel ranonymize rapath rapolicy \
- raservices rasort rasplit rasql rasqlinsert rastream \
+ raservices rasort rasplit rastream \
rastrip ratemplate ratimerange ratop ratree rauserdata
${INSTALL_PROGRAM} ${WRKSRC}/bin/$i ${PREFIX}/bin/$i
.endfor
+.if defined(WITH_MYSQL)
+.for i in rasql rasqlinsert
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/$i ${PREFIX}/bin/$i
+.endfor
+.endif
.for i in radark ragraph rahosts raports
${INSTALL_SCRIPT} ${WRKSRC}/bin/$i ${PREFIX}/bin/$i
.endfor