aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/argus3-clients
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2008-04-20 17:33:41 +0000
committerStefan Eßer <se@FreeBSD.org>2008-04-20 17:33:41 +0000
commit556f23dbc042051340895728c3542b4027ae8f26 (patch)
tree00938e2101dcd94b5d344e106990e815438e0576 /net-mgmt/argus3-clients
parentddfd9a7a564112e0fc1095b3b1b544e352294edb (diff)
downloadports-556f23dbc042051340895728c3542b4027ae8f26.tar.gz
ports-556f23dbc042051340895728c3542b4027ae8f26.zip
Notes
Diffstat (limited to 'net-mgmt/argus3-clients')
-rw-r--r--net-mgmt/argus3-clients/Makefile76
-rw-r--r--net-mgmt/argus3-clients/distinfo3
-rw-r--r--net-mgmt/argus3-clients/files/patch-clients::Makefile.in11
-rw-r--r--net-mgmt/argus3-clients/files/patch-common::Makefile.in11
-rw-r--r--net-mgmt/argus3-clients/files/patch-common::argus_util.c12
-rw-r--r--net-mgmt/argus3-clients/files/patch-radium::Makefile.in11
-rw-r--r--net-mgmt/argus3-clients/files/patch-ragrep::Makefile.in11
-rw-r--r--net-mgmt/argus3-clients/files/patch-ratop::Makefile.in11
-rw-r--r--net-mgmt/argus3-clients/pkg-descr15
-rw-r--r--net-mgmt/argus3-clients/pkg-plist53
10 files changed, 214 insertions, 0 deletions
diff --git a/net-mgmt/argus3-clients/Makefile b/net-mgmt/argus3-clients/Makefile
new file mode 100644
index 000000000000..6380868115ac
--- /dev/null
+++ b/net-mgmt/argus3-clients/Makefile
@@ -0,0 +1,76 @@
+# New ports collection makefile for: argus3-clients
+# Date created: 24 March 2004
+# Whom: Stefan Esser <se@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= argus-clients
+PORTVERSION= 3.0.0
+CATEGORIES= net-mgmt security
+MASTER_SITES= http://qosient.com/argus/src/ \
+ ftp://qosient.com/pub/argus/src/
+
+MAINTAINER= se@freebsd.org
+COMMENT= Client programs for the argus IP network transaction auditing tool
+
+OPTIONS+= SASL "SASL authentication support 1" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SASL)
+PKGNAMESUFFIX= -sasl
+LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
+.endif
+
+USE_BISON= build
+GNU_CONFIGURE= true
+
+.if defined(WITH_SASL)
+CONFIGURE_ARGS+= --with-sasl=${PREFIX}
+.endif
+
+MAN1= ra.1 rabins.1 racluster.1 racount.1 ragraph.1 ragrep.1 rahisto.1 \
+ rasort.1 rasplit.1 rastrip.1
+MAN5= racluster.5 radium.conf.5 rarc.5
+MAN8= radium.8
+
+do-install:
+.for i in ra rabins racluster racount radump rafilteraddr \
+ ragrep rahisto ralabel ranonymize rapath rapolicy \
+ rasort rasplit rastream rastrip ratemplate \
+ ratimerange ratop ratree
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/$i ${PREFIX}/bin/$i
+.endfor
+.for i in argusbug radark ragraph rahosts raports
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/$i ${PREFIX}/bin/$i
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/
+.for i in README COPYING CREDITS doc/CHANGES doc/FAQ doc/HOW-TO
+ ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
+.endfor
+.endif
+.if !defined(NOMAN)
+.for i in ${MAN1}
+ ${INSTALL_DATA} ${WRKSRC}/man/man1/$i ${MANPREFIX}/man/man1
+.endfor
+.for i in ${MAN5}
+ ${INSTALL_DATA} ${WRKSRC}/man/man5/$i ${MANPREFIX}/man/man5
+.endfor
+.for i in ${MAN8}
+ ${INSTALL_DATA} ${WRKSRC}/man/man8/$i ${MANPREFIX}/man/man8
+.endfor
+.endif
+.for i in argus_client.a argus_common.a argus_parse.a
+ ${INSTALL_DATA} ${WRKSRC}/lib/$i ${PREFIX}/lib/$i
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/include/cons_def.h ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/include/cons_out.h ${PREFIX}/include
+ ${MKDIR} ${EXAMPLESDIR}
+.for i in Config Startup System
+ ${MKDIR} ${EXAMPLESDIR}/$i
+ ${INSTALL_DATA} ${WRKSRC}/support/$i/* ${EXAMPLESDIR}/$i
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/argus3-clients/distinfo b/net-mgmt/argus3-clients/distinfo
new file mode 100644
index 000000000000..8a7f60bbb5c9
--- /dev/null
+++ b/net-mgmt/argus3-clients/distinfo
@@ -0,0 +1,3 @@
+MD5 (argus-clients-3.0.0.tar.gz) = 69220c898c0a3ad612292eaecdec70d2
+SHA256 (argus-clients-3.0.0.tar.gz) = f3b5b37c69b0eb7f3bf561a25709900e295ee15de69000d4c7d165684ebe783d
+SIZE (argus-clients-3.0.0.tar.gz) = 1421803
diff --git a/net-mgmt/argus3-clients/files/patch-clients::Makefile.in b/net-mgmt/argus3-clients/files/patch-clients::Makefile.in
new file mode 100644
index 000000000000..c22136b2c923
--- /dev/null
+++ b/net-mgmt/argus3-clients/files/patch-clients::Makefile.in
@@ -0,0 +1,11 @@
+--- clients/Makefile.in~ 2008-02-05 04:37:43.000000000 +0100
++++ clients/Makefile.in 2008-02-07 11:32:41.576020693 +0100
+@@ -45,7 +45,7 @@
+
+ CC = @CC@
+ CCOPT = @V_CCOPT@
+-INCLS = -I. -I../include -I../common @V_INCLS@
++INCLS = -I. -I../include -I../common @V_INCLS@ @SASLFLAGS@
+ DEFS = @DEFS@
+ COMPATLIB = @COMPATLIB@ @LIB_SASL@ @LIBS@ @V_THREADS@
+
diff --git a/net-mgmt/argus3-clients/files/patch-common::Makefile.in b/net-mgmt/argus3-clients/files/patch-common::Makefile.in
new file mode 100644
index 000000000000..efb48995864d
--- /dev/null
+++ b/net-mgmt/argus3-clients/files/patch-common::Makefile.in
@@ -0,0 +1,11 @@
+--- common/Makefile.in~ 2008-02-05 04:37:43.000000000 +0100
++++ common/Makefile.in 2008-02-07 11:32:41.580020066 +0100
+@@ -40,7 +40,7 @@
+
+ CC = @CC@
+ CCOPT = @V_CCOPT@
+-INCLS = -I. -I../include @V_INCLS@ @MYSQL_INCLS@
++INCLS = -I. -I../include @V_INCLS@ @MYSQL_INCLS@ @SASLFLAGS@
+ DEFS = @DEFS@ -DARGUS_SYSLOG
+
+ # Standard CFLAGS
diff --git a/net-mgmt/argus3-clients/files/patch-common::argus_util.c b/net-mgmt/argus3-clients/files/patch-common::argus_util.c
new file mode 100644
index 000000000000..c9fe888242e7
--- /dev/null
+++ b/net-mgmt/argus3-clients/files/patch-common::argus_util.c
@@ -0,0 +1,12 @@
+--- common/argus_util.c~ 2008-02-05 04:37:43.000000000 +0100
++++ common/argus_util.c 2008-02-07 11:32:41.604018124 +0100
+@@ -100,6 +100,9 @@
+ #ifndef AF_INET6
+ #define AF_INET6 23
+ #endif
++#if defined(__FreeBSD__) /* should work for NetBSD too */
++#include <sys/limits.h>
++#endif
+
+
+ #ifndef INET6_ADDRSTRLEN
diff --git a/net-mgmt/argus3-clients/files/patch-radium::Makefile.in b/net-mgmt/argus3-clients/files/patch-radium::Makefile.in
new file mode 100644
index 000000000000..b4aff807f68e
--- /dev/null
+++ b/net-mgmt/argus3-clients/files/patch-radium::Makefile.in
@@ -0,0 +1,11 @@
+--- radium/Makefile.in~ 2008-02-05 04:37:43.000000000 +0100
++++ radium/Makefile.in 2008-02-07 11:32:41.610018616 +0100
+@@ -44,7 +44,7 @@
+
+ CC = @CC@
+ CCOPT = @V_CCOPT@
+-INCLS = -I. -I../include -I../common @V_INCLS@
++INCLS = -I. -I../include -I../common @V_INCLS@ @SASLFLAGS@
+ DEFS = @DEFS@
+ COMPATLIB = @COMPATLIB@ @LIB_SASL@ @LIBS@ @V_THREADS@
+
diff --git a/net-mgmt/argus3-clients/files/patch-ragrep::Makefile.in b/net-mgmt/argus3-clients/files/patch-ragrep::Makefile.in
new file mode 100644
index 000000000000..506373f80e02
--- /dev/null
+++ b/net-mgmt/argus3-clients/files/patch-ragrep::Makefile.in
@@ -0,0 +1,11 @@
+--- ragrep/Makefile.in~ 2008-02-05 04:37:43.000000000 +0100
++++ ragrep/Makefile.in 2008-02-07 11:32:41.614018339 +0100
+@@ -38,7 +38,7 @@
+
+ CC = @CC@
+ CCOPT = @V_CCOPT@
+-INCLS = -I$(srcdir) -I$(srcdir)/../include -I$(srcdir)/../common @V_INCLS@
++INCLS = -I$(srcdir) -I$(srcdir)/../include -I$(srcdir)/../common @V_INCLS@ @SASLFLAGS@
+ DEFS = @DEFS@
+ COMPATLIB = @COMPATLIB@ @LIB_SASL@ @LIBS@ @V_THREADS@
+
diff --git a/net-mgmt/argus3-clients/files/patch-ratop::Makefile.in b/net-mgmt/argus3-clients/files/patch-ratop::Makefile.in
new file mode 100644
index 000000000000..0b65b3223685
--- /dev/null
+++ b/net-mgmt/argus3-clients/files/patch-ratop::Makefile.in
@@ -0,0 +1,11 @@
+--- ratop/Makefile.in~ 2008-02-28 23:00:36.000000000 +0100
++++ ratop/Makefile.in 2008-04-18 12:03:41.737798597 +0200
+@@ -50,7 +50,7 @@
+
+ CC = @CC@
+ CCOPT = @V_CCOPT@
+-INCLS = @INCLS@ -I. -I../include -I../common @V_INCLS@
++INCLS = @INCLS@ -I. -I../include -I../common @V_INCLS@ @SASLFLAGS@
+ DEFS = @DEFS@
+ COMPATLIB = @LIBS@ @COMPATLIB@ @LIB_SASL@ @V_THREADS@
+ CURSESLIB = @CURSESLIB@
diff --git a/net-mgmt/argus3-clients/pkg-descr b/net-mgmt/argus3-clients/pkg-descr
new file mode 100644
index 000000000000..80e8053dee96
--- /dev/null
+++ b/net-mgmt/argus3-clients/pkg-descr
@@ -0,0 +1,15 @@
+Client programs that read, parse and process Argus data, and comprise
+the client part of the Audit Record Generation and Utilization System.
+
+Argus is a generic IP network transaction auditing tool that has been used
+by thousands of sites to perform a number of powerful network management
+tasks that are currently not possible using commercial network management
+tools.
+
+Argus runs as an application level daemon, promiscuously reading network
+datagrams from a specified interface, and generates network traffic audit
+records for the network activity that it encounters. It is the way that
+Argus categorizes and reports on network activity that makes this tool
+unique and powerful.
+
+WWW: http://www.qosient.com/argus/
diff --git a/net-mgmt/argus3-clients/pkg-plist b/net-mgmt/argus3-clients/pkg-plist
new file mode 100644
index 000000000000..abe12f0ae77e
--- /dev/null
+++ b/net-mgmt/argus3-clients/pkg-plist
@@ -0,0 +1,53 @@
+bin/argusbug
+bin/ra
+bin/rabins
+bin/racluster
+bin/racount
+bin/radark
+bin/radump
+bin/rafilteraddr
+bin/ragraph
+bin/ragrep
+bin/rahisto
+bin/rahosts
+bin/ralabel
+bin/ranonymize
+bin/rapath
+bin/rapolicy
+bin/raports
+bin/rasort
+bin/rasplit
+bin/rastream
+bin/rastrip
+bin/ratemplate
+bin/ratimerange
+bin/ratop
+bin/ratree
+include/cons_def.h
+include/cons_out.h
+lib/argus_client.a
+lib/argus_common.a
+lib/argus_parse.a
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/CREDITS
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/HOW-TO
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%EXAMPLESDIR%%/Config/delegated-ipv4-latest
+%%EXAMPLESDIR%%/Config/excel.rc
+%%EXAMPLESDIR%%/Config/ra.print.all.conf
+%%EXAMPLESDIR%%/Config/racluster.conf
+%%EXAMPLESDIR%%/Config/radium.conf
+%%EXAMPLESDIR%%/Config/ragetcountrycodes.sh
+%%EXAMPLESDIR%%/Config/ranonymize.conf
+%%EXAMPLESDIR%%/Config/rarc
+%%EXAMPLESDIR%%/Config/rastream.sh
+%%EXAMPLESDIR%%/Startup/radium
+%%EXAMPLESDIR%%/System/magic
+%%EXAMPLESDIR%%/System/protocols
+@dirrm %%EXAMPLESDIR%%/System
+@dirrm %%EXAMPLESDIR%%/Startup
+@dirrm %%EXAMPLESDIR%%/Config
+@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%