aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/argus3/Makefile
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2008-04-20 17:24:09 +0000
committerStefan Eßer <se@FreeBSD.org>2008-04-20 17:24:09 +0000
commit2066612ac72227369a38bc44da787488791ceb5a (patch)
tree1f9a8ea72733834275e6db732c3528c4e68014cb /net-mgmt/argus3/Makefile
parente866d4fe980de544dd9e24763bd54dfffd26ec49 (diff)
downloadports-2066612ac72227369a38bc44da787488791ceb5a.tar.gz
ports-2066612ac72227369a38bc44da787488791ceb5a.zip
Notes
Diffstat (limited to 'net-mgmt/argus3/Makefile')
-rw-r--r--net-mgmt/argus3/Makefile69
1 files changed, 69 insertions, 0 deletions
diff --git a/net-mgmt/argus3/Makefile b/net-mgmt/argus3/Makefile
new file mode 100644
index 000000000000..bb56cac5bfa1
--- /dev/null
+++ b/net-mgmt/argus3/Makefile
@@ -0,0 +1,69 @@
+# New ports collection makefile for: argus3
+# Date created: 08 Jul 2006
+# Whom: Stefan Esser <se@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= argus
+PORTVERSION= 3.0.0
+CATEGORIES= net-mgmt security
+MASTER_SITES= http://qosient.com/argus/src/ \
+ ftp://qosient.com/pub/argus/src/
+
+MAINTAINER= se@freebsd.org
+COMMENT= A generic IP network transaction auditing tool
+
+#RUN_DEPENDS= ${LOCALBASE}/bin/ragrep:${PORTSDIR}/net-mgmt/argus3-clients
+
+OPTIONS+= SASL "SASL authentication support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SASL)
+PKGNAMESUFFIX= -sasl
+LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
+.endif
+
+USE_BISON= build
+GNU_CONFIGURE= true
+.if defined(WITH_SASL)
+CONFIGURE_ARGS+= --with-sasl=${PREFIX}
+.endif
+
+MAN5= argus.conf.5
+MAN8= argus.8
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/argus ${PREFIX}/sbin/argus
+# ${INSTALL_SCRIPT} ${WRKSRC}/bin/argusbug ${PREFIX}/bin/argusbug
+ ${MKDIR} ${EXAMPLESDIR}/Archive ${EXAMPLESDIR}/Config \
+ ${EXAMPLESDIR}/Deployment ${EXAMPLESDIR}/Startup \
+ ${EXAMPLESDIR}/System
+.for i in README \
+ Archive/argusarchive \
+ Config/argus.conf \
+ Deployment/sample \
+ Startup/argus Startup/README \
+ System/crontab System/magic
+ ${INSTALL_DATA} ${WRKSRC}/support/$i ${EXAMPLESDIR}/$i
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/
+.for i in FAQ HOW-TO
+ ${INSTALL_DATA} ${WRKSRC}/doc/$i ${DOCSDIR}/
+.endfor
+.endif
+.if !defined(NOMAN)
+#.for i in ${MAN1}
+# ${INSTALL_DATA} ${WRKSRC}/man/man1/$i ${MANPREFIX}/man/man1
+#.endfor
+.for i in ${MAN5}
+ ${INSTALL_DATA} ${WRKSRC}/man/man5/$i ${MANPREFIX}/man/man5
+.endfor
+.for i in ${MAN8}
+ ${INSTALL_DATA} ${WRKSRC}/man/man8/$i ${MANPREFIX}/man/man8
+.endfor
+.endif
+
+.include <bsd.port.post.mk>