aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/argus3
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2013-01-05 07:52:19 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2013-01-05 07:52:19 +0000
commitf40e13cbaa2229d9c73bfbb3042839d1b81f560f (patch)
tree153900adb6d10f2ab01a02d1aa4539c4317891f9 /net-mgmt/argus3
parentc8e8f2480f66291ec5bb59c1de95e842c9f3bf39 (diff)
downloadports-f40e13cbaa2229d9c73bfbb3042839d1b81f560f.tar.gz
ports-f40e13cbaa2229d9c73bfbb3042839d1b81f560f.zip
Notes
Diffstat (limited to 'net-mgmt/argus3')
-rw-r--r--net-mgmt/argus3/Makefile32
-rw-r--r--net-mgmt/argus3/distinfo4
-rw-r--r--net-mgmt/argus3/files/patch-Makefile.in13
-rw-r--r--net-mgmt/argus3/files/patch-common_Makefile.in11
-rw-r--r--net-mgmt/argus3/pkg-descr6
-rw-r--r--net-mgmt/argus3/pkg-plist21
6 files changed, 32 insertions, 55 deletions
diff --git a/net-mgmt/argus3/Makefile b/net-mgmt/argus3/Makefile
index 48194c97be87..b3fff6aa68e7 100644
--- a/net-mgmt/argus3/Makefile
+++ b/net-mgmt/argus3/Makefile
@@ -1,24 +1,21 @@
-# New ports collection makefile for: argus3
-# Date created: 08 Jul 2006
-# Whom: Stefan Esser <se@FreeBSD.org>
-#
+# Created by: Stefan Esser <se@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= argus
-PORTVERSION= 3.0.4
-PORTREVISION= 1
+PORTVERSION= 3.0.6.1
CATEGORIES= net-mgmt security
MASTER_SITES= http://qosient.com/argus/src/ \
ftp://qosient.com/pub/argus/src/
MAINTAINER= pauls@utdallas.edu
-COMMENT= A generic IP network transaction auditing tool
+COMMENT= Generic IP network transaction auditing tool
+
+LICENSE= GPLv3
CONFLICTS= argus-2* argus-sasl-2* argus-clients-2*
-OPTIONS_DEFINE= SASL
-OPTIONS_DEFAULT= SASL
+OPTIONS_DEFINE= SASL MANPAGES
+OPTIONS_DEFAULT=SASL MANPAGES
USE_RC_SUBR= argus
@@ -26,9 +23,10 @@ USE_RC_SUBR= argus
USE_BISON= build
GNU_CONFIGURE= true
+USE_PERL5= yes
.if ${PORT_OPTIONS:MSASL}
-PKGNAMESUFFIX= -sasl
+PKGNAMESUFFIX+= -sasl
LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
CONFIGURE_ARGS+= --with-sasl=${LOCALBASE}
.endif
@@ -36,14 +34,14 @@ CONFIGURE_ARGS+= --with-sasl=${LOCALBASE}
MAN5= argus.conf.5
MAN8= argus.8
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's#/usr/lib/sasl2#${LOCALBASE}/lib/sasl2#' ${WRKSRC}/argus/ArgusOutput.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/argus ${PREFIX}/sbin/argus
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/argusbug ${PREFIX}/bin/argusbug
+.for i in argus-lsof argus-snmp argus-vmstat argusbug
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/$i ${PREFIX}/bin/$i
+.endfor
${MKDIR} ${EXAMPLESDIR}/Archive ${EXAMPLESDIR}/Config \
${EXAMPLESDIR}/Deployment ${EXAMPLESDIR}/Startup \
${EXAMPLESDIR}/System
@@ -55,13 +53,13 @@ do-install:
System/crontab System/magic
${INSTALL_DATA} ${WRKSRC}/support/$i ${EXAMPLESDIR}/$i
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}/
.for i in README
${INSTALL_DATA} ${WRKSRC}/doc/$i ${DOCSDIR}/
.endfor
.endif
-.if !defined(NOMAN)
+.if ${PORT_OPTIONS:MMANPAGES}
.for i in ${MAN5}
${INSTALL_DATA} ${WRKSRC}/man/man5/$i ${MANPREFIX}/man/man5
.endfor
@@ -70,4 +68,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/argus3/distinfo b/net-mgmt/argus3/distinfo
index 0fbad5fd0a8f..d86b2467bf1d 100644
--- a/net-mgmt/argus3/distinfo
+++ b/net-mgmt/argus3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (argus-3.0.4.tar.gz) = ff8582da63ff9fca807505ba7359bc58628b20e827afb93a08f706dd5b86bb52
-SIZE (argus-3.0.4.tar.gz) = 476702
+SHA256 (argus-3.0.6.1.tar.gz) = ed991d8e12394a4f3d49adf007f82bafe615de4fd836f88c86d97fe7469cad12
+SIZE (argus-3.0.6.1.tar.gz) = 847095
diff --git a/net-mgmt/argus3/files/patch-Makefile.in b/net-mgmt/argus3/files/patch-Makefile.in
deleted file mode 100644
index dff9eb96ea4d..000000000000
--- a/net-mgmt/argus3/files/patch-Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.in~ 2008-02-05 04:37:42.000000000 +0100
-+++ Makefile.in 2008-02-07 10:37:29.349769845 +0100
-@@ -27,8 +27,9 @@
- INSTALL_DATA = @INSTALL_DATA@
-
- DEFS = @DEFS@
--LIBS = @LIBS@
-+LIBS = @LIB_SASL@ @LIBS@
- WRAPLIBS = @WRAPLIBS@
-+CPPFLAGS = @SASLFLAGS@
-
- prefix = @prefix@
- exec_prefix = @exec_prefix@
diff --git a/net-mgmt/argus3/files/patch-common_Makefile.in b/net-mgmt/argus3/files/patch-common_Makefile.in
deleted file mode 100644
index 9a8bbb91a3bf..000000000000
--- a/net-mgmt/argus3/files/patch-common_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- common/Makefile.in.old 2011-06-06 14:35:23.000000000 +0400
-+++ common/Makefile.in 2011-06-06 14:36:20.000000000 +0400
-@@ -35,7 +35,7 @@
-
- CC = @CC@
- CCOPT = @V_CCOPT@
--INCLS = -I$(srcdir) @V_INCLS@ -I$(srcdir)/../include -I$(srcdir)/../argus
-+INCLS = -I$(srcdir) @V_INCLS@ -I$(srcdir)/../include -I$(srcdir)/../argus @SASLFLAGS@
- DEFS = @DEFS@
-
- # Standard CFLAGS
diff --git a/net-mgmt/argus3/pkg-descr b/net-mgmt/argus3/pkg-descr
index afc582b1d8f7..b1ce10f02058 100644
--- a/net-mgmt/argus3/pkg-descr
+++ b/net-mgmt/argus3/pkg-descr
@@ -1,6 +1,6 @@
-Argus is a generic IP network transaction auditing tool that has been used
-by thousands of sites to perform a number of powerful network management
-tasks that are currently not possible using commercial network management
+Argus is a generic IP network transaction auditing tool that has been used
+by thousands of sites to perform a number of powerful network management
+tasks that are currently not possible using commercial network management
tools.
Argus runs as an application level daemon, promiscuously reading network
diff --git a/net-mgmt/argus3/pkg-plist b/net-mgmt/argus3/pkg-plist
index 964ed7bfa54e..d5d9fede0601 100644
--- a/net-mgmt/argus3/pkg-plist
+++ b/net-mgmt/argus3/pkg-plist
@@ -1,18 +1,21 @@
+bin/argus-lsof
+bin/argus-snmp
+bin/argus-vmstat
bin/argusbug
sbin/argus
%%PORTDOCS%%%%DOCSDIR%%/README
%%EXAMPLESDIR%%/Archive/argusarchive
%%EXAMPLESDIR%%/Config/argus.conf
%%EXAMPLESDIR%%/Deployment/sample
-%%EXAMPLESDIR%%/Startup/argus
+%%EXAMPLESDIR%%/README
%%EXAMPLESDIR%%/Startup/README
+%%EXAMPLESDIR%%/Startup/argus
%%EXAMPLESDIR%%/System/crontab
%%EXAMPLESDIR%%/System/magic
-%%EXAMPLESDIR%%/README
-@dirrmtry %%EXAMPLESDIR%%/Archive
-@dirrmtry %%EXAMPLESDIR%%/Config
-@dirrmtry %%EXAMPLESDIR%%/Deployment
-@dirrmtry %%EXAMPLESDIR%%/Startup
-@dirrmtry %%EXAMPLESDIR%%/System
-@dirrmtry %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%EXAMPLESDIR%%/System
+@dirrm %%EXAMPLESDIR%%/Startup
+@dirrm %%EXAMPLESDIR%%/Deployment
+@dirrm %%EXAMPLESDIR%%/Config
+@dirrm %%EXAMPLESDIR%%/Archive
+@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%