aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/arpscan
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2012-10-18 01:42:54 +0000
committerJason E. Hale <jhale@FreeBSD.org>2012-10-18 01:42:54 +0000
commit234783d5173e1c50bfbf446914b2156a2a90f340 (patch)
tree0e36da45ce25820bca86066aff71e69bf3bb793a /net-mgmt/arpscan
parentab445445439d3c8ec0c735eb5f4ad1d6e2b6fc06 (diff)
downloadports-234783d5173e1c50bfbf446914b2156a2a90f340.tar.gz
ports-234783d5173e1c50bfbf446914b2156a2a90f340.zip
Notes
Diffstat (limited to 'net-mgmt/arpscan')
-rw-r--r--net-mgmt/arpscan/Makefile13
-rw-r--r--net-mgmt/arpscan/distinfo4
-rw-r--r--net-mgmt/arpscan/files/patch-arpscan.c35
3 files changed, 8 insertions, 44 deletions
diff --git a/net-mgmt/arpscan/Makefile b/net-mgmt/arpscan/Makefile
index 39f75b7119b4..8af6a1efedee 100644
--- a/net-mgmt/arpscan/Makefile
+++ b/net-mgmt/arpscan/Makefile
@@ -1,19 +1,18 @@
-# New ports collection makefile for: arpscan
-# Date created: 22 Mar 2004
-# Whom: David Yeske <dyeske@gmail.com>
-#
+# Created by: David Yeske <dyeske@gmail.com>
# $FreeBSD$
-#
PORTNAME= arpscan
-PORTVERSION= 0.3
+PORTVERSION= 0.5
CATEGORIES= net-mgmt
MASTER_SITES= GOOGLE_CODE
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple arp scanner
-LIB_DEPENDS= dnet.1:${PORTSDIR}/net/libdnet
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= dnet:${PORTSDIR}/net/libdnet
GNU_CONFIGURE= yes
CONFIGURE_ARGS=--with-libdnet=${LOCALBASE}
diff --git a/net-mgmt/arpscan/distinfo b/net-mgmt/arpscan/distinfo
index 17592a7f5b48..629b721e697c 100644
--- a/net-mgmt/arpscan/distinfo
+++ b/net-mgmt/arpscan/distinfo
@@ -1,2 +1,2 @@
-SHA256 (arpscan-0.3.tar.gz) = 27a2bf1e3b4bf28b976b7e7da26d01ce99d9dc227fd174989dbfa6f164a573f4
-SIZE (arpscan-0.3.tar.gz) = 58052
+SHA256 (arpscan-0.5.tar.gz) = d2561c82a07d88a20aac38e228cf7965e296dcfc3f82d60d9e7f23940255c187
+SIZE (arpscan-0.5.tar.gz) = 75501
diff --git a/net-mgmt/arpscan/files/patch-arpscan.c b/net-mgmt/arpscan/files/patch-arpscan.c
deleted file mode 100644
index ee400d55ef44..000000000000
--- a/net-mgmt/arpscan/files/patch-arpscan.c
+++ /dev/null
@@ -1,35 +0,0 @@
---- arpscan.c.orig Wed Aug 2 08:31:32 2006
-+++ arpscan.c Sun Sep 24 04:31:06 2006
-@@ -9,7 +9,9 @@
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
-+#include <err.h>
- #include <stdio.h>
-+#include <stdlib.h>
- #include <string.h>
- #include <unistd.h>
- #include <fcntl.h>
-@@ -22,6 +24,13 @@
- #include <dnet.h>
- #endif /* DUMBNET */
-
-+#ifdef __FreeBSD__
-+# include <sys/param.h>
-+# if __FreeBSD_version > 500000
-+# define NTOHL(x) (x) = ntohl((u_int32_t)(x))
-+# endif
-+#endif
-+
- /* A concatenation of dnet's arp_hdr and arp_ethip. */
- struct ether_arp {
- struct arp_hdr arp_hdr;
-@@ -45,7 +54,7 @@
- fprintf(stderr, "\teg)\n");
- fprintf(stderr, "\t %s 172.16.1.11\n", __progname);
- fprintf(stderr, "\t %s 192.168.1.100-192.168.1.200\n", __progname);
-- fprintf(stderr, "\t %s 172.16.1.41/29\n");
-+ fprintf(stderr, "\t %s 172.16.1.41/29\n", __progname);
- fprintf(stderr, "\n");
- exit(1);
- }