aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/arpwatch-devel
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-30 09:11:56 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-30 09:11:56 +0000
commit6cdda55cf06a791de2c9c84313a4f478b0f3e613 (patch)
tree3bf0c347a9c81a7266a6fe078a80ddc9349397fe /net-mgmt/arpwatch-devel
parentd1a216dc1f615cdeb49fc779ca0762d8c7f7cf79 (diff)
downloadports-6cdda55cf06a791de2c9c84313a4f478b0f3e613.tar.gz
ports-6cdda55cf06a791de2c9c84313a4f478b0f3e613.zip
Notes
Diffstat (limited to 'net-mgmt/arpwatch-devel')
-rw-r--r--net-mgmt/arpwatch-devel/Makefile1
-rw-r--r--net-mgmt/arpwatch-devel/files/patch-ai10
-rw-r--r--net-mgmt/arpwatch-devel/files/patch-an6
3 files changed, 9 insertions, 8 deletions
diff --git a/net-mgmt/arpwatch-devel/Makefile b/net-mgmt/arpwatch-devel/Makefile
index 8890cbe9853f..58a9e2cfe7fa 100644
--- a/net-mgmt/arpwatch-devel/Makefile
+++ b/net-mgmt/arpwatch-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= arpwatch
PORTVERSION= 2.1.a11
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://www.Awfulhak.org/arpwatch/ \
ftp://ftp.ee.lbl.gov/
diff --git a/net-mgmt/arpwatch-devel/files/patch-ai b/net-mgmt/arpwatch-devel/files/patch-ai
index ae8c0ec29881..e22dcf9e63f6 100644
--- a/net-mgmt/arpwatch-devel/files/patch-ai
+++ b/net-mgmt/arpwatch-devel/files/patch-ai
@@ -1,5 +1,5 @@
---- ../arpwatch.orig/db.c Sat Sep 30 19:39:58 2000
-+++ ./db.c Mon Sep 15 13:17:07 2003
+--- db.c.orig Sat Sep 30 19:39:58 2000
++++ db.c Mon Mar 29 14:26:14 2004
@@ -41,6 +41,7 @@
#include <string.h>
#include <syslog.h>
@@ -58,7 +58,7 @@
register u_int len;
u_char *e2;
time_t t2;
-+ register evt_type event = NULL;
++ register evt_type event = 0;
+ char *if2 = NULL;
+
+ pthread_mutex_lock(&mtx_einfo);
@@ -81,7 +81,7 @@
+ strncpy(ep->iface, interface, sizeof(ep->iface));
+ event |= ETHER_NEW;
+ e2 = NULL;
-+ t2 = NULL;
++ t2 = 0;
+ }
+ } else if (! initializing) {
+ if (strncmp(ep->iface, interface, sizeof(ep->iface)) != 0) {
@@ -127,7 +127,7 @@
+ ap->elist[0] = elist_alloc(a, e, t, h, interface);
+ event |= IP_NEW;
+ e2 = NULL;
-+ t2 = NULL;
++ t2 = 0;
}
/* Check for a flip-flop */
diff --git a/net-mgmt/arpwatch-devel/files/patch-an b/net-mgmt/arpwatch-devel/files/patch-an
index b994a7fee532..623d34853af5 100644
--- a/net-mgmt/arpwatch-devel/files/patch-an
+++ b/net-mgmt/arpwatch-devel/files/patch-an
@@ -1,5 +1,5 @@
---- ../arpwatch.orig/report.c Sat Sep 30 19:41:10 2000
-+++ ./report.c Fri Sep 12 18:57:04 2003
+--- report.c.orig Sat Sep 30 19:41:10 2000
++++ report.c Mon Mar 29 14:24:36 2004
@@ -45,6 +45,8 @@
#include <ctype.h>
@@ -45,7 +45,7 @@
+ /* these types are sent to syslog instead of reported on.
+ * only continue if there are other events as well
+ */
-+ if (event == NULL || (event & ~(IP_ETHER_REUSE | FLIPFLOP_DECNET) == 0))
++ if (event == 0 || (event & ~(IP_ETHER_REUSE | FLIPFLOP_DECNET) == 0))
+ return;
+
if (debug) {