aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/asused
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-07-28 17:03:09 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-07-28 17:03:09 +0000
commit08021bd518f9decff1345985afd6dc42bf0b35cd (patch)
treeffa512c9af1c6c4881d29a227c8613cf6f9b7320 /net-mgmt/asused
parent3b690d6f5748f8ce8f0c38b04c54dfb8bfacadd9 (diff)
downloadports-08021bd518f9decff1345985afd6dc42bf0b35cd.tar.gz
ports-08021bd518f9decff1345985afd6dc42bf0b35cd.zip
Notes
Diffstat (limited to 'net-mgmt/asused')
-rw-r--r--net-mgmt/asused/Makefile41
-rw-r--r--net-mgmt/asused/distinfo3
-rw-r--r--net-mgmt/asused/pkg-descr5
-rw-r--r--net-mgmt/asused/pkg-plist22
4 files changed, 71 insertions, 0 deletions
diff --git a/net-mgmt/asused/Makefile b/net-mgmt/asused/Makefile
new file mode 100644
index 000000000000..fb5fce165b24
--- /dev/null
+++ b/net-mgmt/asused/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: asused
+# Date created: 2006-07-19
+# Whom: Babak Farrokhi <babak@farrokhi.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= asused
+PORTVERSION= 3.72
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= ftp://ftp.ripe.net/tools/ \
+ http://ftp.belnet.be/pub/mirror/ftp.ripe.net/ripe/tools/
+DISTNAME= ${PORTNAME}-${PORTVERSION}_whois_new_query_fix
+
+MAINTAINER= babak@farrokhi.net
+COMMENT= Command-line tool to run a check on the usage of the RIPE Whois DB
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN1= asused.1
+MAN3= ArinWhois.3 NCC::CountryCode.3 NCC::RipeDelegations.3 \
+ Net::RIPEWhois::in.3 Reg::Asused.3 RipeWhois.3 Whois.3 asused.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|asused\.conf|${PREFIX}/etc/asused\.conf|g' \
+ ${WRKSRC}/asused.PL
+
+post-install:
+ @${INSTALL_DATA} ${WRKSRC}/asused.conf ${PREFIX}/etc/asused.conf.dist
+.if !exists(${PREFIX}/etc/asused.conf)
+ @${INSTALL_DATA} ${WRKSRC}/asused.conf ${PREFIX}/etc/asused.conf
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/asused/distinfo b/net-mgmt/asused/distinfo
new file mode 100644
index 000000000000..1e4f6e69be31
--- /dev/null
+++ b/net-mgmt/asused/distinfo
@@ -0,0 +1,3 @@
+MD5 (asused-3.72_whois_new_query_fix.tar.gz) = 133dba98ecc836897c8a53846d9d2463
+SHA256 (asused-3.72_whois_new_query_fix.tar.gz) = 2407a12ba44a75abed0fad335a85b92de4bebcd5c48dedac81926357843c7375
+SIZE (asused-3.72_whois_new_query_fix.tar.gz) = 104421
diff --git a/net-mgmt/asused/pkg-descr b/net-mgmt/asused/pkg-descr
new file mode 100644
index 000000000000..a0e884561604
--- /dev/null
+++ b/net-mgmt/asused/pkg-descr
@@ -0,0 +1,5 @@
+Asused is a tool to check and summarise address space registered in the RIPE
+database. For a given list of allocations the tool prints various information
+concerning the allocations and the assignments they contain.
+
+WWW: http://www.ripe.net/tools/
diff --git a/net-mgmt/asused/pkg-plist b/net-mgmt/asused/pkg-plist
new file mode 100644
index 000000000000..1f2f42043ffc
--- /dev/null
+++ b/net-mgmt/asused/pkg-plist
@@ -0,0 +1,22 @@
+bin/asused
+bin/cwhois
+@unexec if cmp -s %D/etc/asused.conf %D/etc/asused.conf.dist; then rm -f %D/etc/asused.conf; fi
+etc/asused.conf.dist
+@exec [ -f %B/asused.conf ] || cp %B/%f %B/asused.conf
+%%SITE_PERL%%/ArinWhois.pm
+%%SITE_PERL%%/NCC/CountryCode.pm
+%%SITE_PERL%%/NCC/RipeDelegations.pm
+%%SITE_PERL%%/Net/RIPEWhois/in.pm
+%%SITE_PERL%%/Reg/Asused.pm
+%%SITE_PERL%%/RipeWhois.pm
+%%SITE_PERL%%/RipeWhois/FormatMode.pm
+%%SITE_PERL%%/Whois.pm
+%%SITE_PERL%%/asused.pod
+%%SITE_PERL%%/ipv4pack.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/asused/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/asused
+@dirrm %%SITE_PERL%%/RipeWhois
+@dirrm %%SITE_PERL%%/Reg
+@dirrm %%SITE_PERL%%/Net/RIPEWhois
+@dirrmtry %%SITE_PERL%%/Net
+@dirrm %%SITE_PERL%%/NCC