aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/bpft/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-01-15 08:25:17 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-01-15 08:25:17 +0000
commit1720395be1d9dcce5c50a07faf0f9c11b7c7d77b (patch)
tree0363ea02bedd55cf2664fcf92476ed440fcbd9cb /net-mgmt/bpft/Makefile
parent5c110cd44dbf527f486a853df340948500d5f853 (diff)
downloadports-1720395be1d9dcce5c50a07faf0f9c11b7c7d77b.tar.gz
ports-1720395be1d9dcce5c50a07faf0f9c11b7c7d77b.zip
Notes
Diffstat (limited to 'net-mgmt/bpft/Makefile')
-rw-r--r--net-mgmt/bpft/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/net-mgmt/bpft/Makefile b/net-mgmt/bpft/Makefile
index 4bdf5f4cea9f..8305815b4d20 100644
--- a/net-mgmt/bpft/Makefile
+++ b/net-mgmt/bpft/Makefile
@@ -21,11 +21,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_JOBS_UNSAFE= yes
-MANCOMPRESSED= yes
-MAN1= traflog.1 trafstat.1
-MAN8= trafstatd.8 trafd.8
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -33,20 +28,23 @@ post-patch:
's|/usr/local|${PREFIX}|g' ${WRKSRC}/include/pathnames.h
@${REINPLACE_CMD} -e \
'/^PATH_TOSAVE/s|=.*|= ${PREFIX}/var/bpft| ; \
- /^INSTALL_DIRECTORY/s|=.*|= ${MKDIR}|' ${WRKSRC}/Makefile
+ /^INSTALL_DIRECTORY/s|=.*|= ${MKDIR}| ; \
+ s|please!|&"| ; \
+ s| $${PATH_| $${DESTDIR}$${PATH_|g ; \
+ s| $${PREFIX_| $${DESTDIR}$${PREFIX_|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e \
+ 's|bpf_dump.[co]||' ${WRKSRC}/lib/Makefile
@${REINPLACE_CMD} -e \
's|<net/slip.h>|"../linux-include/net/slip.h"|' \
${WRKSRC}/lib/interfaces.c
post-install:
.for i in bin/traflog bin/trafstat sbin/trafd sbin/trafstatd
- @${STRIP_CMD} ${PREFIX}/${i}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/${i}
.endfor
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in README WhatsNew
- (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${DOCSDIR})
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
.endfor
-.endif
.include <bsd.port.mk>