aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/braa/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-06-02 16:14:30 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-06-02 16:14:30 +0000
commit67d827c92d2ae4a1b300c637a36713f88486edad (patch)
treeb58bdf6de14e914223574fe7b5062d0d98315eca /net-mgmt/braa/Makefile
parentba490fd4b8c7afd4979e6533d26895f6a64bdc72 (diff)
downloadports-67d827c92d2ae4a1b300c637a36713f88486edad.tar.gz
ports-67d827c92d2ae4a1b300c637a36713f88486edad.zip
Notes
Diffstat (limited to 'net-mgmt/braa/Makefile')
-rw-r--r--net-mgmt/braa/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-mgmt/braa/Makefile b/net-mgmt/braa/Makefile
new file mode 100644
index 000000000000..a27733f46ecb
--- /dev/null
+++ b/net-mgmt/braa/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: braa
+# Date created: 31.05.2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= braa
+PORTVERSION= 0.3
+CATEGORIES= net
+MASTER_SITES= http://s-tech.elsat.net.pl/braa/
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= Tool for making SNMP queries
+
+LIB_DEPENDS= netsnmp.5:${PORTSDIR}/net/net-snmp
+
+USE_REINPLACE= yes
+
+post-patch:
+.for file in Makefile
+ @${REINPLACE_CMD} -e \
+ 's|CFLAGS =|CFLAGS?=${CFLAGS}|g ; \
+ s|LDFLAGS =|LDFLAGS?=${LDFLAGS}|g ; \
+ s|gcc|${CC}|g ; \
+ s|strip $$(OUT)||g' ${WRKSRC}/${file}
+.endfor
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} \
+ ${PREFIX}/bin/
+
+post-install:
+.for i in ${PORTNAME}
+ ${STRIP_CMD} ${PREFIX}/bin/${i}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>