aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/cdpr
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2003-11-19 17:20:34 +0000
committerMichael Landin <mich@FreeBSD.org>2003-11-19 17:20:34 +0000
commit30f370ac848653df21fe5072d0df956b5ee74535 (patch)
treebda8bcbf769c1e90abf2adea2f77398f5c1adef6 /net-mgmt/cdpr
parenta4faf7b41e0fad374ec1b5ae92c04da3c418441d (diff)
downloadports-30f370ac848653df21fe5072d0df956b5ee74535.tar.gz
ports-30f370ac848653df21fe5072d0df956b5ee74535.zip
Notes
Diffstat (limited to 'net-mgmt/cdpr')
-rw-r--r--net-mgmt/cdpr/Makefile6
-rw-r--r--net-mgmt/cdpr/distinfo2
-rw-r--r--net-mgmt/cdpr/files/patch-aa46
-rw-r--r--net-mgmt/cdpr/pkg-plist9
4 files changed, 49 insertions, 14 deletions
diff --git a/net-mgmt/cdpr/Makefile b/net-mgmt/cdpr/Makefile
index f5302126bcc4..8f8617eb4f87 100644
--- a/net-mgmt/cdpr/Makefile
+++ b/net-mgmt/cdpr/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= cdpr
-PORTVERSION= 2.0.0
+PORTVERSION= 2.1.0
CATEGORIES= net
MASTER_SITES= http://www.monkeymental.com/mmfiles/
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -25,9 +25,13 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/cdprs/* ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/cdpr.conf ${DATADIR}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
+ ${INSTALL_DATA} ${WRKSRC}/README.cdprs ${DOCSDIR}/README.cdprs
.endif
.include <bsd.port.mk>
diff --git a/net-mgmt/cdpr/distinfo b/net-mgmt/cdpr/distinfo
index e68629607965..184be0cf7098 100644
--- a/net-mgmt/cdpr/distinfo
+++ b/net-mgmt/cdpr/distinfo
@@ -1 +1 @@
-MD5 (cdpr-2.0.0.tar.gz) = 22d9bca09fb8188aa2b97640f0120343
+MD5 (cdpr-2.1.0.tar.gz) = a6fa309bd64d63d00658acaad63c3da0
diff --git a/net-mgmt/cdpr/files/patch-aa b/net-mgmt/cdpr/files/patch-aa
index 13728e24b06c..8c591de71e7e 100644
--- a/net-mgmt/cdpr/files/patch-aa
+++ b/net-mgmt/cdpr/files/patch-aa
@@ -1,10 +1,36 @@
---- conffile.c.orig Fri Jun 27 16:38:56 2003
-+++ conffile.c Fri Jun 27 16:37:14 2003
-@@ -6,6 +6,7 @@
- #if WIN32
- #include "Winsock2.h"
- #else
-+#include "sys/types.h"
- #include "sys/socket.h"
- #include "netinet/in.h"
- #include "arpa/inet.h"
+--- cdpr.c.orig Wed Nov 19 17:53:13 2003
++++ cdpr.c Wed Nov 19 17:54:06 2003
+@@ -639,7 +639,7 @@
+ pcap_lookupnet(dev, &net, &mask, errbuf);
+
+ /* Open the pcap device */
+- if((handle = pcap_open_live(dev, BUFSIZ, 1, 0, errbuf)) == NULL)
++ if((handle = pcap_open_live(dev, BUFSIZ, 1, 1000, errbuf)) == NULL)
+ {
+ printf("Error opening device (%s)\n", errbuf);
+ exit(1);
+@@ -656,11 +656,6 @@
+ pcap_setfilter(handle, &filter);
+ pcap_freecode(&filter);
+
+- /* Set non-blocking mode */
+- if(pcap_setnonblock(handle, 1, errbuf))
+- {
+- pcap_perror(handle, NULL);
+- }
+
+ /* Get the next packet that comes in, we only need one */
+ printf("Waiting for CDP advertisement:\n");
+@@ -671,11 +666,7 @@
+ do
+ {
+ packet = pcap_next(handle, &header);
+-#ifdef WIN32
+- Sleep(10000);
+-#else
+- usleep(10000);
+-#endif
++
+ } while ((!packet) && ( timeout=((start_time+seconds) > (unsigned int)time(NULL))) );
+
+ /*
diff --git a/net-mgmt/cdpr/pkg-plist b/net-mgmt/cdpr/pkg-plist
index f98fd8c268a2..79cb7e201903 100644
--- a/net-mgmt/cdpr/pkg-plist
+++ b/net-mgmt/cdpr/pkg-plist
@@ -1,3 +1,8 @@
bin/cdpr
-%%PORTDOCS%%share/doc/cdpr/README
-%%PORTDOCS%%@dirrm share/doc/cdpr
+%%PORTDOCS%%%%DATADIR%%/cdprs.php
+%%PORTDOCS%%%%DATADIR%%/cdprs.cgi
+%%PORTDOCS%%%%DATADIR%%/cdpr.conf
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.cdprs
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%DATADIR%%