aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/check_multi
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-10-25 14:37:47 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-10-25 14:37:47 +0000
commit21518d70b9219096bd7836d5e03b83001352755f (patch)
tree3dd93f3727347e3d637304798120a8d7de3a934f /net-mgmt/check_multi
parent6b3ba14ea213c98145a7cbf9a3a82e85e0060636 (diff)
downloadports-21518d70b9219096bd7836d5e03b83001352755f.tar.gz
ports-21518d70b9219096bd7836d5e03b83001352755f.zip
Notes
Diffstat (limited to 'net-mgmt/check_multi')
-rw-r--r--net-mgmt/check_multi/Makefile40
-rw-r--r--net-mgmt/check_multi/distinfo5
-rw-r--r--net-mgmt/check_multi/pkg-descr8
-rw-r--r--net-mgmt/check_multi/pkg-plist7
4 files changed, 30 insertions, 30 deletions
diff --git a/net-mgmt/check_multi/Makefile b/net-mgmt/check_multi/Makefile
index 3af7a7ffe11a..219d7430132a 100644
--- a/net-mgmt/check_multi/Makefile
+++ b/net-mgmt/check_multi/Makefile
@@ -1,33 +1,39 @@
# $FreeBSD$
PORTNAME= check_multi
-PORTVERSION= 0.19
+PORTVERSION= 0.26
CATEGORIES= net-mgmt
-#MASTER_SITES= http://my-plugin.de/${PORTNAME}/
-#PKGNAMEPREFIX= nagios-
-#DISTNAME= ${PORTNAME}-${PORTVERSION}.current
-MASTER_SITES= ftp://ftp.dinoex.de/pub/FreeBSD/distfiles/
MAINTAINER= ports@FreeBSD.org
COMMENT= Multi-purpose wrapper plugin for Nagios
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= shebangfix perl5 tar:tgz
-USE_PERL5= run
-NO_BUILD= yes
+USES= gmake perl5
+GNU_CONFIGURE= yes
+NO_ARCH= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-PLUGIN_DIR= libexec/nagios
+USE_GITHUB= yes
+GH_ACCOUNT= flackem
-SHEBANG_FILES= check_multi
+CONFIGURE_ARGS= --sysconfdir=${EXAMPLESDIR:H} \
+ --libexecdir=${PREFIX}/libexec/nagios
-OPTIONS_DEFINE= EXAMPLES
+INSTALL_TARGET= install
+TEST_TARGET= test
-do-install:
- -${MKDIR} ${STAGEDIR}${PREFIX}/${PLUGIN_DIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/check_multi ${STAGEDIR}${PREFIX}/${PLUGIN_DIR}/
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- @${TAR} -C ${WRKSRC}/contrib -cf - . | ${TAR} -C ${STAGEDIR}${EXAMPLESDIR} -xf -
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+EXAMPLES_INSTALL_TARGET= install-config
+
+PORTDOCS= Changelog README
+PORTEXAMPLES= *
+
+PLIST_FILES= libexec/nagios/check_multi
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/net-mgmt/check_multi/distinfo b/net-mgmt/check_multi/distinfo
index 80876db6fd2e..b1ec15b5c9e6 100644
--- a/net-mgmt/check_multi/distinfo
+++ b/net-mgmt/check_multi/distinfo
@@ -1,2 +1,3 @@
-SHA256 (check_multi-0.19.tgz) = beca8b28ffb0cdd95d786b3e36d9ce6f2fbd633063499303f8e8ea43cf82fe02
-SIZE (check_multi-0.19.tgz) = 27113
+TIMESTAMP = 1477404608
+SHA256 (flackem-check_multi-0.26_GH0.tar.gz) = f098755b2aadddeac943baabf7f076e7856f5d2d31d3a446d9cefdcc833bb7e6
+SIZE (flackem-check_multi-0.26_GH0.tar.gz) = 126723
diff --git a/net-mgmt/check_multi/pkg-descr b/net-mgmt/check_multi/pkg-descr
index dd15507bedc6..fcbb26ca2a97 100644
--- a/net-mgmt/check_multi/pkg-descr
+++ b/net-mgmt/check_multi/pkg-descr
@@ -2,8 +2,10 @@ check_multi is kind of a wrapper plugin which takes benefit of the
Nagios 3.x capability to display multiple lines of plugin output.
It calls multiple child plugins and displays their output in the
long_plugin_output. A summary is given in the standard plugin output.
-The child return code with the highest severity becomes the parent
-(check_multi) plugin return code.
+
+Normally the child return code with the highest severity becomes the
+parent (check_multi) plugin return code. But you can influence this
+by specifying flexible state evaluation rules.
The configuration is very simple: a NRPE-stylish config file contains
a tag for each child plugin and then the check command line.
@@ -12,6 +14,4 @@ check_multi can cover complex Business Process Views - using a builtin
state evaluation mechanism. The second benefit is cluster monitoring
with no need for extra services. All you need is provided by check_multi.
-LICENSE: GPL2 or later
-
WWW: http://www.my-plugin.de/wiki/projects/check_multi/start
diff --git a/net-mgmt/check_multi/pkg-plist b/net-mgmt/check_multi/pkg-plist
deleted file mode 100644
index c4e5d7dd73cd..000000000000
--- a/net-mgmt/check_multi/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-libexec/nagios/check_multi
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/check_multi.cmd
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cluster_example/download.cfg
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cluster_example/download.cmd
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cluster_example/download_my-plugin.cmd
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cluster_example/download_sourceforge.cmd
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notify_service_html