aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/circe/Makefile
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-03-15 19:26:26 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-03-15 19:26:26 +0000
commitc1fbcb6e9e0fe6795727e9c3fc07ee284503596d (patch)
tree5eb5022b415229cee960652a2fea75d0d3a2d42f /net-mgmt/circe/Makefile
parente7751f6a0378cfabcccb9f0c0f05fb4f84b6e8fb (diff)
downloadports-c1fbcb6e9e0fe6795727e9c3fc07ee284503596d.tar.gz
ports-c1fbcb6e9e0fe6795727e9c3fc07ee284503596d.zip
Notes
Diffstat (limited to 'net-mgmt/circe/Makefile')
-rw-r--r--net-mgmt/circe/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-mgmt/circe/Makefile b/net-mgmt/circe/Makefile
new file mode 100644
index 000000000000..e699feba9207
--- /dev/null
+++ b/net-mgmt/circe/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: circe
+# Date created: 23 July 2010
+# Whom: Berkeley NAC-Team
+#
+# $FreeBSD$
+#
+
+PORTNAME= circe
+PORTVERSION= 0.1.2
+CATEGORIES= net-mgmt
+MASTER_SITES= http://bws.berkeley.edu/ports/
+
+MAINTAINER= circe-port-maintainers@bws.berkeley.edu
+COMMENT= Code that implements a perl based circe captive portal system
+
+DIST_SUBDIR= ${PORTNAME}
+
+BUILD_DEPENDS= ${SITE_PERL}/mach/Net/IP/Match/XS.pm:${PORTSDIR}/net-mgmt/p5-Net-IP-Match-XS \
+ ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ ${SITE_PERL}/mach/IO.pm:${PORTSDIR}/devel/p5-IO \
+ ${SITE_PERL}/mach/IO/Interface.pm:${PORTSDIR}/net/p5-IO-Interface \
+ ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
+ ${SITE_PERL}/mach/Sys/Syslog.pm:${PORTSDIR}/sysutils/p5-Sys-Syslog \
+ ${SITE_PERL}/mach/TryCatch.pm:${PORTSDIR}/lang/p5-TryCatch
+
+MANCOMPRESSED= no
+
+WRKSRC= ${WRKDIR}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(SITE_PERL)|${SITE_PERL}|g' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>