aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/collectd5
diff options
context:
space:
mode:
authorJason Unovitch <junovitch@FreeBSD.org>2015-08-11 01:48:54 +0000
committerJason Unovitch <junovitch@FreeBSD.org>2015-08-11 01:48:54 +0000
commit4752da4e1e272f024366712124d9797cc353d0b1 (patch)
treec29f845a161fd3ace7917f4e630de69e3cb9bfb7 /net-mgmt/collectd5
parent236314df92c7c769343ffdaa613dbb1b2d1b59dc (diff)
downloadports-4752da4e1e272f024366712124d9797cc353d0b1.tar.gz
ports-4752da4e1e272f024366712124d9797cc353d0b1.zip
Notes
Diffstat (limited to 'net-mgmt/collectd5')
-rw-r--r--net-mgmt/collectd5/Makefile128
-rw-r--r--net-mgmt/collectd5/distinfo4
-rw-r--r--net-mgmt/collectd5/files/patch-Makefile.am10
-rw-r--r--net-mgmt/collectd5/files/patch-configure.ac14
-rw-r--r--net-mgmt/collectd5/files/patch-src-curl_xml.c11
-rw-r--r--net-mgmt/collectd5/files/patch-src__Makefile.am75
-rw-r--r--net-mgmt/collectd5/files/patch-src__Makefile.in11
-rw-r--r--net-mgmt/collectd5/files/patch-src__collectd.c11
-rw-r--r--net-mgmt/collectd5/files/patch-src__daemon__Makefile.am20
-rw-r--r--net-mgmt/collectd5/files/patch-src__daemon__collectd.h (renamed from net-mgmt/collectd5/files/patch-src__collectd.h)6
-rw-r--r--net-mgmt/collectd5/files/patch-src__disk.c12
-rw-r--r--net-mgmt/collectd5/files/patch-src__dns.c6
-rw-r--r--net-mgmt/collectd5/files/patch-src__modbus.c (renamed from net-mgmt/collectd5/files/patch-src_modbus.c)4
-rw-r--r--net-mgmt/collectd5/files/patch-src__users.c18
-rw-r--r--net-mgmt/collectd5/files/patch-version-gen.sh17
-rw-r--r--net-mgmt/collectd5/pkg-descr2
-rw-r--r--net-mgmt/collectd5/pkg-plist31
17 files changed, 228 insertions, 152 deletions
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index 98e9ece0c6d5..ca108cb51b0f 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= collectd
-PORTVERSION= 5.4.2
-PORTREVISION= 3
+PORTVERSION= 5.5.0
CATEGORIES= net-mgmt
-MASTER_SITES= http://collectd.org/files/
+MASTER_SITES= https://collectd.org/files/ \
+ http://collectd.org/files/
PKGNAMESUFFIX= 5
MAINTAINER= ports@bsdserwis.com
@@ -21,20 +21,22 @@ LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
USES= autoreconf gmake libtool pkgconfig shebangfix tar:bzip2
GNU_CONFIGURE= yes
-OPTIONS_DEFINE= CGI DEBUG GCRYPT VIRT
+OPTIONS_DEFINE= CGI DEBUG GCRYPT LOGSTASH VIRT
OPTIONS_GROUP= INPUT OUTPUT
OPTIONS_GROUP_OUTPUT= RRDTOOL NOTIFYEMAIL NOTIFYDESKTOP RIEMANN
-OPTIONS_GROUP_INPUT= CURL DBI JSON MEMCACHEC MODBUS MONGODB MYSQL \
- NUTUPS PERL PGSQL PING PYTHON RABBITMQ REDIS \
- ROUTEROS SIGROK SNMP STATGRAB TOKYOTYRANT VARNISH \
- XML XMMS
+OPTIONS_GROUP_INPUT= CURL DBI IPMI JSON MEMCACHEC MODBUS MONGODB MYSQL \
+ NUTUPS OLSRD ONEWIRE OPENLDAP PERL PGSQL PINBA PING \
+ PYTHON RABBITMQ REDIS ROUTEROS SIGROK SNMP STATGRAB \
+ STATSD TOKYOTYRANT VARNISH XML XMMS ZOOKEEPER
CGI_DESC= Install collection.cgi (requires rrdtool)
CURL_DESC= Enable curl-based plugins (apache, nginx, etc)
DEBUG_DESC= Enable debugging
DBI_DESC= Enable dbi plugin
GCRYPT_DESC= Build with libgcrypt
+IPMI_DESC= Enable OpenIPMI plugin
JSON_DESC= Enable JSON plugins
+LOGSTASH_DESC= Enable log_logstash plugin (requires json)
MEMCACHEC_DESC= Enable memcachec plugin
MODBUS_DESC= Enable modbus plugin
MONGODB_DESC= Enable MongoDB-based plugins
@@ -42,8 +44,12 @@ MYSQL_DESC= Enable mysql-based plugins
NOTIFYEMAIL_DESC= Enable notifications via email
NOTIFYDESKTOP_DESC= Enable desktop notifications
NUTUPS_DESC= Enable nut (ups) plugin
+OLSRD_DESC= Enable olsrd plugin
+ONEWIRE_DESC= Eanble onewire plugin (via owfs)
+OPENLDAP_DESC= Enable OpenLDAP plugin
PERL_DESC= Enable libperl plugin and binding
PGSQL_DESC= Enable postgresql-based plugins
+PINBA_DESC= Enable pinba plugin (via protobuf-c)
PING_DESC= Enable ping plugin
PYTHON_DESC= Enable python-based plugins
RABBITMQ_DESC= Enable rabbitmq-based plugins
@@ -54,11 +60,13 @@ RRDTOOL_DESC= Enable rrdtool plugin (also rrdcached plugin)
SIGROK_DESC= Enable sigrok plugin
SNMP_DESC= Enable SNMP plugin
STATGRAB_DESC= Enable statgrab-based plugins (disk, interface, etc)
+STATSD_DESC= Enable statsd plugin
TOKYOTYRANT_DESC= Enable tokyotyrant plugin
-VARNISH_DESC= Enable varnish 3.x cache statistics
+VARNISH_DESC= Enable varnish 4.x cache statistics
VIRT_DESC= Enable libvirt plugin (requires XML)
XML_DESC= Enable XML plugins
XMMS_DESC= Enable xmms plugin
+ZOOKEEPER_DESC= Enable zookeeper plugin
USE_RC_SUBR= collectd collectdmon
@@ -81,17 +89,22 @@ CONFIGURE_ARGS= --localstatedir=/var \
--without-libganglia \
--without-libiptc \
--without-libjvm \
+ --without-liblvm2app \
--without-libkstat \
+ --without-libldap \
+ --without-libmnl \
--without-libmodbus \
--without-libnetlink \
--without-libnetapp \
- --without-libopenipmi \
--without-libowcapi \
--without-libperfstat \
+ --without-librdkafka \
--without-libsensors \
+ --without-libvarnish \
--without-lvm \
--without-mic \
- --without-oracle
+ --without-oracle \
+ --disable-turbostat
# NOTE: Plugins without external dependencies
CONFIGURE_ARGS+= \
@@ -104,6 +117,7 @@ CONFIGURE_ARGS+= \
--enable-dns \
--enable-email \
--enable-exec \
+ --enable-fhcount \
--enable-filecount \
--enable-load \
--enable-logfile \
@@ -126,6 +140,7 @@ CONFIGURE_ARGS+= \
--enable-syslog \
--enable-table \
--enable-tail \
+ --enable-tail_csv \
--enable-target_notification \
--enable-target_replace \
--enable-target_scale \
@@ -139,7 +154,8 @@ CONFIGURE_ARGS+= \
--enable-uptime \
--enable-uuid \
--enable-write_graphite \
- --enable-zfs_arc
+ --enable-write_log \
+ --enable-zfs_arc \
.if ${PORT_OPTIONS:MCGI}
RUN_DEPENDS+= p5-URI>=0:${PORTSDIR}/net/p5-URI \
@@ -217,6 +233,15 @@ LIBS+= -lgcrypt
CONFIGURE_ARGS+=--without-libgcrypt
.endif
+.if ${PORT_OPTIONS:MIPMI}
+LIB_DEPENDS+= libOpenIPMI.so:${PORTSDIR}/sysutils/openipmi
+CONFIGURE_ARGS+=--enable-ipmi
+PLIST_SUB+= IPMI=""
+.else
+CONFIGURE_ARGS+=--disable-ipmi
+PLIST_SUB+= IPMI="@comment "
+.endif
+
.if ${PORT_OPTIONS:MJSON}
LIB_DEPENDS+= libyajl.so:${PORTSDIR}/devel/yajl
CONFIGURE_ARGS+=--with-libyajl=${LOCALBASE}
@@ -224,6 +249,16 @@ CONFIGURE_ARGS+=--with-libyajl=${LOCALBASE}
CONFIGURE_ARGS+=--without-libyajl
.endif
+.if ${PORT_OPTIONS:MLOGSTASH}
+CONFIGURE_ARGS+=--enable-log_logstash
+PLIST_SUB+= LOGSTASH=""
+.if empty(PORT_OPTIONS:MJSON)
+IGNORE= LOGSTASH requires JSON. Either select JSON or deselect LOGSTASH
+.endif
+.else
+PLIST_SUB+= LOGSTASH="@comment "
+.endif
+
.if ${PORT_OPTIONS:MMEMCACHEC}
LIB_DEPENDS+= libmemcached.so:${PORTSDIR}/databases/libmemcached
CONFIGURE_ARGS+=--with-libmemcached=${LOCALBASE} --enable-memcachec
@@ -235,7 +270,7 @@ PLIST_SUB+= MEMCACHEC="@comment "
.if ${PORT_OPTIONS:MMODBUS}
LIB_DEPENDS+= libmodbus.so:${PORTSDIR}/comms/libmodbus
-CONFIGURE_ARGS+=--enable-modbus
+CONFIGURE_ARGS+=--with-libmodbus=${LOCALBASE} --enable-modbus
PLIST_SUB+= MODBUS=""
.else
PLIST_SUB+= MODBUS="@comment "
@@ -290,6 +325,32 @@ CONFIGURE_ARGS+=--without-libupsclient --disable-nut
PLIST_SUB+= NUTUPS="@comment "
.endif
+.if ${PORT_OPTIONS:MOLSRD}
+CONFIGURE_ARGS+=--enable-olsrd
+PLIST_SUB+= OLSRD=""
+.else
+CONFIGURE_ARGS+=--enable-olsrd
+PLIST_SUB+= OLSRD="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MONEWIRE}
+LIB_DEPENDS+= libow.so:${PORTSDIR}/comms/owfs
+CONFIGURE_ARGS+=--with-libowcapi=${LOCALBASE} --enable-onewire
+PLIST_SUB+= ONEWIRE=""
+.else
+CONFIGURE_ARGS+=--disable-onewire
+PLIST_SUB+= ONEWIRE="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MOPENLDAP}
+USE_OPENLDAP= yes
+CONFIGURE_ARGS+=--with-libldap=${LOCALBASE} --enable-openldap
+PLIST_SUB+= OPENLDAP=""
+.else
+CONFIGURE_ARGS+=--disable-openldap
+PLIST_SUB+= OPENLDAP="@comment "
+.endif
+
.if ${PORT_OPTIONS:MPERL}
USES+= perl5
CONFIGURE_ARGS+=--with-perl=${PERL} --with-perl-bindings --enable-perl
@@ -308,6 +369,15 @@ CONFIGURE_ARGS+=--without-postgresql --disable-postgresql --without-libpq
PLIST_SUB+= PGSQL="@comment "
.endif
+.if ${PORT_OPTIONS:MPINBA}
+LIB_DEPENDS+= libprotobuf-c.so:${PORTSDIR}/devel/protobuf-c
+CONFIGURE_ARGS+=--enable-pinba
+PLIST_SUB+= PINBA=""
+.else
+CONFIGURE_ARGS+=--disable-pinba
+PLIST_SUB+= PINBA="@comment "
+.endif
+
.if ${PORT_OPTIONS:MPING}
LIB_DEPENDS+= liboping.so:${PORTSDIR}/net/liboping
CONFIGURE_ARGS+=--with-liboping=${LOCALBASE} --enable-ping
@@ -338,8 +408,8 @@ PLIST_SUB+= RABBITMQ="@comment "
.endif
.if ${PORT_OPTIONS:MREDIS}
-LIB_DEPENDS+= libcredis.so:${PORTSDIR}/databases/credis
-CONFIGURE_ARGS+=--with-libcredis=${LOCALBASE} \
+LIB_DEPENDS+= libhiredis.so:${PORTSDIR}/databases/hiredis
+CONFIGURE_ARGS+=--with-libhiredis=${LOCALBASE} \
--enable-redis \
--enable-write_redis
PLIST_SUB+= REDIS=""
@@ -382,7 +452,6 @@ PLIST_SUB+= RRDTOOL="@comment "
.endif
.if ${PORT_OPTIONS:MSTATGRAB}
-USES+= pkgconfig
LIB_DEPENDS+= libstatgrab.so:${PORTSDIR}/devel/libstatgrab
LIBS+= `pkg-config --libs libstatgrab`
CONFIGURE_ARGS+=--with-libstatgrab=${LOCALBASE} \
@@ -408,6 +477,7 @@ PLIST_SUB+= USERS="@comment "
USE_GNOME+= glib20
LIB_DEPENDS+= libsigrok.so:${PORTSDIR}/devel/libsigrok
CONFIGURE_ARGS+=--with-libsigrok --enable-sigrok
+CFLAGS+= `pkg-config --cflags glib-2.0`
PLIST_SUB+= SIGROK=""
.else
CONFIGURE_ARGS+=--disable-sigrok
@@ -423,6 +493,14 @@ CONFIGURE_ARGS+=--without-libnetsnmp
PLIST_SUB+= SNMP="@comment "
.endif
+.if ${PORT_OPTIONS:MSTATSD}
+CONFIGURE_ARGS+=--enable-statsd
+PLIST_SUB+= STATSD=""
+.else
+CONFIGURE_ARGS+=--disable-statsd
+PLIST_SUB+= STATSD="@comment "
+.endif
+
.if ${PORT_OPTIONS:MTOKYOTYRANT}
LIB_DEPENDS+= libtokyotyrant.so:${PORTSDIR}/databases/tokyotyrant
CONFIGURE_ARGS+=--with-libtokyotyrant=${LOCALBASE} --enable-tokyotyrant
@@ -433,7 +511,7 @@ PLIST_SUB+= TOKYOTYRANT="@comment "
.endif
.if ${PORT_OPTIONS:MVARNISH}
-LIB_DEPENDS+= libvarnishapi.so:${PORTSDIR}/www/varnish
+LIB_DEPENDS+= libvarnishapi.so:${PORTSDIR}/www/varnish4
CONFIGURE_ARGS+=--with-libvarnish=${LOCALBASE} --enable-varnish
PLIST_SUB+= VARNISH=""
.else
@@ -446,10 +524,10 @@ PLIST_SUB+= VARNISH="@comment "
IGNORE= VIRT requires XML. Either select XML or deselect VIRT.
.endif
LIB_DEPENDS+= libvirt.so:${PORTSDIR}/devel/libvirt
-CONFIGURE_ARGS+=--enable-libvirt
+CONFIGURE_ARGS+=--enable-virt
PLIST_SUB+= VIRT=""
.else
-CONFIGURE_ARGS+=--without-libvirt --disable-libvirt
+CONFIGURE_ARGS+=--without-virt --disable-virt
PLIST_SUB+= VIRT="@comment "
.endif
@@ -468,6 +546,15 @@ CONFIGURE_ARGS+=--without-libxmms --disable-xmms
PLIST_SUB+= XMMS="@comment "
.endif
+.if ${PORT_OPTIONS:MZOOKEEPER}
+LIB_DEPENDS+= libzookeeper_mt.so:${PORTSDIR}/devel/libzookeeper
+CONFIGURE_ARGS+=--with-libzookeeper=${LOCALBASE} --enable-zookeeper
+PLIST_SUB+= ZOOKEEPER=""
+.else
+CONFIGURE_ARGS+=--without-libzookeeper --disable-zookeeper
+PLIST_SUB+= ZOOKEEPER="@comment "
+.endif
+
INSTALL_TARGET=install-strip
SHEBANG_FILES= contrib/collection.cgi
@@ -479,7 +566,8 @@ post-patch:
-e 's;@prefix@/var/;/var/;' \
-e 's;/var/lib/;/var/db/;' \
-e 's;@localstatedir@/lib/;/var/db/;' \
- ${WRKSRC}/src/collectd.conf.in
+ ${WRKSRC}/src/collectd.conf.in \
+ ${WRKSRC}/src/collectd.conf.5
@${REINPLACE_CMD} \
-e 's;/etc/collection\.conf;${WWWDIR}/collection.conf;' \
${WRKSRC}/contrib/collection.cgi
diff --git a/net-mgmt/collectd5/distinfo b/net-mgmt/collectd5/distinfo
index f08e7e21025e..29104d600186 100644
--- a/net-mgmt/collectd5/distinfo
+++ b/net-mgmt/collectd5/distinfo
@@ -1,2 +1,2 @@
-SHA256 (collectd-5.4.2.tar.bz2) = 9789e900c138b5dbe907d3d744143f12b1e30022276cb1d8c65bbabaf0c4e393
-SIZE (collectd-5.4.2.tar.bz2) = 1633610
+SHA256 (collectd-5.5.0.tar.bz2) = 847684cf5c10de1dc34145078af3fcf6e0d168ba98c14f1343b1062a4b569e88
+SIZE (collectd-5.5.0.tar.bz2) = 1824495
diff --git a/net-mgmt/collectd5/files/patch-Makefile.am b/net-mgmt/collectd5/files/patch-Makefile.am
new file mode 100644
index 000000000000..8aa0dda630e3
--- /dev/null
+++ b/net-mgmt/collectd5/files/patch-Makefile.am
@@ -0,0 +1,10 @@
+--- Makefile.am.orig 2015-03-09 09:38:22 UTC
++++ Makefile.am
+@@ -8,7 +8,6 @@ EXTRA_DIST = contrib version-gen.sh
+
+ install-exec-hook:
+ $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run
+- $(mkinstalldirs) $(DESTDIR)$(localstatedir)/lib/$(PACKAGE_NAME)
+ $(mkinstalldirs) $(DESTDIR)$(localstatedir)/log
+
+ maintainer-clean-local:
diff --git a/net-mgmt/collectd5/files/patch-configure.ac b/net-mgmt/collectd5/files/patch-configure.ac
index 5f886afd1ae8..4d26a525dcfc 100644
--- a/net-mgmt/collectd5/files/patch-configure.ac
+++ b/net-mgmt/collectd5/files/patch-configure.ac
@@ -1,6 +1,6 @@
--- configure.ac.orig 2015-02-26 11:49:16 UTC
+++ configure.ac
-@@ -111,7 +111,7 @@ then
+@@ -120,7 +120,7 @@ then
fi
# Where to install .pc files.
@@ -9,7 +9,7 @@
AC_SUBST(pkgconfigdir)
# Check for standards compliance mode
-@@ -1440,6 +1440,7 @@ if test "x$with_kstat" = "xyes"
+@@ -1495,6 +1495,7 @@ if test "x$with_kstat" = "xyes"
then
AC_CHECK_LIB(kstat, kstat_open, [with_kstat="yes"], [with_kstat="no (libkstat not found)"], [])
fi
@@ -17,7 +17,7 @@
if test "x$with_kstat" = "xyes"
then
AC_CHECK_LIB(devinfo, di_init, [with_devinfo="yes"], [with_devinfo="no (not found)"], [])
-@@ -1449,6 +1450,8 @@ if test "x$with_kstat" = "xyes"
+@@ -1504,6 +1505,8 @@ if test "x$with_kstat" = "xyes"
then
AC_DEFINE(HAVE_LIBKSTAT, 1,
[Define to 1 if you have the 'kstat' library (-lkstat)])
@@ -26,7 +26,7 @@
fi
AM_CONDITIONAL(BUILD_WITH_LIBKSTAT, test "x$with_kstat" = "xyes")
AM_CONDITIONAL(BUILD_WITH_LIBDEVINFO, test "x$with_devinfo" = "xyes")
-@@ -3508,7 +3511,7 @@ fi
+@@ -3629,7 +3632,7 @@ fi
if test "x$with_python" = "xyes"
then
LDFLAGS="-L$python_library_path $LDFLAGS"
@@ -35,11 +35,13 @@
AC_CHECK_FUNC(PyObject_CallFunction,
[with_python="yes"],
-@@ -4415,7 +4418,7 @@ AC_ARG_WITH(libvarnish, [AS_HELP_STRING(
+@@ -4692,8 +4695,8 @@ AC_ARG_WITH(libvarnish, [AS_HELP_STRING(
+ else if test -d "$with_libvarnish/lib"
then
AC_MSG_NOTICE([Not checking for libvarnish: Manually configured])
- with_libvarnish_cflags="-I$withval/include"
+- with_libvarnish_cflags="-I$withval/include"
- with_libvarnish_libs="-L$withval/lib -lvarnishapi"
++ with_libvarnish_cflags="-I$withval/include/varnish"
+ with_libvarnish_libs="-L$withval/lib/varnish -lvarnishapi"
with_libvarnish="yes"
fi; fi; fi
diff --git a/net-mgmt/collectd5/files/patch-src-curl_xml.c b/net-mgmt/collectd5/files/patch-src-curl_xml.c
deleted file mode 100644
index 326b619ec786..000000000000
--- a/net-mgmt/collectd5/files/patch-src-curl_xml.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/curl_xml.c.orig 2015-03-28 23:25:34.546602000 +0300
-+++ src/curl_xml.c 2015-03-28 23:25:51.513304000 +0300
-@@ -385,7 +385,7 @@ static int cx_handle_instance_xpath (xml
- /* If the base xpath returns more than one block, the result is assumed to be
- * a table. The `Instance' option is not optional in this case. Check for the
- * condition and inform the user. */
-- if (is_table)
-+ if (is_table && (vl->type_instance == NULL))
- {
- WARNING ("curl_xml plugin: "
- "Base-XPath %s is a table (more than one result was returned), "
diff --git a/net-mgmt/collectd5/files/patch-src__Makefile.am b/net-mgmt/collectd5/files/patch-src__Makefile.am
index 858be48175ed..037b4a567666 100644
--- a/net-mgmt/collectd5/files/patch-src__Makefile.am
+++ b/net-mgmt/collectd5/files/patch-src__Makefile.am
@@ -1,7 +1,7 @@
---- src/Makefile.am.orig 2013-08-18 04:24:25.061973000 -0600
-+++ src/Makefile.am 2013-08-20 21:34:14.000000000 -0600
-@@ -10,7 +10,7 @@
- AM_CPPFLAGS = -DPREFIX='"${prefix}"'
+--- src/Makefile.am.orig 2015-05-26 19:38:14 UTC
++++ src/Makefile.am
+@@ -14,7 +14,7 @@ AM_CPPFLAGS = -I$(srcdir)/daemon
+ AM_CPPFLAGS += -DPREFIX='"${prefix}"'
AM_CPPFLAGS += -DCONFIGFILE='"${sysconfdir}/${PACKAGE_NAME}.conf"'
AM_CPPFLAGS += -DLOCALSTATEDIR='"${localstatedir}"'
-AM_CPPFLAGS += -DPKGLOCALSTATEDIR='"${localstatedir}/lib/${PACKAGE_NAME}"'
@@ -9,34 +9,25 @@
if BUILD_FEATURE_DAEMON
AM_CPPFLAGS += -DPIDFILE='"${localstatedir}/run/${PACKAGE_NAME}.pid"'
endif
-@@ -64,7 +64,7 @@
- collectd_LDADD += -lpthread
- endif
- if BUILD_WITH_LIBKSTAT
--collectd_LDADD += -lkstat
-+collectd_LDADD += $(BUILD_WITH_LIBKSTAT_LIBS)
- endif
- if BUILD_WITH_LIBDEVINFO
- collectd_LDADD += -ldevinfo
-@@ -275,7 +275,7 @@
- cpu_la_LDFLAGS = -module -avoid-version
- cpu_la_LIBADD =
+@@ -218,7 +218,7 @@ cpu_la_CFLAGS = $(AM_CFLAGS)
+ cpu_la_LDFLAGS = $(PLUGIN_LDFLAGS)
+ cpu_la_LIBADD =
if BUILD_WITH_LIBKSTAT
-cpu_la_LIBADD += -lkstat
+cpu_la_LIBADD += $(BUILD_WITH_LIBKSTAT_LIBS)
endif
if BUILD_WITH_LIBDEVINFO
cpu_la_LIBADD += -ldevinfo
-@@ -373,7 +373,7 @@
- disk_la_LDFLAGS = -module -avoid-version
- disk_la_LIBADD =
+@@ -303,7 +303,7 @@ disk_la_CFLAGS = $(AM_CFLAGS)
+ disk_la_LDFLAGS = $(PLUGIN_LDFLAGS)
+ disk_la_LIBADD =
if BUILD_WITH_LIBKSTAT
-disk_la_LIBADD += -lkstat
+disk_la_LIBADD += $(BUILD_WITH_LIBKSTAT_LIBS)
endif
if BUILD_WITH_LIBDEVINFO
disk_la_LIBADD += -ldevinfo
-@@ -480,7 +480,7 @@
+@@ -408,7 +408,7 @@ interface_la_CFLAGS += $(BUILD_WITH_LIBS
interface_la_LIBADD += $(BUILD_WITH_LIBSTATGRAB_LDFLAGS)
else
if BUILD_WITH_LIBKSTAT
@@ -45,44 +36,35 @@
endif
if BUILD_WITH_LIBDEVINFO
interface_la_LIBADD += -ldevinfo
-@@ -694,7 +694,7 @@
- collectd_LDADD += "-dlopen" memory.la
- collectd_DEPENDENCIES += memory.la
+@@ -591,7 +591,7 @@ memory_la_CFLAGS = $(AM_CFLAGS)
+ memory_la_LDFLAGS = $(PLUGIN_LDFLAGS)
+ memory_la_LIBADD =
if BUILD_WITH_LIBKSTAT
-memory_la_LIBADD += -lkstat
+memory_la_LIBADD += $(BUILD_WITH_LIBKSTAT_LIBS)
endif
if BUILD_WITH_LIBDEVINFO
memory_la_LIBADD += -ldevinfo
-@@ -823,7 +823,7 @@
- pkglib_LTLIBRARIES += notify_email.la
- notify_email_la_SOURCES = notify_email.c
- notify_email_la_LDFLAGS = -module -avoid-version
--notify_email_la_LIBADD = -lesmtp -lssl -lcrypto -lpthread -ldl
-+notify_email_la_LIBADD = -lesmtp -lssl -lcrypto -lpthread
- collectd_LDADD += "-dlopen" notify_email.la
- collectd_DEPENDENCIES += notify_email.la
- endif
-@@ -1108,7 +1108,7 @@
- collectd_LDADD += "-dlopen" swap.la
- collectd_DEPENDENCIES += swap.la
+@@ -964,7 +964,7 @@ swap_la_CFLAGS = $(AM_CFLAGS)
+ swap_la_LDFLAGS = $(PLUGIN_LDFLAGS)
+ swap_la_LIBADD =
if BUILD_WITH_LIBKSTAT
-swap_la_LIBADD += -lkstat
+swap_la_LIBADD += $(BUILD_WITH_LIBKSTAT_LIBS)
endif
if BUILD_WITH_LIBDEVINFO
swap_la_LIBADD += -ldevinfo
-@@ -1162,7 +1162,7 @@
+@@ -1010,7 +1010,7 @@ if BUILD_PLUGIN_TAPE
pkglib_LTLIBRARIES += tape.la
tape_la_SOURCES = tape.c
- tape_la_LDFLAGS = -module -avoid-version
+ tape_la_LDFLAGS = $(PLUGIN_LDFLAGS)
-tape_la_LIBADD = -lkstat -ldevinfo
+tape_la_LIBADD = $(BUILD_WITH_LIBKSTAT_LIBS) -ldevinfo
- collectd_LDADD += "-dlopen" tape.la
- collectd_DEPENDENCIES += tape.la
endif
-@@ -1285,7 +1285,7 @@
- uptime_la_LDFLAGS = -module -avoid-version
+
+ if BUILD_PLUGIN_TARGET_NOTIFICATION
+@@ -1116,7 +1116,7 @@ uptime_la_CFLAGS = $(AM_CFLAGS)
+ uptime_la_LDFLAGS = $(PLUGIN_LDFLAGS)
uptime_la_LIBADD =
if BUILD_WITH_LIBKSTAT
-uptime_la_LIBADD += -lkstat
@@ -90,7 +72,16 @@
endif
if BUILD_WITH_PERFSTAT
uptime_la_LIBADD += -lperfstat
-@@ -1519,12 +1519,7 @@
+@@ -1275,7 +1275,7 @@ if BUILD_LINUX
+ # zfs_arc requires no library on linux
+ else
+ # solaris
+-zfs_arc_la_LIBADD = -lkstat
++zfs_arc_la_LIBADD = $(BUILD_WITH_LIBKSTAT_LIBS)
+ endif
+ endif
+ endif
+@@ -1364,12 +1364,7 @@ endif
install-exec-hook:
$(mkinstalldirs) $(DESTDIR)$(sysconfdir)
diff --git a/net-mgmt/collectd5/files/patch-src__Makefile.in b/net-mgmt/collectd5/files/patch-src__Makefile.in
new file mode 100644
index 000000000000..f908020e24a5
--- /dev/null
+++ b/net-mgmt/collectd5/files/patch-src__Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig 2015-05-27 07:51:49.001922000 +0000
++++ src/Makefile.in
+@@ -2434,7 +2434,7 @@ PLUGIN_LDFLAGS = -module -avoid-version
+ AM_CPPFLAGS = -I$(srcdir)/daemon -DPREFIX='"${prefix}"' \
+ -DCONFIGFILE='"${sysconfdir}/${PACKAGE_NAME}.conf"' \
+ -DLOCALSTATEDIR='"${localstatedir}"' \
+- -DPKGLOCALSTATEDIR='"${localstatedir}/lib/${PACKAGE_NAME}"' \
++ -DPKGLOCALSTATEDIR='"${localstatedir}/db/${PACKAGE_NAME}"' \
+ $(am__append_2) -DPLUGINDIR='"${pkglibdir}"' \
+ -DPKGDATADIR='"${pkgdatadir}"'
+ AUTOMAKE_OPTIONS = subdir-objects
diff --git a/net-mgmt/collectd5/files/patch-src__collectd.c b/net-mgmt/collectd5/files/patch-src__collectd.c
deleted file mode 100644
index e5673fe52c19..000000000000
--- a/net-mgmt/collectd5/files/patch-src__collectd.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/collectd.c.orig 2014-01-26 08:09:14.840391000 +0000
-+++ ./src/collectd.c 2014-05-10 23:35:17.226683756 +0100
-@@ -288,7 +288,7 @@
- #endif
-
- #if HAVE_LIBSTATGRAB
-- if (sg_init ())
-+ if (sg_init (0))
- {
- ERROR ("sg_init: %s", sg_str_error (sg_get_error ()));
- return (-1);
diff --git a/net-mgmt/collectd5/files/patch-src__daemon__Makefile.am b/net-mgmt/collectd5/files/patch-src__daemon__Makefile.am
new file mode 100644
index 000000000000..eff70a85e9e3
--- /dev/null
+++ b/net-mgmt/collectd5/files/patch-src__daemon__Makefile.am
@@ -0,0 +1,20 @@
+--- src/daemon/Makefile.am.orig 2015-05-26 19:38:31 UTC
++++ src/daemon/Makefile.am
+@@ -6,7 +6,7 @@
+ AM_CPPFLAGS += -DPREFIX='"${prefix}"'
+ AM_CPPFLAGS += -DCONFIGFILE='"${sysconfdir}/${PACKAGE_NAME}.conf"'
+ AM_CPPFLAGS += -DLOCALSTATEDIR='"${localstatedir}"'
+-AM_CPPFLAGS += -DPKGLOCALSTATEDIR='"${localstatedir}/lib/${PACKAGE_NAME}"'
++AM_CPPFLAGS += -DPKGLOCALSTATEDIR='"${localstatedir}/db/${PACKAGE_NAME}"'
+ if BUILD_FEATURE_DAEMON
+ AM_CPPFLAGS += -DPIDFILE='"${localstatedir}/run/${PACKAGE_NAME}.pid"'
+ endif
+@@ -49,7 +49,7 @@ collectd_CPPFLAGS = $(AM_CPPFLAGS) $(LT
+ collectd_CFLAGS = $(AM_CFLAGS)
+ collectd_LDFLAGS = -export-dynamic
+ collectd_LDADD = libavltree.la libcommon.la libheap.la -lm
+-collectd_DEPENDENCIES =
++collectd_DEPENDENCIES = libavltree.la libcommon.la libheap.la
+
+ # Link to these libraries..
+ if BUILD_WITH_LIBRT
diff --git a/net-mgmt/collectd5/files/patch-src__collectd.h b/net-mgmt/collectd5/files/patch-src__daemon__collectd.h
index 07bb90b1902d..c56ea64007ca 100644
--- a/net-mgmt/collectd5/files/patch-src__collectd.h
+++ b/net-mgmt/collectd5/files/patch-src__daemon__collectd.h
@@ -1,6 +1,6 @@
---- ./src/collectd.h.orig 2013-01-27 13:47:18.246255000 +0000
-+++ ./src/collectd.h 2013-05-21 21:00:55.000000000 +0000
-@@ -235,15 +235,15 @@
+--- src/daemon/collectd.h.orig 2015-05-22 10:04:36 UTC
++++ src/daemon/collectd.h
+@@ -240,15 +240,15 @@ typedef int _Bool;
#endif
#ifndef LOCALSTATEDIR
diff --git a/net-mgmt/collectd5/files/patch-src__disk.c b/net-mgmt/collectd5/files/patch-src__disk.c
deleted file mode 100644
index c444d57b0fbf..000000000000
--- a/net-mgmt/collectd5/files/patch-src__disk.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./src/disk.c.orig 2014-01-26 08:09:14.856391000 +0000
-+++ ./src/disk.c 2014-05-10 23:35:17.232681397 +0100
-@@ -732,7 +732,8 @@
-
- #elif defined(HAVE_LIBSTATGRAB)
- sg_disk_io_stats *ds;
-- int disks, counter;
-+ size_t disks;
-+ int counter;
- char name[DATA_MAX_NAME_LEN];
-
- if ((ds = sg_get_disk_io_stats(&disks)) == NULL)
diff --git a/net-mgmt/collectd5/files/patch-src__dns.c b/net-mgmt/collectd5/files/patch-src__dns.c
index 84e0d2e65398..47183fed89d8 100644
--- a/net-mgmt/collectd5/files/patch-src__dns.c
+++ b/net-mgmt/collectd5/files/patch-src__dns.c
@@ -1,8 +1,6 @@
-diff --git src/dns.c src/dns.c
-index fe3b672..0c43985 100644
---- src/dns.c
+--- src/dns.c.orig 2015-03-10 14:14:45 UTC
+++ src/dns.c
-@@ -223,6 +223,15 @@ static void *dns_child_loop (__attribute__((unused)) void *dummy)
+@@ -224,6 +224,15 @@ static int dns_run_pcap_loop (void)
pthread_sigmask (SIG_SETMASK, &sigmask, NULL);
}
diff --git a/net-mgmt/collectd5/files/patch-src_modbus.c b/net-mgmt/collectd5/files/patch-src__modbus.c
index 8c5d9be78e45..3093a8db69c4 100644
--- a/net-mgmt/collectd5/files/patch-src_modbus.c
+++ b/net-mgmt/collectd5/files/patch-src__modbus.c
@@ -1,5 +1,5 @@
---- src/modbus.c.orig 2013-01-27 17:47:18.246255000 +0400
-+++ src/modbus.c 2013-05-14 18:40:05.000000000 +0400
+--- src/modbus.c.orig 2015-05-20 12:04:47 UTC
++++ src/modbus.c
@@ -25,6 +25,9 @@
#include "plugin.h"
#include "configfile.h"
diff --git a/net-mgmt/collectd5/files/patch-src__users.c b/net-mgmt/collectd5/files/patch-src__users.c
deleted file mode 100644
index c69d9d31a8bf..000000000000
--- a/net-mgmt/collectd5/files/patch-src__users.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./src/users.c.orig 2014-06-02 22:12:33.650261000 -0700
-+++ ./src/users.c 2014-06-11 00:10:39.000000000 -0700
-@@ -101,12 +101,13 @@
-
- #elif HAVE_LIBSTATGRAB
- sg_user_stats *us;
-+ size_t num_entries;
-
-- us = sg_get_user_stats ();
-+ us = sg_get_user_stats (&num_entries);
- if (us == NULL)
- return (-1);
-
-- users_submit ((gauge_t) us->num_entries);
-+ users_submit ((gauge_t) num_entries);
- /* #endif HAVE_LIBSTATGRAB */
-
- #else
diff --git a/net-mgmt/collectd5/files/patch-version-gen.sh b/net-mgmt/collectd5/files/patch-version-gen.sh
index f3dbdb780a70..221ee39b79ea 100644
--- a/net-mgmt/collectd5/files/patch-version-gen.sh
+++ b/net-mgmt/collectd5/files/patch-version-gen.sh
@@ -1,18 +1,17 @@
---- version-gen.sh.orig 2015-03-02 20:20:43 UTC
+--- version-gen.sh.orig 2015-05-26 20:23:28 UTC
+++ version-gen.sh
@@ -1,13 +1,3 @@
--#!/usr/bin/env bash
--
--DEFAULT_VERSION="5.4.2.git"
+ #!/bin/sh
+
+-DEFAULT_VERSION="5.5.0.git"
-
--VERSION="`git describe 2> /dev/null | sed -e 's/^collectd-//'`"
+-VERSION="`git describe 2> /dev/null | grep collectd | sed -e 's/^collectd-//'`"
-
-if test -z "$VERSION"; then
- VERSION="$DEFAULT_VERSION"
-fi
-
-VERSION="`echo \"$VERSION\" | sed -e 's/-/./g'`"
-+#!/bin/sh
-
--echo -n "$VERSION"
-+echo -n "5.4.2.git"
+-
+-printf "%s" "$VERSION"
++echo -n "5.5.0.git"
diff --git a/net-mgmt/collectd5/pkg-descr b/net-mgmt/collectd5/pkg-descr
index a591a0195caa..edc4500868e3 100644
--- a/net-mgmt/collectd5/pkg-descr
+++ b/net-mgmt/collectd5/pkg-descr
@@ -3,4 +3,4 @@ system & network statistics along with updating output RRD or CSV files.
The daemon is very fast and allows for frequent polling of values, with
support for polling as frequent as every 10 seconds.
-WWW: http://www.collectd.org/
+WWW: https://www.collectd.org/
diff --git a/net-mgmt/collectd5/pkg-plist b/net-mgmt/collectd5/pkg-plist
index 7b1eb03bd4d3..f44242112c6f 100644
--- a/net-mgmt/collectd5/pkg-plist
+++ b/net-mgmt/collectd5/pkg-plist
@@ -10,6 +10,9 @@ include/collectd/client.h
include/collectd/lcc_features.h
include/collectd/network.h
include/collectd/network_buffer.h
+lib/libcollectdclient.so
+lib/libcollectdclient.so.1
+lib/libcollectdclient.so.1.0.0
lib/collectd/aggregation.so
%%CURL%%lib/collectd/apache.so
lib/collectd/apcups.so
@@ -27,9 +30,12 @@ lib/collectd/df.so
lib/collectd/dns.so
lib/collectd/email.so
lib/collectd/exec.so
+lib/collectd/fhcount.so
lib/collectd/filecount.so
%%STATGRAB%%lib/collectd/interface.so
+%%IPMI%%lib/collectd/ipmi.so
lib/collectd/load.so
+%%LOGSTASH%%lib/collectd/log_logstash.so
lib/collectd/logfile.so
lib/collectd/match_empty_counter.so
lib/collectd/match_hashed.so
@@ -40,21 +46,24 @@ lib/collectd/mbmon.so
%%MEMCACHEC%%lib/collectd/memcachec.so
lib/collectd/memcached.so
lib/collectd/memory.so
+%%MODBUS%%lib/collectd/modbus.so
%%MYSQL%%lib/collectd/mysql.so
lib/collectd/network.so
%%CURL%%lib/collectd/nginx.so
-%%NOTIFYEMAIL%%lib/collectd/notify_email.so
%%NOTIFYDESKTOP%%lib/collectd/notify_desktop.so
+%%NOTIFYEMAIL%%lib/collectd/notify_email.so
lib/collectd/ntpd.so
%%NUTUPS%%lib/collectd/nut.so
+%%OLSRD%%lib/collectd/olsrd.so
+%%ONEWIRE%%lib/collectd/onewire.so
+%%OPENLDAP%%lib/collectd/openldap.so
lib/collectd/openvpn.so
%%PERL%%lib/collectd/perl.so
-%%PERL%%%%PERL5_MAN3%%/Collectd::Unixsock.3.gz
-%%PERL%%%%SITE_PERL%%/Collectd/Plugins/OpenVZ.pm
+lib/collectd/pf.so
+%%PINBA%%lib/collectd/pinba.so
%%PING%%lib/collectd/ping.so
%%PGSQL%%lib/collectd/postgresql.so
lib/collectd/powerdns.so
-lib/collectd/pf.so
lib/collectd/processes.so
%%PYTHON%%lib/collectd/python.so
%%REDIS%%lib/collectd/redis.so
@@ -63,11 +72,12 @@ lib/collectd/processes.so
%%RRDTOOL%%lib/collectd/rrdtool.so
%%SIGROK%%lib/collectd/sigrok.so
%%SNMP%%lib/collectd/snmp.so
-lib/collectd/statsd.so
+%%STATSD%%lib/collectd/statsd.so
lib/collectd/swap.so
lib/collectd/syslog.so
lib/collectd/table.so
lib/collectd/tail.so
+lib/collectd/tail_csv.so
lib/collectd/target_notification.so
lib/collectd/target_replace.so
lib/collectd/target_scale.so
@@ -83,20 +93,21 @@ lib/collectd/uptime.so
%%USERS%%lib/collectd/users.so
lib/collectd/uuid.so
%%VARNISH%%lib/collectd/varnish.so
-%%VIRT%%lib/collectd/libvirt.so
+%%VIRT%%lib/collectd/virt.so
lib/collectd/write_graphite.so
%%CURL%%lib/collectd/write_http.so
+lib/collectd/write_log.so
%%MONGODB%%lib/collectd/write_mongodb.so
%%REDIS%%lib/collectd/write_redis.so
%%RIEMANN%%lib/collectd/write_riemann.so
%%XMMS%%lib/collectd/xmms.so
lib/collectd/zfs_arc.so
-lib/libcollectdclient.so
-lib/libcollectdclient.so.1
-lib/libcollectdclient.so.1.0.0
+%%ZOOKEEPER%%lib/collectd/zookeeper.so
libdata/pkgconfig/libcollectdclient.pc
%%DATADIR%%/postgresql_default.conf
%%DATADIR%%/types.db
+%%PERL%%%%PERL5_MAN3%%/Collectd::Unixsock.3.gz
+%%PERL%%%%SITE_PERL%%/Collectd/Plugins/OpenVZ.pm
%%PERL%%%%SITE_PERL%%/Collectd.pm
%%PERL%%%%SITE_PERL%%/Collectd/Unixsock.pm
man/man1/collectd-nagios.1.gz
@@ -115,5 +126,3 @@ man/man5/collectd-unixsock.5.gz
man/man5/collectd.conf.5.gz
man/man5/types.db.5.gz
@dir /var/db/collectd
-@dir /var/lib/collectd
-@dir /var/lib