aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/collectd5
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-10-01 23:58:57 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-10-01 23:58:57 +0000
commitaed0e3005cccfde946855b0485f7d1b27262d07a (patch)
tree3f276cdca8459f4ff06e22bd967ed031d8d41715 /net-mgmt/collectd5
parent943851900e74ce3522f18c84a2398f14d48c896c (diff)
downloadports-aed0e3005cccfde946855b0485f7d1b27262d07a.tar.gz
ports-aed0e3005cccfde946855b0485f7d1b27262d07a.zip
Notes
Diffstat (limited to 'net-mgmt/collectd5')
-rw-r--r--net-mgmt/collectd5/Makefile6
-rw-r--r--net-mgmt/collectd5/files/patch-src_zfs__arc.c10
2 files changed, 13 insertions, 3 deletions
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index 70225e4652f8..b9f84baf7db0 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= collectd
PORTVERSION= 5.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= https://collectd.org/files/ \
http://collectd.org/files/
@@ -62,7 +62,7 @@ PING_DESC= Enable ping plugin
PYTHON_DESC= Enable python-based plugins
RABBITMQ_DESC= Enable rabbitmq-based plugins
REDIS_DESC= Enable redis-based plugins
-RIEMANN_DESC= Enable write_riemann plugin (via protobuf-c)
+RIEMANN_DESC= Enable write_riemann plugin (via riemann-c-client)
ROUTEROS_DESC= Enable routeros plugin
RRDTOOL_DESC= Enable rrdtool plugin (also rrdcached plugin)
SIGROK_DESC= Enable sigrok plugin
@@ -224,7 +224,7 @@ REDIS_LIB_DEPENDS= libhiredis.so:databases/hiredis
REDIS_CONFIGURE_ENABLE= redis write_redis
REDIS_CONFIGURE_WITH= libhiredis=${LOCALBASE}
-RIEMANN_LIB_DEPENDS= libprotobuf-c.so:devel/protobuf-c
+RIEMANN_LIB_DEPENDS= libriemann-client.so:net-mgmt/riemann-c-client
RIEMANN_CONFIGURE_ENABLE= write_riemann
ROUTEROS_LIB_DEPENDS= librouteros.so:net/librouteros
diff --git a/net-mgmt/collectd5/files/patch-src_zfs__arc.c b/net-mgmt/collectd5/files/patch-src_zfs__arc.c
new file mode 100644
index 000000000000..6b7bf6cac9b5
--- /dev/null
+++ b/net-mgmt/collectd5/files/patch-src_zfs__arc.c
@@ -0,0 +1,10 @@
+--- src/zfs_arc.c.orig 2016-09-11 08:10:25 UTC
++++ src/zfs_arc.c
+@@ -314,7 +314,6 @@ static int za_read (void)
+ za_read_derive (ksp, "demand_data_misses", "cache_result", "demand_data-miss");
+ za_read_derive (ksp, "demand_metadata_misses", "cache_result", "demand_metadata-miss");
+ za_read_derive (ksp, "prefetch_data_misses", "cache_result", "prefetch_data-miss");
+- za_read_derive (ksp, "prefetch_metadata_misses", "cache_result", "prefetch_metadata-miss");
+ za_read_derive (ksp, "mfu_hits", "cache_result", "mfu-hit");
+ za_read_derive (ksp, "mfu_ghost_hits", "cache_result", "mfu_ghost-hit");
+ za_read_derive (ksp, "mru_hits", "cache_result", "mru-hit");