aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/collectd
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-09-24 14:25:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-09-24 14:25:51 +0000
commit13c43e36168436a815f6f8b57ebb65c4ece39261 (patch)
tree501d71eca3d3d6473de79756a860eeda70772e21 /net-mgmt/collectd
parent7f25d4ef72f4c9555c6e2c425e5d7e157e6434a3 (diff)
Notes
Diffstat (limited to 'net-mgmt/collectd')
-rw-r--r--net-mgmt/collectd/Makefile17
-rw-r--r--net-mgmt/collectd/pkg-plist2
2 files changed, 15 insertions, 4 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index e4caaed929dc..58a84643c3fe 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -23,6 +23,7 @@ OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
DEBUG "Enable debugging" Off \
APACHE "Input: Apache mod_status (libcurl)" Off \
APCUPS "Input: APC UPS (apcupsd)" Off \
+ NUTUPS "Input: NUT UPS daemon" Off \
INTERFACE "Input: Network interfaces (libstatgrab)" On \
MBMON "Input: MBMon" Off \
MYSQL "Input: MySQL" Off \
@@ -48,9 +49,9 @@ BROKEN= Need bind9 import post 6.1
# NOTE: Feel free to submit patches adding support for any of these
# disabled plugins. If a plugin requires external dependencies,
-# make it optional through OPTIONS. Some of these are Linux
-# specific, but others will probably run on FreeBSD as well,
-# given a bit of careful attention.
+# make it optional through OPTIONS defaulting to Off. Some of
+# these are Linux specific, but others will probably run on
+# FreeBSD as well, given a bit of careful attention.
CONFIGURE_ARGS= --localstatedir=/var \
--disable-apple_sensors \
--disable-ascent \
@@ -70,7 +71,6 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-nginx \
--disable-notify_desktop \
--disable-notify_email \
- --disable-nut \
--disable-onewire \
--disable-perl \
--disable-postgresql \
@@ -115,6 +115,15 @@ CONFIGURE_ARGS+=--disable-apcups
PLIST_SUB+= APCUPS="@comment "
.endif
+.if defined(WITH_NUTUPS)
+CONFIGURE_ARGS+=--enable-nut
+BUILD_DEPENDS+= ${LOCALBASE}/include/upsclient.h:${PORTSDIR}/sysutils/nut
+PLIST_SUB+= NUTUPS=""
+.else
+CONFIGURE_ARGS+=--disable-nut
+PLIST_SUB+= NUTUPS="@comment "
+.endif
+
.if defined(WITH_INTERFACE)
BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
CONFIGURE_ARGS+=--enable-interface
diff --git a/net-mgmt/collectd/pkg-plist b/net-mgmt/collectd/pkg-plist
index 0831641f3310..f1eb8e179469 100644
--- a/net-mgmt/collectd/pkg-plist
+++ b/net-mgmt/collectd/pkg-plist
@@ -45,6 +45,8 @@ lib/collectd/memory.so
%%MYSQL%%lib/collectd/mysql.so
lib/collectd/network.la
lib/collectd/network.so
+%%NUTUPS%%lib/collectd/nut.la
+%%NUTUPS%%lib/collectd/nut.so
lib/collectd/ntpd.la
lib/collectd/ntpd.so
%%PING%%lib/collectd/ping.la