aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/collectd
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2012-04-12 05:44:15 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2012-04-12 05:44:15 +0000
commita459a2dec239bf455206ea2494374e038358d63b (patch)
tree7e2ae8dfa34a8067d2f807ead76422460c6f5f89 /net-mgmt/collectd
parent9f02490239d3e692724bdf933b7826fec0718ce4 (diff)
downloadports-a459a2dec239bf455206ea2494374e038358d63b.tar.gz
ports-a459a2dec239bf455206ea2494374e038358d63b.zip
Notes
Diffstat (limited to 'net-mgmt/collectd')
-rw-r--r--net-mgmt/collectd/Makefile13
-rw-r--r--net-mgmt/collectd/files/patch-configure.in21
-rw-r--r--net-mgmt/collectd/pkg-plist2
3 files changed, 28 insertions, 8 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index a8f99a244928..fc754894732d 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= collectd
PORTVERSION= 4.10.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= http://collectd.org/files/
@@ -41,6 +41,7 @@ OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
PGSQL "Input: PostgreSQL" Off \
PING "Input: Network latency (liboping)" On \
PYTHON "Input: Python plugin" Off \
+ ROUTEROS "Input: RouterOS plugin" Off \
SNMP "Input: SNMP" On \
TOKYOTYRANT "Input: Tokyotyrant database" Off \
XMMS "Input: XMMS" Off \
@@ -105,7 +106,6 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-perl \
--disable-pinba \
--disable-protocols \
- --disable-routeros \
--disable-sensors \
--disable-serial \
--disable-table \
@@ -333,6 +333,15 @@ CONFIGURE_ARGS+=--disable-python
PLIST_SUB+= PYTHON="@comment "
.endif
+.if defined(WITH_ROUTEROS)
+LIB_DEPENDS+= routeros:${PORTSDIR}/net/librouteros
+CONFIGURE_ARGS+=--enable-routeros --with-librouteros=${LOCALBASE}
+PLIST_SUB+= ROUTEROS=""
+.else
+CONFIGURE_ARGS+=--disable-routeros --without-librouteros
+PLIST_SUB+= ROUTEROS="@comment "
+.endif
+
.if defined(WITH_RRDTOOL)
LIB_DEPENDS+= rrd:${PORTSDIR}/databases/rrdtool
CONFIGURE_ARGS+=--enable-rrdtool
diff --git a/net-mgmt/collectd/files/patch-configure.in b/net-mgmt/collectd/files/patch-configure.in
index 186744f29871..7f158b4b239a 100644
--- a/net-mgmt/collectd/files/patch-configure.in
+++ b/net-mgmt/collectd/files/patch-configure.in
@@ -1,6 +1,15 @@
---- configure.in.orig 2011-10-14 22:46:13.000000000 +0200
-+++ configure.in 2012-01-08 13:56:06.000000000 +0100
-@@ -1541,9 +1541,6 @@
+--- configure.in.orig 2011-10-14 12:49:49.000000000 -0800
++++ configure.in 2012-03-20 08:09:25.000000000 -0800
+@@ -98,7 +98,7 @@
+ fi
+
+ # Where to install .pc files.
+-pkgconfigdir="${libdir}/pkgconfig"
++pkgconfigdir="${prefix}/libdata/pkgconfig"
+ AC_SUBST(pkgconfigdir)
+
+ # Check for standards compliance mode
+@@ -1745,9 +1745,6 @@
[with_libgcrypt="yes"],
[with_libgcrypt="no (symbol gcry_md_hash_buffer not found)"])
@@ -10,16 +19,16 @@
fi
CPPFLAGS="$SAVE_CPPFLAGS"
-@@ -2960,7 +2957,7 @@
+@@ -3165,7 +3162,7 @@
if test "x$with_python" = "xyes"
then
AC_MSG_CHECKING([for Python LIBS])
- python_library_flags=`echo "import distutils.sysconfig;import sys;sys.stdout.write(distutils.sysconfig.get_config_vars(\"BLDLIBRARY\").__getitem__(0))" | "$with_python_prog" 2>&1`
-+ python_library_flags=`echo "import distutils.sysconfig;import sys;sys.stdout.write(distutils.sysconfig.get_config_vars(\"LIBDIR\").__getitem__(0)+\"/\"+distutils.sysconfig.get_config_vars(\"BLDLIBRARY\").__getitem__(0))" | "$with_python_prog" 2>&1`
++ python_library_flags=`echo "import distutils.sysconfig;import sys;sys.stdout.write(distutils.sysconfig.get_config_var(\"LINKFORSHARED\")+\" -L\"+distutils.sysconfig.get_config_vars(\"LIBDIR\").__getitem__(0)+\" -l\"+distutils.sysconfig.get_config_vars(\"BLDLIBRARY\").__getitem__(0).replace(\"lib\", \"\").replace(\".a\", \"\"))" | "$with_python_prog" 2>&1`
python_config_status=$?
if test "$python_config_status" -ne 0 || test "x$python_library_flags" = "x"
-@@ -2975,7 +2972,7 @@
+@@ -3180,7 +3177,7 @@
if test "x$with_python" = "xyes"
then
LDFLAGS="-L$python_library_path $LDFLAGS"
diff --git a/net-mgmt/collectd/pkg-plist b/net-mgmt/collectd/pkg-plist
index 7ae16778b644..52d063e60a5a 100644
--- a/net-mgmt/collectd/pkg-plist
+++ b/net-mgmt/collectd/pkg-plist
@@ -77,6 +77,8 @@ lib/collectd/ntpd.so
%%PYTHON%%lib/collectd/python.so
lib/collectd/processes.so
lib/collectd/processes.la
+%%ROUTEROS%%lib/collectd/routeros.la
+%%ROUTEROS%%lib/collectd/routeros.so
%%RRD%%lib/collectd/rrdtool.la
%%RRD%%lib/collectd/rrdtool.so
%%RRDCACHED%%lib/collectd/rrdcached.la