aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/collectd
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-01 22:19:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-01 22:19:09 +0000
commitff0f78c1bba8d0b5da3da37cfe4efe7a8b27983c (patch)
tree5039c11a99d815f8eb2e2b33236188df61f7eadd /net-mgmt/collectd
parent3376f0cca946eeed66266a2ccb813c12daaa3400 (diff)
downloadports-ff0f78c1bba8d0b5da3da37cfe4efe7a8b27983c.tar.gz
ports-ff0f78c1bba8d0b5da3da37cfe4efe7a8b27983c.zip
Notes
Diffstat (limited to 'net-mgmt/collectd')
-rw-r--r--net-mgmt/collectd/Makefile40
-rw-r--r--net-mgmt/collectd/distinfo6
-rw-r--r--net-mgmt/collectd/files/collectd.in2
-rw-r--r--net-mgmt/collectd/files/collectdmon.in27
-rw-r--r--net-mgmt/collectd/pkg-plist19
5 files changed, 83 insertions, 11 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index 43ce9fe4024b..ce84a147621a 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= collectd
-PORTVERSION= 4.1.2
-PORTREVISION= 3
+PORTVERSION= 4.5.1
CATEGORIES= net-mgmt
MASTER_SITES= http://collectd.org/files/ \
http://mirror.roe.ch/dist/${PORTNAME}/
@@ -31,10 +30,11 @@ OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
XMMS "Input: XMMS" Off \
RRDTOOL "Output: RRDTool" On
-MAN1= collectd.1 collectd-nagios.1
+MAN1= collectd.1 collectd-nagios.1 collectdmon.1
MAN5= collectd.conf.5 collectd-email.5 collectd-exec.5 \
- collectd-snmp.5 collectd-unixsock.5 collectd-perl.5
-USE_RC_SUBR= collectd
+ collectd-snmp.5 collectd-unixsock.5 collectd-perl.5 \
+ types.db.5
+USE_RC_SUBR= collectd collectdmon
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -45,17 +45,43 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
BROKEN= Need bind9 import post 6.1
.endif
+# NOTE: Feel free to submit patches adding support for any of these
+# disabled plugins. If a plugin requires external dependencies,
+# make it optional through OPTIONS. Some of these are Linux
+# specific, but others will probably run on FreeBSD as well,
+# given a bit of careful attention.
CONFIGURE_ARGS= --localstatedir=/var \
--disable-apple_sensors \
+ --disable-ascent \
--disable-battery \
+ --disable-cpufreq \
+ --disable-disk \
+ --disable-entropy \
--disable-hddtemp \
- --disable-multimeter \
--disable-iptables \
+ --disable-ipmi \
+ --disable-ipvs \
+ --disable-irq \
+ --disable-libvirt \
+ --disable-multimeter \
+ --disable-netlink \
+ --disable-nfs \
+ --disable-nginx \
+ --disable-notify_desktop \
+ --disable-notify_email \
+ --disable-nut \
+ --disable-onewire \
--disable-perl \
+ --disable-postgresql \
--disable-sensors \
--disable-serial \
+ --disable-tape \
+ --disable-thermal \
+ --disable-users \
+ --disable-vmem \
--disable-vserver \
- --disable-wireless
+ --disable-wireless \
+ --without-perl-bindings
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+=--enable-debug
diff --git a/net-mgmt/collectd/distinfo b/net-mgmt/collectd/distinfo
index 7fce046fb9d7..24b577a02551 100644
--- a/net-mgmt/collectd/distinfo
+++ b/net-mgmt/collectd/distinfo
@@ -1,3 +1,3 @@
-MD5 (collectd-4.1.2.tar.gz) = 40458dabe8ec5df87323c1862a03cb94
-SHA256 (collectd-4.1.2.tar.gz) = fba4423378a8a270de8b48f98dc2f102f4f3c630381672267344776885a6e690
-SIZE (collectd-4.1.2.tar.gz) = 999229
+MD5 (collectd-4.5.1.tar.gz) = ab900d15662859b8793abf99eda15c29
+SHA256 (collectd-4.5.1.tar.gz) = 9ab967b7909d9c229cfcd4d1a5503da42f38a1246a53fc5cfaaf1dfde6fae8a1
+SIZE (collectd-4.5.1.tar.gz) = 1279434
diff --git a/net-mgmt/collectd/files/collectd.in b/net-mgmt/collectd/files/collectd.in
index 5ec218f3b27e..0dd6c3f38847 100644
--- a/net-mgmt/collectd/files/collectd.in
+++ b/net-mgmt/collectd/files/collectd.in
@@ -9,7 +9,7 @@
# collectd_enable (bool): Set to NO by default.
# Set it to YES to enable collectd.
# collectd_flags (string): Set to "" by default.
-# Additional flags to collecd, see manual page.
+# Additional flags to collectd, see manual page.
#
. %%RC_SUBR%%
diff --git a/net-mgmt/collectd/files/collectdmon.in b/net-mgmt/collectd/files/collectdmon.in
new file mode 100644
index 000000000000..3d934e8223b2
--- /dev/null
+++ b/net-mgmt/collectd/files/collectdmon.in
@@ -0,0 +1,27 @@
+#!/bin/sh
+
+# PROVIDE: collectdmon
+# REQUIRE: LOGIN
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# collectdmon_enable (bool): Set to NO by default.
+# Set it to YES to enable collectd.
+# collectdmon_flags (string): Set to "-c %%PREFIX%%/sbin/collectd" by default.
+# Additional flags to collectdmon, see manual page.
+#
+
+. %%RC_SUBR%%
+
+name="collectdmon"
+rcvar=${name}_enable
+
+command=%%PREFIX%%/sbin/${name}
+
+load_rc_config $name
+
+: ${collectdmon_enable="NO"}
+: ${collectdmon_flags="-c %%PREFIX%%/sbin/collectd"}
+
+run_rc_command "$1"
diff --git a/net-mgmt/collectd/pkg-plist b/net-mgmt/collectd/pkg-plist
index 2da1f6995781..0831641f3310 100644
--- a/net-mgmt/collectd/pkg-plist
+++ b/net-mgmt/collectd/pkg-plist
@@ -1,5 +1,6 @@
@stopdaemon collectd
sbin/collectd
+sbin/collectdmon
@unexec if cmp -s %D/etc/collectd.conf.sample %D/etc/collectd.conf; then rm -f %D/etc/collectd.conf; fi
etc/collectd.conf.sample
@exec if [ ! -f %B/collectd.conf ] ; then cp -p %B/%f %B/collectd.conf; fi
@@ -26,6 +27,8 @@ lib/collectd/email.la
lib/collectd/email.so
lib/collectd/exec.la
lib/collectd/exec.so
+lib/collectd/filecount.so
+lib/collectd/filecount.la
%%INTERFACE%%lib/collectd/interface.la
%%INTERFACE%%lib/collectd/interface.so
lib/collectd/load.la
@@ -34,6 +37,8 @@ lib/collectd/logfile.la
lib/collectd/logfile.so
%%MBMON%%lib/collectd/mbmon.la
%%MBMON%%lib/collectd/mbmon.so
+lib/collectd/memcached.so
+lib/collectd/memcached.la
lib/collectd/memory.la
lib/collectd/memory.so
%%MYSQL%%lib/collectd/mysql.la
@@ -44,6 +49,10 @@ lib/collectd/ntpd.la
lib/collectd/ntpd.so
%%PING%%lib/collectd/ping.la
%%PING%%lib/collectd/ping.so
+lib/collectd/powerdns.so
+lib/collectd/powerdns.la
+lib/collectd/processes.so
+lib/collectd/processes.la
%%RRD%%lib/collectd/rrdtool.la
%%RRD%%lib/collectd/rrdtool.so
%%SNMP%%lib/collectd/snmp.la
@@ -52,10 +61,20 @@ lib/collectd/swap.la
lib/collectd/swap.so
lib/collectd/syslog.la
lib/collectd/syslog.so
+lib/collectd/tail.so
+lib/collectd/tail.la
+lib/collectd/tcpconns.so
+lib/collectd/tcpconns.la
+lib/collectd/teamspeak2.so
+lib/collectd/teamspeak2.la
lib/collectd/unixsock.la
lib/collectd/unixsock.so
+lib/collectd/uuid.so
+lib/collectd/uuid.la
%%XMMS%%lib/collectd/xmms.la
%%XMMS%%lib/collectd/xmms.so
+share/collectd/postgresql_default.conf
@dirrm lib/collectd
+@dirrm share/collectd
@exec mkdir -p /var/db/collectd
@unexec rmdir /var/db/collectd 2>/dev/null || true