aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/dhcdrop
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-04-22 13:31:33 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-04-22 13:31:33 +0000
commit4f4adc720651ec08ea934be4fda849c0100f925f (patch)
treea303a4a67796531b76f18c905923476d34d5eb94 /net-mgmt/dhcdrop
parent879e75a6593d4f669464a017aaebd9f8bee250f3 (diff)
downloadports-4f4adc720651ec08ea934be4fda849c0100f925f.tar.gz
ports-4f4adc720651ec08ea934be4fda849c0100f925f.zip
net-mgmt/dhcdrop: Fix build on FreeBSD >= 12.0 and unbreak STATIC option
Add missing libibverbs dependency when linking statically. On FreeBSD >= 12.0 libpcap needs libibverbs: /usr/bin/ld: error: undefined symbol: ibv_get_device_list >>> referenced by pcap-rdmasniff.c:370 (/usr/src/contrib/libpcap/pcap-rdmasniff.c:370) >>> pcap-rdmasniff.o:(rdmasniff_create) in archive /usr/lib/libpcap.a http://beefy6.nyi.freebsd.org/data/120amd64-default/499421/logs/errors/dhcdrop-0.5_2.log While here fix the STATIC option. Currently the port always links statically since --disable-static-build is broken and also enables static linking. Reported by: antoine, pkg-fallout
Notes
Notes: svn path=/head/; revision=499639
Diffstat (limited to 'net-mgmt/dhcdrop')
-rw-r--r--net-mgmt/dhcdrop/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/net-mgmt/dhcdrop/Makefile b/net-mgmt/dhcdrop/Makefile
index 7af6cd58b932..f9b60cf2ae69 100644
--- a/net-mgmt/dhcdrop/Makefile
+++ b/net-mgmt/dhcdrop/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dhcdrop
PORTVERSION= 0.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt sysutils
MASTER_SITES= http://www.netpatch.ru/projects/dhcdrop/
@@ -22,6 +22,16 @@ PLIST_FILES= sbin/dhcdrop man/man8/dhcdrop.8.gz \
OPTIONS_DEFINE= STATIC
STATIC_DESC= Build a static version of dhcdrop
-STATIC_CONFIGURE_ENABLE= static-build
+# --disable-static-build is broken and has the same effect as
+# --enable-static-build, so do not use STATIC_CONFIGURE_ENABLE
+# here.
+STATIC_CONFIGURE_ON= --enable-static-build
+
+.if exists(/usr/lib/libibverbs.a)
+# Link with libibverbs too needed by static libpcap
+post-patch-STATIC-on:
+ @${REINPLACE_CMD} -e 's,^dhcdrop_LDADD.*,& -libverbs,' \
+ ${WRKSRC}/src/Makefile.am
+.endif
.include <bsd.port.mk>