aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/dhcp_probe
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-03-20 10:53:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-03-20 10:53:08 +0000
commit654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc (patch)
treec30aa05ffe4be67ca3bb38317073b7e6603daa7c /net-mgmt/dhcp_probe
parent3dc362ac88ab73d6f0b3635628a59d9597e6da4e (diff)
downloadports-654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc.tar.gz
ports-654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc.zip
Notes
Diffstat (limited to 'net-mgmt/dhcp_probe')
-rw-r--r--net-mgmt/dhcp_probe/Makefile20
-rw-r--r--net-mgmt/dhcp_probe/files/patch-Makefile.am9
2 files changed, 7 insertions, 22 deletions
diff --git a/net-mgmt/dhcp_probe/Makefile b/net-mgmt/dhcp_probe/Makefile
index c2038eb435dc..8958f22d2f50 100644
--- a/net-mgmt/dhcp_probe/Makefile
+++ b/net-mgmt/dhcp_probe/Makefile
@@ -3,38 +3,32 @@
PORTNAME= dhcp_probe
PORTVERSION= 1.3.0
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= https://www.net.princeton.edu/software/dhcp_probe/
MAINTAINER= khung@nullaxiom.com
COMMENT= Attempts to discover DHCP and BootP servers on a network
-LICENSE= GPLv2 addl
+LICENSE= GPLv2 LGPL20 addl
LICENSE_COMB= multi
+LICENSE_FILE_GPLv2=${WRKSRC}/COPYING.GPL
+LICENSE_FILE_LGPL20=${WRKSRC}/COPYING.LIB
LICENSE_NAME_addl=Additional legal notices for copyrighted code
LICENSE_FILE_addl=${WRKSRC}/COPYING
LICENSE_PERMS_addl=dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
-USE_AUTOTOOLS= aclocal automake
-AUTOMAKE_ARGS= -a
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libnet-include=${LOCALBASE}/include/libnet11/ --with-libnet-lib=${LOCALBASE}/lib/libnet11/
-MANPREFIX= ${PREFIX}
+INSTALL_TARGET= install-strip
USE_RC_SUBR= dhcp_probe
SUB_FILES= pkg-message
-# Put additional licenses in DOCS
-PORTDOCS= COPYING*
-
-# Can't use INSTALL_PROGRAM macro as we need to patch Makefile.am and
-# regenerate Makefile.in
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/dhcp_probe
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/COPYING* ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/extras/dhcp_probe.cf.sample \
+ ${STAGEDIR}${PREFIX}/etc
.include <bsd.port.mk>
diff --git a/net-mgmt/dhcp_probe/files/patch-Makefile.am b/net-mgmt/dhcp_probe/files/patch-Makefile.am
deleted file mode 100644
index 6c57481c8088..000000000000
--- a/net-mgmt/dhcp_probe/files/patch-Makefile.am
+++ /dev/null
@@ -1,9 +0,0 @@
---- Makefile.am.orig 2015-01-28 01:27:58.000000000 -0500
-+++ Makefile.am 2015-01-28 01:38:40.000000000 -0500
-@@ -25,3 +25,6 @@
- extras/README
-
- ACLOCAL_AMFLAGS = -I m4
-+
-+## Copy sample configuration file to PREFIX/etc/
-+sysconf_DATA= extras/dhcp_probe.cf.sample