aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/fastnetmon
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-09-03 22:33:25 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-09-03 22:33:25 +0000
commit81750cabf0f1cd84c96a0900ef9cb702ed1704bf (patch)
tree997c18b08c27bf33b1ae3f1ca823facece367c3a /net-mgmt/fastnetmon
parent0656905283ca1f1b98e6eaee94c36d2d96fe8c1b (diff)
downloadports-81750cabf0f1cd84c96a0900ef9cb702ed1704bf.tar.gz
ports-81750cabf0f1cd84c96a0900ef9cb702ed1704bf.zip
Notes
Diffstat (limited to 'net-mgmt/fastnetmon')
-rw-r--r--net-mgmt/fastnetmon/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/net-mgmt/fastnetmon/Makefile b/net-mgmt/fastnetmon/Makefile
index f3dc8f17a923..b165b313f0ac 100644
--- a/net-mgmt/fastnetmon/Makefile
+++ b/net-mgmt/fastnetmon/Makefile
@@ -15,16 +15,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_armv6= Does not build: invokes x86 assembler
BROKEN_armv7= Does not build: invokes x86 assembler
-BROKEN_powerpc64= Does not build
LIB_DEPENDS= libboost_regex.so:devel/boost-libs \
liblog4cpp.so:devel/log4cpp \
- libluajit-5.1.so:lang/luajit \
libmongoc-1.0.so:devel/mongo-c-driver \
libjson-c.so:devel/json-c \
libbson-1.0.so:devel/libbson
-USES= cmake
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= pavel-odintsov
@@ -46,6 +44,14 @@ CMAKE_ARGS+= -DDISABLE_PF_RING_SUPPORT=ON \
-DENABLE_NETMAP_SUPPORT=OFF
CMAKE_INSTALL_PREFIX= ${PREFIX}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == amd64 || ${ARCH} == i386
+LIB_DEPENDS+= libluajit-5.1.so:lang/luajit
+.else
+CMAKE_ARGS+= -DENABLE_LUA_SUPPORT:BOOL=OFF
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/src/CMakeLists.txt
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|; \
@@ -65,4 +71,4 @@ post-install:
post-install-DOCS-on:
cd ${WRKSRC} && ${COPYTREE_SHARE} "README.md docs" ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>