aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/fastnetmon
diff options
context:
space:
mode:
authorBabak Farrokhi <farrokhi@FreeBSD.org>2023-03-06 12:35:23 +0000
committerBabak Farrokhi <farrokhi@FreeBSD.org>2023-03-06 12:35:23 +0000
commitb8c336c15842011facfe07163cb3d91e50bc1468 (patch)
tree333d90006388af360beec809cc7fcede680ed0a1 /net-mgmt/fastnetmon
parent4ed0610ed9cb2f49adea0745e11bb48458fad81d (diff)
downloadports-b8c336c15842011facfe07163cb3d91e50bc1468.tar.gz
ports-b8c336c15842011facfe07163cb3d91e50bc1468.zip
Diffstat (limited to 'net-mgmt/fastnetmon')
-rw-r--r--net-mgmt/fastnetmon/Makefile38
-rw-r--r--net-mgmt/fastnetmon/distinfo6
-rw-r--r--net-mgmt/fastnetmon/files/extra-patch-src_fast__library.h11
-rw-r--r--net-mgmt/fastnetmon/files/extra-patch-src_netflow__plugin_netflow__collector.cpp11
-rw-r--r--net-mgmt/fastnetmon/files/patch-src_CMakeLists.txt88
-rw-r--r--net-mgmt/fastnetmon/files/patch-src_fast__endianless.hpp10
-rw-r--r--net-mgmt/fastnetmon/files/patch-src_fast__library.cpp15
-rw-r--r--net-mgmt/fastnetmon/files/patch-src_fast__platform.h.template38
-rw-r--r--net-mgmt/fastnetmon/files/patch-src_fastnetmon.cpp40
-rw-r--r--net-mgmt/fastnetmon/files/patch-src_man_fastnetmon.8 (renamed from net-mgmt/fastnetmon/files/patch-src_man_fastnetmon.1)8
-rw-r--r--net-mgmt/fastnetmon/files/patch-src_notify__about__attack.sh8
-rw-r--r--net-mgmt/fastnetmon/pkg-plist4
12 files changed, 120 insertions, 157 deletions
diff --git a/net-mgmt/fastnetmon/Makefile b/net-mgmt/fastnetmon/Makefile
index 00bf090400a5..f1269937c2ad 100644
--- a/net-mgmt/fastnetmon/Makefile
+++ b/net-mgmt/fastnetmon/Makefile
@@ -1,7 +1,6 @@
PORTNAME= fastnetmon
-PORTVERSION= 1.1.4
+PORTVERSION= 1.2.4
DISTVERSIONPREFIX= v
-PORTREVISION= 9
CATEGORIES= net-mgmt security
MAINTAINER= farrokhi@FreeBSD.org
@@ -11,16 +10,21 @@ WWW= https://fastnetmon.com
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_armv6= Does not build: invokes x86 assembler
-BROKEN_armv7= Does not build: invokes x86 assembler
+BROKEN_armv6= does not build: invokes x86 assembler
+BROKEN_armv7= does not build: invokes x86 assembler
LIB_DEPENDS= libboost_regex.so:devel/boost-libs \
liblog4cpp.so:devel/log4cpp \
libmongoc-1.0.so:devel/mongo-c-driver \
libjson-c.so:devel/json-c \
- libbson-1.0.so:devel/libbson
+ libbson-1.0.so:devel/libbson \
+ libcapnp.so:devel/capnproto \
+ libgrpc.so:devel/grpc142 \
+ libprotobuf.so:devel/protobuf \
+ libabsl_base.so:devel/abseil \
+ libhiredis.so:databases/hiredis
-USES= cmake compiler:c++11-lang luajit
+USES= cmake compiler:c++11-lang pkgconfig localbase:ldflags ssl
USE_GITHUB= yes
GH_ACCOUNT= pavel-odintsov
@@ -36,38 +40,32 @@ REDIS_LIB_DEPENDS= libhiredis.so:databases/hiredis
PORTDOCS= *
+CXXFLAGS += -DBOOST_STACKTRACE_GNU_SOURCE_NOT_REQUIRED
CFLAGS_i386= -march=i586
CMAKE_SOURCE_PATH= ${WRKSRC}/src
CMAKE_ARGS+= -DDISABLE_PF_RING_SUPPORT=ON \
- -DENABLE_NETMAP_SUPPORT=OFF
+ -DENABLE_NETMAP_SUPPORT=OFF \
+ -DLINK_WITH_ABSL=ON \
+ -DSET_ABSOLUTE_INSTALL_PATH=OFF \
+ -DCMAKE_INSTALL_MANDIR=${PREFIX}/man
+
CMAKE_INSTALL_PREFIX= ${PREFIX}
.include <bsd.port.pre.mk>
-.if ${ARCH} != amd64 && ${ARCH} != armv6 && ${ARCH} != armv7 && ${ARCH} != i386 && ${ARCH} != powerpc && empty(ARCH:Mpowerpc64*)
-CMAKE_ARGS+= -DENABLE_LUA_SUPPORT:BOOL=OFF
-.else
-. if ${LUAJIT_VER} == luajit-devel || ${LUAJIT_VER} == luajit-openresty
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-src_fast__library.h \
- ${FILESDIR}/extra-patch-src_netflow__plugin_netflow__collector.cpp
-. endif
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/src/CMakeLists.txt
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|; \
s|/var/run|&/fastnetmon|g; s|/var/log|&/fastnetmon|g; \
s|"/etc/|"${PREFIX}/etc/|g; s|/root/fastnetmon|${DATADIR}|g' \
${WRKSRC}/src/fastnetmon.conf ${WRKSRC}/src/fastnetmon.cpp
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
- ${WRKSRC}/src/man/fastnetmon.1 ${WRKSRC}/src/fast_platform.h.template
+ ${WRKSRC}/src/man/fastnetmon.8 ${WRKSRC}/src/fast_platform.h.template
post-install:
${MV} ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf \
${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf.sample
${MKDIR} ${STAGEDIR}/var/run/fastnetmon ${STAGEDIR}/var/log/fastnetmon
- ${INSTALL_MAN} ${WRKSRC}/src/man/fastnetmon.1 ${STAGEDIR}${MANPREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/src/man/fastnetmon_client.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/notify_about_attack.sh ${STAGEDIR}${PREFIX}/bin
post-install-DOCS-on:
cd ${WRKSRC} && ${COPYTREE_SHARE} "README.md docs" ${STAGEDIR}${DOCSDIR}
diff --git a/net-mgmt/fastnetmon/distinfo b/net-mgmt/fastnetmon/distinfo
index 88f0234acdca..ae85613297b9 100644
--- a/net-mgmt/fastnetmon/distinfo
+++ b/net-mgmt/fastnetmon/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1555233508
-SHA256 (pavel-odintsov-fastnetmon-v1.1.4_GH0.tar.gz) = 4c13bc3304346db52086938533d6514d69c7014a0ac100655c6cf75ff321e0fb
-SIZE (pavel-odintsov-fastnetmon-v1.1.4_GH0.tar.gz) = 665067
+TIMESTAMP = 1677848493
+SHA256 (pavel-odintsov-fastnetmon-v1.2.4_GH0.tar.gz) = 84cd5db0e270f6c268923592eabd5cb0d1689293d9d9f6f0634af548b29f9bb4
+SIZE (pavel-odintsov-fastnetmon-v1.2.4_GH0.tar.gz) = 1056097
diff --git a/net-mgmt/fastnetmon/files/extra-patch-src_fast__library.h b/net-mgmt/fastnetmon/files/extra-patch-src_fast__library.h
deleted file mode 100644
index 8e9b1144676f..000000000000
--- a/net-mgmt/fastnetmon/files/extra-patch-src_fast__library.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/fast_library.h.orig 2020-09-23 17:00:00 UTC
-+++ src/fast_library.h
-@@ -25,7 +25,7 @@
- #include "libpatricia/patricia.h"
-
- #ifdef ENABLE_LUA_HOOKS
--#include <luajit-2.0/lua.hpp>
-+#include <luajit-2.1/lua.hpp>
- #endif
-
- #define TCP_FIN_FLAG_SHIFT 1
diff --git a/net-mgmt/fastnetmon/files/extra-patch-src_netflow__plugin_netflow__collector.cpp b/net-mgmt/fastnetmon/files/extra-patch-src_netflow__plugin_netflow__collector.cpp
deleted file mode 100644
index 161ec190e2cc..000000000000
--- a/net-mgmt/fastnetmon/files/extra-patch-src_netflow__plugin_netflow__collector.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/netflow_plugin/netflow_collector.cpp.orig 2020-09-23 17:05:19 UTC
-+++ src/netflow_plugin/netflow_collector.cpp
-@@ -28,7 +28,7 @@
- #include "log4cpp/Priority.hh"
-
- #ifdef ENABLE_LUA_HOOKS
--#include <luajit-2.0/lua.hpp>
-+#include <luajit-2.1/lua.hpp>
- #endif
-
- #ifdef ENABLE_LUA_HOOKS
diff --git a/net-mgmt/fastnetmon/files/patch-src_CMakeLists.txt b/net-mgmt/fastnetmon/files/patch-src_CMakeLists.txt
deleted file mode 100644
index 11a11a8a48a4..000000000000
--- a/net-mgmt/fastnetmon/files/patch-src_CMakeLists.txt
+++ /dev/null
@@ -1,88 +0,0 @@
---- src/CMakeLists.txt.orig 2019-02-13 22:20:23 UTC
-+++ src/CMakeLists.txt
-@@ -33,6 +33,13 @@ set (FASTNETMON_VERSION_MINOR 1)
- set(CMAKE_INSTALL_SYSTEMD_SERVICEDIR "/lib/systemd/system"
- CACHE PATH "Location for systemd service files")
-
-+# Respect PREFIX variable in FreeBSD
-+if($ENV{PREFIX})
-+ set(PREFIX $ENV{PREFIX})
-+else()
-+ set(PREFIX "/usr/local")
-+endif()
-+
- if (ENABLE_GOBGP_SUPPORT)
- # We could not compile gRPC without C++ 11
- set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -std=c++11")
-@@ -65,12 +72,12 @@ SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_RPATH};/opt/l
-
- message(STATUS "C++ compilation flags: ${CMAKE_CXX_FLAGS_RELEASE}")
-
--set(HIREDIS_CUSTOM_INSTALL_PATH "/opt/libhiredis_0_13")
--set(LOG4CPP_CUSTOM_INSTALL_PATH "/opt/log4cpp1.1.1")
--set(JSONC_CUSTOM_INSTALL_PATH "/opt/json-c-0.12")
--set(PFRING_CUSTOM_INSTALL_PATH "/opt/pf_ring_6.0.3")
--set(LIBPCAP_CUSTOM_INSTALL_PATH "/opt/libpcap_1.7.4")
--set(MONGO_C_CUSTOM_INSTALL_PATH "/opt/mongo_c_driver_1_1_9")
-+set(HIREDIS_CUSTOM_INSTALL_PATH ${PREFIX})
-+set(LOG4CPP_CUSTOM_INSTALL_PATH ${PREFIX})
-+set(JSONC_CUSTOM_INSTALL_PATH ${PREFIX})
-+set(PFRING_CUSTOM_INSTALL_PATH ${PREFIX})
-+set(LIBPCAP_CUSTOM_INSTALL_PATH ${PREFIX})
-+set(MONGO_C_CUSTOM_INSTALL_PATH ${PREFIX})
-
- set(FASTNETMON_PROFILER OFF)
-
-@@ -227,21 +234,22 @@ add_library(sflow_plugin STATIC sflow_plugin/sflow_col
- add_library(netflow_plugin STATIC netflow_plugin/netflow_collector.cpp)
- target_link_libraries(netflow_plugin ipfix_rfc)
-
--option(ENABLE_DPI_SUPPORT "Enable Deep Packet Inspection support" ON)
-+option(ENABLE_DPI_SUPPORT "Enable Deep Packet Inspection support" OFF)
- if (ENABLE_DPI_SUPPORT)
- message(STATUS "We will enable nDPI support")
-
- add_library(fast_dpi STATIC fast_dpi.cpp)
-
-- set(NDPI_INCLUDE_DIRS "/opt/ndpi/include/libndpi-1.7.1")
-+ set(NDPI_INCLUDE_DIRS ${PREFIX})
-
-- find_library(NDPI_LIBRARIES NAMES ndpi PATHS "/opt/ndpi/lib" NO_DEFAULT_PATH)
-+ file(GLOB NDPI_SEARCH_PATHS "${NDPI_CUSTOM_INSTALL_PATH}/include/libndpi-*")
-+ find_library(NDPI_LIBRARIES NAMES ndpi PATHS "${NDPI_CUSTOM_INSTALL_PATH}/lib" NO_DEFAULT_PATH)
-
- if (NOT NDPI_LIBRARIES)
- message(FATAL_ERROR "Could not find nDPI library")
- endif()
-
-- link_directories("/opt/ndpi/lib")
-+ link_directories(${NDPI_LIBRARIES})
- include_directories(${NDPI_INCLUDE_DIRS})
-
- add_definitions(-DENABLE_DPI)
-@@ -258,7 +266,7 @@ if (ENABLE_LUA_SUPPORT)
-
- add_definitions(-DENABLE_LUA_HOOKS)
-
-- set(LUAJIT_CUSTOM_INSTALL_PATH "/opt/luajit_2.0.4")
-+ set(LUAJIT_CUSTOM_INSTALL_PATH ${PREFIX})
-
- link_directories("${LUAJIT_CUSTOM_INSTALL_PATH}/lib")
- include_directories("${LUAJIT_CUSTOM_INSTALL_PATH}/include")
-@@ -656,12 +664,12 @@ install(FILES networks_list DESTINATION "${CMAKE_INSTA
- install(FILES networks_whitelist DESTINATION "${CMAKE_INSTALL_SYSCONFDIR}")
-
- # man pages
--install(FILES man/fastnetmon.1 DESTINATION /usr/share/man/man1)
--install(FILES man/fastnetmon_client.1 DESTINATION /usr/share/man/man1)
-+#install(FILES man/fastnetmon.1 DESTINATION /usr/share/man/man1)
-+#install(FILES man/fastnetmon_client.1 DESTINATION /usr/share/man/man1)
-
- # service files
--configure_file(fastnetmon.service.in "${CMAKE_CURRENT_BINARY_DIR}/fastnetmon.service" @ONLY)
--install(FILES "${CMAKE_CURRENT_BINARY_DIR}/fastnetmon.service" DESTINATION ${CMAKE_INSTALL_SYSTEMD_SERVICEDIR})
-+#configure_file(fastnetmon.service.in "${CMAKE_CURRENT_BINARY_DIR}/fastnetmon.service" @ONLY)
-+#install(FILES "${CMAKE_CURRENT_BINARY_DIR}/fastnetmon.service" DESTINATION ${CMAKE_INSTALL_SYSTEMD_SERVICEDIR})
-
- if (${OS_ID} MATCHES debian|ubuntu)
- install(FILES fastnetmon_init_script_debian_6_7 DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/init.d RENAME fastnetmon)
diff --git a/net-mgmt/fastnetmon/files/patch-src_fast__endianless.hpp b/net-mgmt/fastnetmon/files/patch-src_fast__endianless.hpp
new file mode 100644
index 000000000000..3b80a205bcde
--- /dev/null
+++ b/net-mgmt/fastnetmon/files/patch-src_fast__endianless.hpp
@@ -0,0 +1,10 @@
+--- src/fast_endianless.hpp.orig 2023-03-04 15:33:46 UTC
++++ src/fast_endianless.hpp
+@@ -12,6 +12,7 @@
+ // For be64toh and htobe64
+ #if defined(__FreeBSD__) || defined(__DragonFly__)
+ #include <sys/endian.h>
++#include <cstdint>
+ #endif
+
+ // Linux standard functions for endian conversions are ugly because there are no checks about arguments length
diff --git a/net-mgmt/fastnetmon/files/patch-src_fast__library.cpp b/net-mgmt/fastnetmon/files/patch-src_fast__library.cpp
new file mode 100644
index 000000000000..86b2dcd4bb68
--- /dev/null
+++ b/net-mgmt/fastnetmon/files/patch-src_fast__library.cpp
@@ -0,0 +1,15 @@
+--- src/fast_library.cpp.orig 2023-03-05 11:34:07 UTC
++++ src/fast_library.cpp
+@@ -1249,7 +1249,11 @@ bool get_interface_number_by_device_name(int socket_fd
+ return false;
+ }
+
+- interface_number = ifr.ifr_ifindex;
++ #ifdef __FreeBSD__
++ interface_number = ifr.ifr_ifru.ifru_index;
++ #else
++ interface_number = ifr.ifr_ifindex;
++ #endif
+ #else
+ /* Fallback to if_nametoindex(3) otherwise. */
+ interface_number = if_nametoindex(interface_name.c_str());
diff --git a/net-mgmt/fastnetmon/files/patch-src_fast__platform.h.template b/net-mgmt/fastnetmon/files/patch-src_fast__platform.h.template
index 6b8858525fba..bbf14617178a 100644
--- a/net-mgmt/fastnetmon/files/patch-src_fast__platform.h.template
+++ b/net-mgmt/fastnetmon/files/patch-src_fast__platform.h.template
@@ -1,26 +1,26 @@
---- src/fast_platform.h.template.orig 2019-02-13 22:20:23 UTC
+--- src/fast_platform.h.template.orig 2023-03-01 14:23:34 UTC
+++ src/fast_platform.h.template
-@@ -8,19 +8,19 @@
- std::string fastnetmon_version = "${FASTNETMON_APPLICATION_VERSION}";
+@@ -9,19 +9,19 @@ class FastnetmonPlatformConfigurtion {
+ std::string fastnetmon_version = "${FASTNETMON_APPLICATION_VERSION}";
- std::string pid_path = "/var/run/fastnetmon.pid";
--std::string global_config_path = "/etc/fastnetmon.conf";
-+std::string global_config_path = "%%PREFIX%%/etc/fastnetmon.conf";
+ std::string pid_path = "/var/run/fastnetmon.pid";
+- std::string global_config_path = "/etc/fastnetmon.conf";
++ std::string global_config_path = "%%PREFIX%%/etc/fastnetmon.conf";
- std::string log_file_path = "/var/log/fastnetmon.log";
- std::string attack_details_folder = "/var/log/fastnetmon_attacks";
+ std::string log_file_path = "/var/log/fastnetmon.log";
+ std::string attack_details_folder = "/var/log/fastnetmon_attacks";
- // Default path to notify script
--std::string notify_script_path = "/usr/local/bin/notify_about_attack.sh";
-+std::string notify_script_path = "%%PREFIX%%/bin/notify_about_attack.sh";
+ // Default path to notify script
+- std::string notify_script_path = "/usr/local/bin/notify_about_attack.sh";
++ std::string notify_script_path = "%%PREFIX%%/bin/notify_about_attack.sh";
- // Default path to file with networks for whitelising
--std::string white_list_path = "/etc/networks_whitelist";
-+std::string white_list_path = "%%PREFIX%%/etc/networks_whitelist";
+ // Default path to file with networks for whitelising
+- std::string white_list_path = "/etc/networks_whitelist";
++ std::string white_list_path = "%%PREFIX%%/etc/networks_whitelist";
- // Default path to file with all networks listing
--std::string networks_list_path = "/etc/networks_list";
-+std::string networks_list_path = "%%PREFIX%%/etc/networks_list";
-
- /* Platform specific paths end */
+ // Default path to file with all networks listing
+- std::string networks_list_path = "/etc/networks_list";
++ std::string networks_list_path = "%%PREFIX%%/etc/networks_list";
+ /* Platform specific paths end */
+ };
diff --git a/net-mgmt/fastnetmon/files/patch-src_fastnetmon.cpp b/net-mgmt/fastnetmon/files/patch-src_fastnetmon.cpp
new file mode 100644
index 000000000000..b0ba26165d1b
--- /dev/null
+++ b/net-mgmt/fastnetmon/files/patch-src_fastnetmon.cpp
@@ -0,0 +1,40 @@
+--- src/fastnetmon.cpp.orig 2023-03-01 14:23:34 UTC
++++ src/fastnetmon.cpp
+@@ -12,8 +12,8 @@
+ #include <unistd.h>
+
+ #include <arpa/inet.h>
+-#include <net/if_arp.h> // struct arphdr
+-#include <netinet/if_ether.h>
++//#include <net/if_arp.h> // struct arphdr
++//#include <netinet/if_ether.h>
+ #include <netinet/in.h>
+ #include <netinet/ip.h>
+ #include <netinet/ip_icmp.h>
+@@ -161,7 +161,7 @@ unsigned int stats_thread_initial_call_delay = 30;
+ std::string reporting_server = "community-stats.fastnetmon.com";
+
+ // Path to temporarily store backtrace when fatal failure happened
+-std::string backtrace_path = "/var/log/fastnetmon_backtrace.dump";
++std::string backtrace_path = "/var/log/fastnetmon/fastnetmon_backtrace.dump";
+
+ // Each this seconds we will check about available data in bucket
+ unsigned int check_for_availible_for_processing_packets_buckets = 1;
+@@ -435,7 +435,7 @@ std::string exabgp_community_subnet = "";
+ std::string exabgp_community_host = "";
+
+
+-std::string exabgp_command_pipe = "/var/run/exabgp.cmd";
++std::string exabgp_command_pipe = "/var/run/fastnetmon/exabgp.cmd";
+ std::string exabgp_next_hop = "";
+
+ // Graphite monitoring
+@@ -519,7 +519,7 @@ void sigpipe_handler_for_popen(int signo) {
+ #ifdef GEOIP
+ bool geoip_init() {
+ // load GeoIP ASN database to memory
+- geo_ip = GeoIP_open("/root/fastnetmon/GeoIPASNum.dat", GEOIP_MEMORY_CACHE);
++ geo_ip = GeoIP_open("/usr/local/share/fastnetmon/GeoIPASNum.dat", GEOIP_MEMORY_CACHE);
+
+ if (geo_ip == NULL) {
+ return false;
diff --git a/net-mgmt/fastnetmon/files/patch-src_man_fastnetmon.1 b/net-mgmt/fastnetmon/files/patch-src_man_fastnetmon.8
index 6e389fc45583..bb43f4f3a050 100644
--- a/net-mgmt/fastnetmon/files/patch-src_man_fastnetmon.1
+++ b/net-mgmt/fastnetmon/files/patch-src_man_fastnetmon.8
@@ -1,11 +1,11 @@
---- src/man/fastnetmon.1.orig 2019-02-13 22:20:23 UTC
-+++ src/man/fastnetmon.1
+--- src/man/fastnetmon.8.orig 2023-03-03 16:20:18 UTC
++++ src/man/fastnetmon.8
@@ -8,7 +8,7 @@ fastnetmon [--daemonize]
.SH DESCRIPTION
- FastNetMon - a high performance DoS/DDoS load analyzer built on top of multiple packet capture engines (NetFlow, IPFIX, sFLOW, netmap, PF_RING, PCAP).
+ FastNetMon - a high performance DoS/DDoS load analyzer built on top of multiple packet capture engines (NetFlow, IPFIX, sFlow, port mirror).
-For more information about configuration, please look at the comments in /etc/fastnetmon.conf and check the project GitHub page: https://github.com/pavel-odintsov/fastnetmon.
-+For more information about configuration, please look at the comments in /usr/local/etc/fastnetmon.conf and check the project GitHub page: https://github.com/pavel-odintsov/fastnetmon.
++For more information about configuration, please look at the comments in %%PREFIX%%/etc/fastnetmon.conf and check the project GitHub page: https://github.com/pavel-odintsov/fastnetmon.
.SH OPTIONS
fastnetmon has only a single command line option --daemonize which is used for forking and detaching it from the terminal.
.SH SEE ALSO
diff --git a/net-mgmt/fastnetmon/files/patch-src_notify__about__attack.sh b/net-mgmt/fastnetmon/files/patch-src_notify__about__attack.sh
new file mode 100644
index 000000000000..dc4a974f3297
--- /dev/null
+++ b/net-mgmt/fastnetmon/files/patch-src_notify__about__attack.sh
@@ -0,0 +1,8 @@
+--- src/notify_about_attack.sh.orig 2023-03-06 10:33:26 UTC
++++ src/notify_about_attack.sh
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env bash
++#!/bin/sh
+
+ #
+ # Hello, lovely FastNetMon customer. I'm really happy to see you here
diff --git a/net-mgmt/fastnetmon/pkg-plist b/net-mgmt/fastnetmon/pkg-plist
index 9ad378086236..01e28de42b0d 100644
--- a/net-mgmt/fastnetmon/pkg-plist
+++ b/net-mgmt/fastnetmon/pkg-plist
@@ -1,8 +1,10 @@
bin/fastnetmon
+bin/fastnetmon_api_client
bin/fastnetmon_client
+bin/notify_about_attack.sh
etc/networks_list
etc/networks_whitelist
-man/man1/fastnetmon.1.gz
+man/man8/fastnetmon.8.gz
man/man1/fastnetmon_client.1.gz
@sample etc/fastnetmon.conf.sample
@dir(fastnetmon,fastnetmon) /var/run/fastnetmon