aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/flow-extract
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-05-14 14:21:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-05-14 14:21:48 +0000
commit0df0b4780c1cc328eda1e0dcb3844145a7af5996 (patch)
tree30046d3edb7b55ea3fc372b71234c3a799a50e49 /net-mgmt/flow-extract
parent0149bce295e707f5b9641b1c32d084824a6be0e3 (diff)
downloadports-0df0b4780c1cc328eda1e0dcb3844145a7af5996.tar.gz
ports-0df0b4780c1cc328eda1e0dcb3844145a7af5996.zip
Notes
Diffstat (limited to 'net-mgmt/flow-extract')
-rw-r--r--net-mgmt/flow-extract/Makefile20
-rw-r--r--net-mgmt/flow-extract/distinfo6
-rw-r--r--net-mgmt/flow-extract/files/patch-Makefile32
-rw-r--r--net-mgmt/flow-extract/files/patch-includes70
4 files changed, 34 insertions, 94 deletions
diff --git a/net-mgmt/flow-extract/Makefile b/net-mgmt/flow-extract/Makefile
index 7ac5499debda..6f898ab74f88 100644
--- a/net-mgmt/flow-extract/Makefile
+++ b/net-mgmt/flow-extract/Makefile
@@ -6,30 +6,26 @@
#
PORTNAME= flow-extract
-PORTVERSION= 2.4
+PORTVERSION= 2.61
CATEGORIES= net-mgmt
-MASTER_SITES= http://security.uchicago.edu/tools/net-forensics/files/
-DISTNAME= flowextract-${PORTVERSION}
-EXTRACT_SUFX= .cpio.gz
+MASTER_SITES= http://security.uchicago.edu/tools/net-forensics/
+DISTNAME= flow-extract-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Cisco NetFlow awk-like extracting tool
BUILD_DEPENDS= flow-cat:${PORTSDIR}/net-mgmt/flow-tools
-EXTRACT_AFTER_ARGS= | ${CPIO} -idmu
+MAN1= flow-extract.1
+PLIST_FILES= bin/flow-extract
-post-patch: patch-makefile
+WRKSRC= ${WRKDIR}/${PORTNAME}
-patch-makefile:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
- ${WRKSRC}/Makefile
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/Makefile
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/flow-extract ${PREFIX}/bin
@${INSTALL_MAN} ${WRKSRC}/flow-extract.1 ${PREFIX}/man/man1
-MAN1= flow-extract.1
-PLIST_FILES= bin/flow-extract
-
.include <bsd.port.mk>
diff --git a/net-mgmt/flow-extract/distinfo b/net-mgmt/flow-extract/distinfo
index 5f812952c404..0345b2da8e95 100644
--- a/net-mgmt/flow-extract/distinfo
+++ b/net-mgmt/flow-extract/distinfo
@@ -1,3 +1,3 @@
-MD5 (flowextract-2.4.cpio.gz) = b1fdb245df78a5804e42b47c18275aaa
-SHA256 (flowextract-2.4.cpio.gz) = 1e66936481c9c8706b076ae4ce9a54b33aa32dd2307321bedaeb75608d892a7f
-SIZE (flowextract-2.4.cpio.gz) = 138571
+MD5 (flow-extract-2.61.tar.gz) = be11dd12b3f7c09b93a2858add6ae656
+SHA256 (flow-extract-2.61.tar.gz) = dfe6b55e201c557bc6d03beca3a0ae88e09054d1cf405c4b51af520f91d06f10
+SIZE (flow-extract-2.61.tar.gz) = 36882
diff --git a/net-mgmt/flow-extract/files/patch-Makefile b/net-mgmt/flow-extract/files/patch-Makefile
index 66d25454ca67..d1b59dab162e 100644
--- a/net-mgmt/flow-extract/files/patch-Makefile
+++ b/net-mgmt/flow-extract/files/patch-Makefile
@@ -1,25 +1,39 @@
---- Makefile.original Fri Mar 14 13:20:42 2003
-+++ Makefile Fri Mar 14 13:21:33 2003
-@@ -10,10 +10,9 @@
+--- /home/barzog/Makefile 2008-05-11 02:57:48.000000000 +0000
++++ Makefile 2008-05-11 02:59:59.000000000 +0000
+@@ -10,10 +10,10 @@
#
# For SunOS 5, use LIBS=-lsocket -lnsl
#
-CC=gcc
--FLAGS=-ggdb3 -gstabs
+-FLAGS=-ggdb3 -gstabs -D_FILE_OFFSET_BITS=64
-LIBS=-L/opt/lib -R/opt/lib /opt/lib/libft.a -lsocket -lnsl -lz
-INCLUDES=-I/opt/include
-+CC ?= cc
-+LIBS = -L%%PREFIX%%/lib -lft -lz
-+INCLUDES = -I%%PREFIX%%/include
++#CC=gcc
++#FLAGS=-ggdb3 -gstabs -D_FILE_OFFSET_BITS=64
++#LIBS=-L/opt/lib -R/opt/lib /opt/lib/libft.a -lsocket -lnsl -lz
++#INCLUDES=-I/opt/include
#
# For Linux
#
-@@ -30,7 +29,7 @@
+@@ -22,9 +22,9 @@
+ #INCLUDES=
+ #
+ # For BSD
+-FLAGS=-ggdb3 -gstabs -D_FILE_OFFSET_BITS=64
+-LIBS=-L/usr/local/netflow/lib /usr/local/netflow/lib/libft.a -lz
+-INCLUDES=-I/usr/local/netflow/include
++CC ?= cc
++LIBS=-L%%PREFIX%%/lib -lft -lz
++INCLUDES=-I%%PREFIX%%/include
+ #
+ #
+ #------------------------------------------------------------------------
+@@ -36,7 +36,7 @@
#CC = cc
LIB=$(LIBS)
-CFLAGS=-O $(FLAGS) $(INCLUDES)
-+CFLAGS+=$(INCLUDES)
++CFLAGS=$(INCLUDES)
all: flow-extract
diff --git a/net-mgmt/flow-extract/files/patch-includes b/net-mgmt/flow-extract/files/patch-includes
deleted file mode 100644
index b5145272ce2b..000000000000
--- a/net-mgmt/flow-extract/files/patch-includes
+++ /dev/null
@@ -1,70 +0,0 @@
---- extract.c.orig Mon Jun 17 16:59:16 2002
-+++ extract.c Fri Mar 14 13:01:27 2003
-@@ -13,7 +13,6 @@
- #include <sys/stat.h>
- #include <netdb.h>
- #include <errno.h>
--#include <malloc.h>
- #include <unistd.h>
- #include <netinet/in.h>
- #include <netinet/in_systm.h>
-@@ -22,7 +21,6 @@
-
-
- #include <ftlib.h>
--#include <fmt.h>
- #include "extract.h"
- #include "chario.h"
- #include "parser.h"
---- chario.c.orig Mon Jun 17 16:59:16 2002
-+++ chario.c Fri Mar 14 13:01:27 2003
-@@ -11,7 +11,7 @@
- #include <stdio.h>
- #include <sys/stat.h>
- #include <string.h>
--#include <malloc.h>
-+#include <stdlib.h>
- #include "stdunix.h"
-
- #include "chario.h"
---- grammar.y.orig Mon Jun 17 16:59:16 2002
-+++ grammar.y Fri Mar 14 13:01:27 2003
-@@ -13,7 +13,7 @@
- #include <netdb.h>
- #include <sys/types.h>
- #include <netinet/in.h>
--#include <malloc.h>
-+#include <stdlib.h>
- #include "lex.h"
- #include "chario.h"
- #include "parser.h"
---- lex.c.orig Mon Jun 17 16:59:16 2002
-+++ lex.c Fri Mar 14 13:01:27 2003
-@@ -9,15 +9,13 @@
- */
- #include <stdio.h>
- #include <ctype.h>
--#include <malloc.h>
-+#include <stdlib.h>
- #include "y.tab.h"
- #include "lex.h"
- #include "chario.h"
-
- #define TRUE 1
- #define FALSE 0
--
--extern int atoi(char *);
-
- static int buflen = 0;
- static int bufptr = 0;
---- builder.c.orig Fri Mar 14 13:03:45 2003
-+++ builder.c Fri Mar 14 13:03:55 2003
-@@ -8,7 +8,7 @@
-
- */
- #include <stdio.h>
--#include <malloc.h>
-+#include <stdlib.h>
- #include "stdunix.h"
-
- #include "parser.h"