aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/flow-tools-ng
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2010-03-14 16:56:00 +0000
committerAlberto Villa <avilla@FreeBSD.org>2010-03-14 16:56:00 +0000
commit0d4b4662cc60497b7cac75f957417b095e8a4d4e (patch)
tree3ce39ce0c1cb61effe5d17213e067fab46472728 /net-mgmt/flow-tools-ng
parentef0ec4a76ef316d9fe06b8b745d1a7fb5175da7a (diff)
downloadports-0d4b4662cc60497b7cac75f957417b095e8a4d4e.tar.gz
ports-0d4b4662cc60497b7cac75f957417b095e8a4d4e.zip
Notes
Diffstat (limited to 'net-mgmt/flow-tools-ng')
-rw-r--r--net-mgmt/flow-tools-ng/Makefile1
-rw-r--r--net-mgmt/flow-tools-ng/files/flow_capture.in16
-rw-r--r--net-mgmt/flow-tools-ng/files/flow_fanout.in16
3 files changed, 27 insertions, 6 deletions
diff --git a/net-mgmt/flow-tools-ng/Makefile b/net-mgmt/flow-tools-ng/Makefile
index 7eccce926644..c53401dcc77b 100644
--- a/net-mgmt/flow-tools-ng/Makefile
+++ b/net-mgmt/flow-tools-ng/Makefile
@@ -7,6 +7,7 @@
PORTNAME= flow-tools
PORTVERSION= 0.68.5
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMESUFFIX= -ng
diff --git a/net-mgmt/flow-tools-ng/files/flow_capture.in b/net-mgmt/flow-tools-ng/files/flow_capture.in
index 856695d6fedf..d378c6c7fc59 100644
--- a/net-mgmt/flow-tools-ng/files/flow_capture.in
+++ b/net-mgmt/flow-tools-ng/files/flow_capture.in
@@ -14,9 +14,9 @@
# flow_capture_datadir (str): Base flow data directory.
# Default is "/var/db/flows"
# flow_capture_localip (str): IP address to bind to
-# Default to "0.0.0.0"
+# Default is "0.0.0.0"
# flow_capture_remoteip (str): IP address to accept flows from
-# Default to "0.0.0.0" or all IPs
+# Default is "0.0.0.0" or all IPs
# flow_capture_port (int): Port to accept flow data on
# Default is "8787"
# flow_capture_flags (str): Custom additional arguments to be passed
@@ -39,7 +39,7 @@
# with parameters taken from appropriate
# flow_capture_PROFILENAME_xxx variables. For
# unspecified parameters flow_capture_xxx
-# varialbes will be used.
+# variables will be used.
. /etc/rc.subr
@@ -78,6 +78,15 @@ stop_profiles()
done
}
+status_profiles()
+{
+ unset status_cmd
+ for _profile in ${flow_capture_profiles}; do
+ setup_profile_vars $_profile
+ run_rc_command "${rc_arg}"
+ done
+}
+
load_rc_config $name
: ${flow_capture_enable="NO"}
@@ -105,6 +114,7 @@ fi
if [ "${flow_capture_profiles}" ]; then
start_cmd="start_profiles"
stop_cmd="stop_profiles"
+ status_cmd="status_profiles"
fi
run_rc_command "$cmd"
diff --git a/net-mgmt/flow-tools-ng/files/flow_fanout.in b/net-mgmt/flow-tools-ng/files/flow_fanout.in
index 1d9ec7ff1116..0cc17b058e6b 100644
--- a/net-mgmt/flow-tools-ng/files/flow_fanout.in
+++ b/net-mgmt/flow-tools-ng/files/flow_fanout.in
@@ -12,9 +12,9 @@
# flow_fanout_enable (bool): Set it to "YES" to enable flow-fanout daemon.
# Set to "NO" by default.
# flow_fanout_ip (str): IP address to bind to
-# Default to "0.0.0.0"
+# Default is "0.0.0.0"
# flow_fanout_remoteip (str): IP address to accept flows from
-# Default to "0.0.0.0" or all IPs
+# Default is "0.0.0.0" or all IPs
# flow_fanout_port (int): Port to accept flow data on
# Default is "8787"
# flow_fanout_export (str): Where to send flows to. Default is "0/0/8788"
@@ -36,7 +36,7 @@
# with parameters taken from appropriate
# flow_fanout_PROFILENAME_xxx variables. For
# unspecified parameters flow_fanout_xxx
-# varialbes will be used.
+# variables will be used.
. /etc/rc.subr
@@ -73,6 +73,15 @@ stop_profiles()
done
}
+status_profiles()
+{
+ unset status_cmd
+ for _profile in ${flow_fanout_profiles}; do
+ setup_profile_vars $_profile
+ run_rc_command "${rc_arg}"
+ done
+}
+
load_rc_config $name
: ${flow_fanout_enable="NO"}
@@ -99,6 +108,7 @@ fi
if [ "${flow_fanout_profiles}" ]; then
start_cmd="start_profiles"
stop_cmd="stop_profiles"
+ status_cmd="status_profiles"
fi
run_rc_command "$cmd"