aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/flow-tools/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-12-09 14:34:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-12-09 14:34:26 +0000
commitc937cfe6f73b397b910798ab32d23bb898d6b09b (patch)
tree88a12ffb20424b0799e0e1ffbaa102bd030e14ee /net-mgmt/flow-tools/Makefile
parent573398bd128776acd639b80d9357eafec70bc2dd (diff)
downloadports-c937cfe6f73b397b910798ab32d23bb898d6b09b.tar.gz
ports-c937cfe6f73b397b910798ab32d23bb898d6b09b.zip
Notes
Diffstat (limited to 'net-mgmt/flow-tools/Makefile')
-rw-r--r--net-mgmt/flow-tools/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/net-mgmt/flow-tools/Makefile b/net-mgmt/flow-tools/Makefile
index f22bd99158d6..adf49e924be4 100644
--- a/net-mgmt/flow-tools/Makefile
+++ b/net-mgmt/flow-tools/Makefile
@@ -7,12 +7,14 @@
PORTNAME= flow-tools
PORTVERSION= 0.68
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= ftp://ftp.eng.oar.net/pub/flow-tools/
MAINTAINER= billf@FreeBSD.org
COMMENT= Suite of tools and library to work with netflow data
+USE_PYTHON_RUN= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--localstatedir=${PREFIX}
@@ -25,8 +27,17 @@ MAN1= flow-capture.1 flow-cat.1 flow-dscan.1 flow-expire.1 \
flow-tag.1 flow-tools.1 flow-tools-examples.1 \
flow-xlate.1 flow-rptfmt.1 flow-log2rrd.1 flow-rpt2rrd.1
+.if defined(WITH_PGSQL)
+CONFIGURE_ARGS+=--with-pgsql=${PREFIX}
+USE_PGSQL= yes
+.endif
+
+.if defined(WITH_MYSQL)
+CONFIGURE_ARGS+=--with-mysql=${PREFIX}
+USE_MYSQL= yes
+.endif
+
post-patch:
- ${TOUCH} -r ${WRKSRC}/configure.in.orig ${WRKSRC}/configure.in
${REINPLACE_CMD}\
-e 's|@localstatedir@/sym/|${PREFIX}/share/flow-tools/|' \
-e 's|@localstatedir@/cfg/|${PREFIX}/etc/flow-tools/|' \