aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/fprobe/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-06-03 18:56:39 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-06-03 18:56:39 +0000
commitab52677e5c991cb59d904495b35a4783db091c31 (patch)
tree8c213d5e06402a9f434010250d4239f7b62745de /net-mgmt/fprobe/Makefile
parent02f43a0ef5321843e9834baa8786fdcd74f1755c (diff)
Notes
Diffstat (limited to 'net-mgmt/fprobe/Makefile')
-rw-r--r--net-mgmt/fprobe/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-mgmt/fprobe/Makefile b/net-mgmt/fprobe/Makefile
new file mode 100644
index 000000000000..754206427c02
--- /dev/null
+++ b/net-mgmt/fprobe/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: fprobe
+# Date created: 03.06.2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fprobe
+PORTVERSION= 1.0.p5
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/.pre/}
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= Tool that collects network traffic data
+
+MAN1= fprobe.1
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ChangeLog README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>