aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/gnu-ipcalc
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2016-09-09 15:58:43 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2016-09-09 15:58:43 +0000
commit466720dc50993fd8bce669632b951b1c51d116e2 (patch)
treeadd14f7056389d2be8f5d2e59e06f1aab9d3f53b /net-mgmt/gnu-ipcalc
parent45219c9f98e1baa612eb183a915f539735b00546 (diff)
downloadports-466720dc50993fd8bce669632b951b1c51d116e2.tar.gz
ports-466720dc50993fd8bce669632b951b1c51d116e2.zip
Notes
Diffstat (limited to 'net-mgmt/gnu-ipcalc')
-rw-r--r--net-mgmt/gnu-ipcalc/Makefile43
-rw-r--r--net-mgmt/gnu-ipcalc/distinfo3
-rw-r--r--net-mgmt/gnu-ipcalc/pkg-descr11
3 files changed, 57 insertions, 0 deletions
diff --git a/net-mgmt/gnu-ipcalc/Makefile b/net-mgmt/gnu-ipcalc/Makefile
new file mode 100644
index 000000000000..6fe089e51be7
--- /dev/null
+++ b/net-mgmt/gnu-ipcalc/Makefile
@@ -0,0 +1,43 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ipcalc
+PORTVERSION= 0.1.8
+CATEGORIES= net-mgmt
+PKGNAMEPREFIX= gnu-
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Modern network address calculation tool for IPv4 and IPv6
+
+LICENSE= GPLv2
+
+CONFLICTS_INSTALL= ipcalc-[0-9]*
+
+USE_GITHUB= yes
+GH_ACCOUNT= nmav
+
+OPTIONS_DEFINE= GEOIP
+OPTIONS_DEFAULT=GEOIP
+
+GEOIP_LIB_DEPENDS= libGeoIP.so:net/GeoIP
+
+CFLAGS+= -I${LOCALBASE}/include \
+ -DLIBPATH="\"${LOCALBASE}/lib\"" \
+ -DVERSION="\"${PORTVERSION}\""
+
+GEOIP_CFLAGS+= -DUSE_DYN_GEOIP -DUSE_GEOIP
+
+PLIST_FILES= bin/ipcalc man/man1/ipcalc.1.gz
+
+do-build:
+ ${CC} ${CFLAGS} \
+ ${WRKSRC}/ipcalc.c \
+ ${WRKSRC}/ipcalc-geoip.c \
+ ${WRKSRC}/ipcalc-reverse.c \
+ -o ${WRKSRC}/ipcalc
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/gnu-ipcalc/distinfo b/net-mgmt/gnu-ipcalc/distinfo
new file mode 100644
index 000000000000..72bde260e18b
--- /dev/null
+++ b/net-mgmt/gnu-ipcalc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1473432181
+SHA256 (nmav-ipcalc-0.1.8_GH0.tar.gz) = 760af9c3b34fcbb9c5c4f9adc2dd03458ebc47c184a9656f34963ba9fcbef2cb
+SIZE (nmav-ipcalc-0.1.8_GH0.tar.gz) = 24783
diff --git a/net-mgmt/gnu-ipcalc/pkg-descr b/net-mgmt/gnu-ipcalc/pkg-descr
new file mode 100644
index 000000000000..44d06c8bafbc
--- /dev/null
+++ b/net-mgmt/gnu-ipcalc/pkg-descr
@@ -0,0 +1,11 @@
+This is a modern tool to assist in network address calculations for IPv4 and
+IPv6. It acts both as a tool to output human readable information about a
+network or address, as well as a tool suitable to be used by scripts or other
+programs.
+
+It supports printing a summary about the provided network address, multiple
+command line options per information to be printed, transparent IPv6 support,
+and in addition it will use libGeoIP if available to provide geographic
+information.
+
+WWW: https://github.com/nmav/ipcalc/