aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icinga2/Makefile
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2014-09-29 21:27:55 +0000
committerLars Engels <lme@FreeBSD.org>2014-09-29 21:27:55 +0000
commit8987561bb2804605a91d6ef86c7f7cacb4f662da (patch)
treed03c724b9b7fe1f2200d4a44c8c7845a0781ed23 /net-mgmt/icinga2/Makefile
parent4e4dc37058b3e976d8c6ebe3170314c0b341b013 (diff)
Notes
Diffstat (limited to 'net-mgmt/icinga2/Makefile')
-rw-r--r--net-mgmt/icinga2/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/net-mgmt/icinga2/Makefile b/net-mgmt/icinga2/Makefile
index d6daa07c6bb5..041df32299d1 100644
--- a/net-mgmt/icinga2/Makefile
+++ b/net-mgmt/icinga2/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= icinga2
-DISTVERSION= 2.0.1
-PORTREVISION= 1
+DISTVERSION= 2.1.1
CATEGORIES= net-mgmt
MASTER_SITES= http://github.com/Icinga/${PORTNAME}/archive/v${DISTVERSION}.tar.gz?dummy=/
@@ -11,11 +10,12 @@ COMMENT= Monitoring and management system for hosts, services and networks
LICENSE= GPLv2
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:${PORTSDIR}/devel/py-setuptools${PYTHON_SUFFIX}
LIB_DEPENDS= libboost_system.so:${PORTSDIR}/devel/boost-libs \
libexecinfo.so:${PORTSDIR}/devel/libexecinfo # for better debugging
RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
-USES= bison cmake
+USES= bison cmake python
USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
@@ -46,6 +46,7 @@ CMAKE_ARGS+= -DICINGA2_USER=${ICINGA2USER} \
-DICINGA2_GROUP=${ICINGA2GROUP} \
-DICINGA2_COMMAND_USER=${ICINGA2USER} \
-DICINGA2_COMMAND_GROUP=${ICINGA2USER} \
+ -DICINGA2_PLUGINDIR=${LOCALBASE}/libexec/nagios \
-DCMAKE_INSTALL_SYSCONFDIR=${PREFIX}/etc \
-DCMAKE_INSTALL_LOCALSTATEDIR=${LOCALSTATEDIR} \
-DCMAKE_INSTALL_MANDIR=${MANPREFIX}/man \
@@ -83,8 +84,6 @@ PLIST_SUB+= PGSQL="@comment "
post-patch:
${REINPLACE_CMD} -e '/^add_subdirectory(initsystem)/d' \
-e '/logrotate\.d/d' ${WRKSRC}/etc/CMakeLists.txt
- ${REINPLACE_CMD} 's,/usr/lib/nagios/plugins,${LOCALBASE}/libexec/nagios,g' \
- ${WRKSRC}/etc/icinga2/constants.conf
.for f in ${LINUX_CONFIG}
${REINPLACE_CMD} 's,[Ll]inux,FreeBSD,g' ${WRKSRC}/etc/icinga2/conf.d/${f}
.endfor