aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icinga2/Makefile
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2014-09-30 14:48:25 +0000
committerLars Engels <lme@FreeBSD.org>2014-09-30 14:48:25 +0000
commit326bc762797168f0e7fda2ed6da3c29e4304ded2 (patch)
treebf466c828e0445526cfd300eae06e8c6673e2405 /net-mgmt/icinga2/Makefile
parentf2a0f8142c3fff699877d97ff49455759fb49671 (diff)
downloadports-326bc762797168f0e7fda2ed6da3c29e4304ded2.tar.gz
ports-326bc762797168f0e7fda2ed6da3c29e4304ded2.zip
Notes
Diffstat (limited to 'net-mgmt/icinga2/Makefile')
-rw-r--r--net-mgmt/icinga2/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/net-mgmt/icinga2/Makefile b/net-mgmt/icinga2/Makefile
index 041df32299d1..b3b39dfc01ef 100644
--- a/net-mgmt/icinga2/Makefile
+++ b/net-mgmt/icinga2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= icinga2
DISTVERSION= 2.1.1
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://github.com/Icinga/${PORTNAME}/archive/v${DISTVERSION}.tar.gz?dummy=/
@@ -20,13 +21,13 @@ USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS EXAMPLES
OPTIONS_MULTI= BACKEND
OPTIONS_MULTI_BACKEND= MYSQL PGSQL
OPTIONS_RADIO= PLUGINS
OPTIONS_RADIO_PLUGINS= MONPLUGINS NAGPLUGINS
-OPTIONS_DEFAULT= MYSQL MONPLUGINS
+OPTIONS_DEFAULT= MYSQL MONPLUGINS EXAMPLES
MONPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net-mgmt/monitoring-plugins
NAGPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net-mgmt/nagios-plugins
@@ -56,6 +57,7 @@ SUB_LIST= ICINGA2LOGDIR=${ICINGA2LOGDIR} \
ICINGA2GROUP=${ICINGA2GROUP} \
WWWGRP=${WWWGRP}
+# Config files with references to "Linux"
LINUX_CONFIG= groups.conf services.conf hosts/localhost.conf
.include <bsd.port.pre.mk>
@@ -75,7 +77,7 @@ PLIST_SUB+= MYSQL="@comment "
.endif
.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
+USES+= pgsql
PLIST_SUB+= PGSQL=""
.else
PLIST_SUB+= PGSQL="@comment "
@@ -94,4 +96,12 @@ post-patch:
${REINPLACE_CMD} '/^add_subdirectory(db_ido_pgsql)/d' ${WRKSRC}/components/CMakeLists.txt
.endif
+post-install:
+.if ${PORT_OPTIONS:MEXAMPLES}
+.for db in mysql pgsql
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/${db}
+ (cd ${WRKSRC}/components/db_ido_${db} && ${COPYTREE_SHARE} schema ${STAGEDIR}${EXAMPLESDIR}/${db})
+.endfor
+.endif
+
.include <bsd.port.post.mk>