aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icinga
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2013-05-10 08:53:27 +0000
committerLars Engels <lme@FreeBSD.org>2013-05-10 08:53:27 +0000
commit88bd29ad445ddfdb8bbba11ee267b153b317d397 (patch)
tree8248f1ffb1a41990313db17aa9a4bf926ffb64fc /net-mgmt/icinga
parenta9b5cf967f3304d91e46227c101453b72b699869 (diff)
downloadports-88bd29ad445ddfdb8bbba11ee267b153b317d397.tar.gz
ports-88bd29ad445ddfdb8bbba11ee267b153b317d397.zip
Notes
Diffstat (limited to 'net-mgmt/icinga')
-rw-r--r--net-mgmt/icinga/Makefile13
-rw-r--r--net-mgmt/icinga/distinfo4
-rw-r--r--net-mgmt/icinga/files/patch-Makefile.in120
-rw-r--r--net-mgmt/icinga/files/patch-base-Makefile.in10
-rw-r--r--net-mgmt/icinga/files/patch-module-idoutils-src-Makefile.in12
-rw-r--r--net-mgmt/icinga/pkg-plist132
6 files changed, 152 insertions, 139 deletions
diff --git a/net-mgmt/icinga/Makefile b/net-mgmt/icinga/Makefile
index 5159eba254a4..5a982f999c9f 100644
--- a/net-mgmt/icinga/Makefile
+++ b/net-mgmt/icinga/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: icinga
-# Date created: 2012/02/10
-# Whom: chinsan
-#
+# Created by: chinsan
# $FreeBSD$
-#
PORTNAME= icinga
-PORTVERSION= 1.8.4
+PORTVERSION= 1.9.0
CATEGORIES= net-mgmt
MASTER_SITES= SF
@@ -113,9 +109,10 @@ CONFIGURE_ARGS+= --enable-idoutils \
--with-dbi-inc=${LOCALBASE}/include
INSTALL_TARGET+= install-idoutils
USE_RC_SUBR+= ido2db
-PLIST_SUB+= IDOUTILS=""
+PLIST_SUB+= IDOUTILS=""
.else
-PLIST_SUB+= IDOUTILS="@comment "
+PLIST_SUB+= IDOUTILS="@comment "
+CONFIGURE_ARGS+= --disable-idoutils
.endif
.if ${PORT_OPTIONS:MAPACHE}
diff --git a/net-mgmt/icinga/distinfo b/net-mgmt/icinga/distinfo
index 603c9bb67a32..17e7d50c8400 100644
--- a/net-mgmt/icinga/distinfo
+++ b/net-mgmt/icinga/distinfo
@@ -1,2 +1,2 @@
-SHA256 (icinga-1.8.4.tar.gz) = e1ecbc6c83bb8b2d4d29934182b101f305c8d45873b0cefe452dd913ee5b6de1
-SIZE (icinga-1.8.4.tar.gz) = 7459130
+SHA256 (icinga-1.9.0.tar.gz) = c98d74e4f8f94a666b35d11bc550eefe0b617acc52c92497cbc71a4bf9c46622
+SIZE (icinga-1.9.0.tar.gz) = 17075732
diff --git a/net-mgmt/icinga/files/patch-Makefile.in b/net-mgmt/icinga/files/patch-Makefile.in
index ca319f03aaf5..c507f1dd3377 100644
--- a/net-mgmt/icinga/files/patch-Makefile.in
+++ b/net-mgmt/icinga/files/patch-Makefile.in
@@ -1,37 +1,22 @@
---- Makefile.in.orig 2012-05-15 13:00:56.000000000 +0000
-+++ Makefile.in 2012-05-16 21:00:54.567967366 +0000
-@@ -362,13 +362,13 @@
- $(MAKE) install-basic
+--- Makefile.in.orig 2013-05-10 08:48:51.000000000 +0200
++++ Makefile.in 2013-05-10 08:50:03.000000000 +0200
+@@ -427,8 +427,8 @@ install-basic:
- install-basic:
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(LIBEXECDIR)
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(LOGDIR)
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(LOGDIR)/archives
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CHECKRESULTDIR)
-+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(LIBEXECDIR)
-+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(LOGDIR)
-+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(LOGDIR)/archives
-+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(CHECKRESULTDIR)
- if [ $(INSTALLPERLSTUFF) = yes ]; then \
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(P1FILELOC); \
-- $(INSTALL) -m 664 $(INSTALL_OPTS) p1.pl $(DESTDIR)$(P1FILELOC); \
-+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(P1FILELOC); \
-+ $(INSTALL) -m 644 $(INSTALL_OPTS) p1.pl $(DESTDIR)$(P1FILELOC); \
- fi;
-
- @echo ""
-@@ -405,23 +405,23 @@
+ install-cgiconf:
+ $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)
+- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/cgi.cfg $(DESTDIR)$(CFGDIR)/cgi.cfg
+- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/cgiauth.cfg $(DESTDIR)$(CFGDIR)/cgiauth.cfg
++ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/cgi.cfg $(DESTDIR)$(CFGDIR)/cgi.cfg-sample
++ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/cgiauth.cfg $(DESTDIR)$(CFGDIR)/cgiauth.cfg-sample
- install-config:
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/objects
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/conf.d
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/modules
+ install-config: install-cgiconf
+@@ -436,17 +436,17 @@ install-config: install-cgiconf
+ $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/objects
+ $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/conf.d
+ $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/modules
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/icinga.cfg $(DESTDIR)$(CFGDIR)/icinga.cfg
- $(INSTALL) -b -m 660 $(INSTALL_OPTS) sample-config/resource.cfg $(DESTDIR)$(CFGDIR)/resource.cfg
-- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/cgi.cfg $(DESTDIR)$(CFGDIR)/cgi.cfg
-- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/cgiauth.cfg $(DESTDIR)$(CFGDIR)/cgiauth.cfg
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/templates.cfg $(DESTDIR)$(CFGDIR)/objects/templates.cfg
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/commands.cfg $(DESTDIR)$(CFGDIR)/objects/commands.cfg
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/contacts.cfg $(DESTDIR)$(CFGDIR)/objects/contacts.cfg
@@ -41,72 +26,35 @@
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/windows.cfg $(DESTDIR)$(CFGDIR)/objects/windows.cfg
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/printer.cfg $(DESTDIR)$(CFGDIR)/objects/printer.cfg
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/switch.cfg $(DESTDIR)$(CFGDIR)/objects/switch.cfg
-+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)
-+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/objects
-+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/conf.d
-+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/modules
-+ $(INSTALL) -b -m 644 $(INSTALL_OPTS) sample-config/icinga.cfg $(DESTDIR)$(CFGDIR)/icinga.cfg-sample
++ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/icinga.cfg $(DESTDIR)$(CFGDIR)/icinga.cfg-sample
+ $(INSTALL) -b -m 660 $(INSTALL_OPTS) sample-config/resource.cfg $(DESTDIR)$(CFGDIR)/resource.cfg-sample
-+ $(INSTALL) -b -m 644 $(INSTALL_OPTS) sample-config/cgi.cfg $(DESTDIR)$(CFGDIR)/cgi.cfg-sample
-+ $(INSTALL) -b -m 644 $(INSTALL_OPTS) sample-config/cgiauth.cfg $(DESTDIR)$(CFGDIR)/cgiauth.cfg-sample
-+ $(INSTALL) -b -m 644 $(INSTALL_OPTS) sample-config/template-object/templates.cfg $(DESTDIR)$(CFGDIR)/objects/templates.cfg-sample
-+ $(INSTALL) -b -m 644 $(INSTALL_OPTS) sample-config/template-object/commands.cfg $(DESTDIR)$(CFGDIR)/objects/commands.cfg-sample
-+ $(INSTALL) -b -m 644 $(INSTALL_OPTS) sample-config/template-object/contacts.cfg $(DESTDIR)$(CFGDIR)/objects/contacts.cfg-sample
-+ $(INSTALL) -b -m 644 $(INSTALL_OPTS) sample-config/template-object/notifications.cfg $(DESTDIR)$(CFGDIR)/objects/notifications.cfg-sample
-+ $(INSTALL) -b -m 644 $(INSTALL_OPTS) sample-config/template-object/timeperiods.cfg $(DESTDIR)$(CFGDIR)/objects/timeperiods.cfg-sample
-+ $(INSTALL) -b -m 644 $(INSTALL_OPTS) sample-config/template-object/localhost.cfg $(DESTDIR)$(CFGDIR)/objects/localhost.cfg-sample
-+ $(INSTALL) -b -m 644 $(INSTALL_OPTS) sample-config/template-object/windows.cfg $(DESTDIR)$(CFGDIR)/objects/windows.cfg-sample
-+ $(INSTALL) -b -m 644 $(INSTALL_OPTS) sample-config/template-object/printer.cfg $(DESTDIR)$(CFGDIR)/objects/printer.cfg-sample
-+ $(INSTALL) -b -m 644 $(INSTALL_OPTS) sample-config/template-object/switch.cfg $(DESTDIR)$(CFGDIR)/objects/switch.cfg-sample
++ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/templates.cfg $(DESTDIR)$(CFGDIR)/objects/templates.cfg-sample
++ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/commands.cfg $(DESTDIR)$(CFGDIR)/objects/commands.cfg-sample
++ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/contacts.cfg $(DESTDIR)$(CFGDIR)/objects/contacts.cfg-sample
++ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/notifications.cfg $(DESTDIR)$(CFGDIR)/objects/notifications.cfg-sample
++ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/timeperiods.cfg $(DESTDIR)$(CFGDIR)/objects/timeperiods.cfg-sample
++ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/localhost.cfg $(DESTDIR)$(CFGDIR)/objects/localhost.cfg-sample
++ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/windows.cfg $(DESTDIR)$(CFGDIR)/objects/windows.cfg-sample
++ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/printer.cfg $(DESTDIR)$(CFGDIR)/objects/printer.cfg-sample
++ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/switch.cfg $(DESTDIR)$(CFGDIR)/objects/switch.cfg-sample
@echo ""
@echo "*** Config files installed ***"
-@@ -432,7 +432,7 @@
- @echo ""
+@@ -464,7 +464,7 @@ install-testconfig:
install-webconf:
-- $(MKDIR) -p -m 775 $(DESTDIR)$(HTTPD_CONF)
-+ $(MKDIR) -p -m 755 $(DESTDIR)$(HTTPD_CONF)
- $(INSTALL) -m 644 sample-config/httpd.conf $(DESTDIR)$(HTTPD_CONF)/icinga.conf
+ $(MKDIR) -p -m 775 $(DESTDIR)$(HTTPD_CONF)
+- $(INSTALL) -b -m 644 $(INSTALL_OPTS) sample-config/httpd.conf $(DESTDIR)$(HTTPDCONFFILE)
++ $(INSTALL) -b -m 644 $(INSTALL_OPTS) sample-config/httpd.conf $(DESTDIR)$(HTTPDCONFFILE)-sample
@echo ""
-@@ -481,7 +481,7 @@
-
-
- install-commandmode:
-- $(INSTALL) -m 775 $(COMMAND_OPTS) -d $(DESTDIR)$(EXTCMDFILEDIR)
-+ $(INSTALL) -m 755 $(COMMAND_OPTS) -d $(DESTDIR)$(EXTCMDFILEDIR)
- chmod g+s $(DESTDIR)$(EXTCMDFILEDIR)
+ @echo "*** Icinga/Apache conf file installed ***"
+@@ -472,7 +472,7 @@ install-webconf:
- @echo ""
-@@ -489,18 +489,18 @@
- @echo ""
+ install-webconf-auth:
- install-eventhandlers:
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(EVENTHANDLERDIR)
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(EVENTHANDLERDIR)/distributed-monitoring
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(EVENTHANDLERDIR)/redundancy-scenario1
-- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/submit_check_result $(DESTDIR)$(EVENTHANDLERDIR)/submit_check_result
-- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/disable_active_service_checks $(DESTDIR)$(EVENTHANDLERDIR)/disable_active_service_checks
-- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/enable_active_service_checks $(DESTDIR)$(EVENTHANDLERDIR)/enable_active_service_checks
-- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/disable_notifications $(DESTDIR)$(EVENTHANDLERDIR)/disable_notifications
-- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/enable_notifications $(DESTDIR)$(EVENTHANDLERDIR)/enable_notifications
-- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/distributed-monitoring/obsessive_svc_handler $(DESTDIR)$(EVENTHANDLERDIR)/distributed-monitoring/obsessive_svc_handler
-- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/distributed-monitoring/submit_check_result_via_nsca $(DESTDIR)$(EVENTHANDLERDIR)/distributed-monitoring/submit_check_result_via_nsca
-- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/redundancy-scenario1/handle-master-host-event $(DESTDIR)$(EVENTHANDLERDIR)/redundancy-scenario1/handle-master-host-event
-- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/redundancy-scenario1/handle-master-proc-event $(DESTDIR)$(EVENTHANDLERDIR)/redundancy-scenario1/handle-master-proc-event
-+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(EVENTHANDLERDIR)
-+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(EVENTHANDLERDIR)/distributed-monitoring
-+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(EVENTHANDLERDIR)/redundancy-scenario1
-+ $(INSTALL) -b -m 755 $(INSTALL_OPTS) contrib/eventhandlers/submit_check_result $(DESTDIR)$(EVENTHANDLERDIR)/submit_check_result
-+ $(INSTALL) -b -m 755 $(INSTALL_OPTS) contrib/eventhandlers/disable_active_service_checks $(DESTDIR)$(EVENTHANDLERDIR)/disable_active_service_checks
-+ $(INSTALL) -b -m 755 $(INSTALL_OPTS) contrib/eventhandlers/enable_active_service_checks $(DESTDIR)$(EVENTHANDLERDIR)/enable_active_service_checks
-+ $(INSTALL) -b -m 755 $(INSTALL_OPTS) contrib/eventhandlers/disable_notifications $(DESTDIR)$(EVENTHANDLERDIR)/disable_notifications
-+ $(INSTALL) -b -m 755 $(INSTALL_OPTS) contrib/eventhandlers/enable_notifications $(DESTDIR)$(EVENTHANDLERDIR)/enable_notifications
-+ $(INSTALL) -b -m 755 $(INSTALL_OPTS) contrib/eventhandlers/distributed-monitoring/obsessive_svc_handler $(DESTDIR)$(EVENTHANDLERDIR)/distributed-monitoring/obsessive_svc_handler
-+ $(INSTALL) -b -m 755 $(INSTALL_OPTS) contrib/eventhandlers/distributed-monitoring/submit_check_result_via_nsca $(DESTDIR)$(EVENTHANDLERDIR)/distributed-monitoring/submit_check_result_via_nsca
-+ $(INSTALL) -b -m 755 $(INSTALL_OPTS) contrib/eventhandlers/redundancy-scenario1/handle-master-host-event $(DESTDIR)$(EVENTHANDLERDIR)/redundancy-scenario1/handle-master-host-event
-+ $(INSTALL) -b -m 755 $(INSTALL_OPTS) contrib/eventhandlers/redundancy-scenario1/handle-master-proc-event $(DESTDIR)$(EVENTHANDLERDIR)/redundancy-scenario1/handle-master-proc-event
+- $(INSTALL) -b -m 644 $(INSTALL_OPTS) icinga.htpasswd $(DESTDIR)$(HTTPAUTHFILE)
++ $(INSTALL) -b -m 644 $(INSTALL_OPTS) icinga.htpasswd $(DESTDIR)$(HTTPAUTHFILE)-sample
@echo ""
- @echo "*** Sample Eventhandlers installed ***"
+ @echo "*** Icinga http auth file installed ***"
diff --git a/net-mgmt/icinga/files/patch-base-Makefile.in b/net-mgmt/icinga/files/patch-base-Makefile.in
index 9fa08e426a65..80b9e6ed4e85 100644
--- a/net-mgmt/icinga/files/patch-base-Makefile.in
+++ b/net-mgmt/icinga/files/patch-base-Makefile.in
@@ -1,6 +1,6 @@
---- base/Makefile.in.orig 2012-05-15 13:00:56.000000000 +0000
-+++ base/Makefile.in 2012-05-16 19:18:25.684923160 +0000
-@@ -207,8 +207,8 @@
+--- base/Makefile.in.orig 2013-05-10 10:15:47.000000000 +0200
++++ base/Makefile.in 2013-05-10 10:16:17.000000000 +0200
+@@ -207,8 +207,8 @@ install-unstripped:
$(MAKE) install-basic
install-basic:
@@ -8,6 +8,6 @@
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(LIBDIR)
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(BINDIR)
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(LIBDIR)
- $(INSTALL) -m 774 $(INSTALL_OPTS) @icinga_name@ $(DESTDIR)$(BINDIR)
- $(INSTALL) -m 774 $(INSTALL_OPTS) @icingastats_name@ $(DESTDIR)$(BINDIR)
+ $(INSTALL) -m 755 $(INSTALL_OPTS) @icinga_name@ $(DESTDIR)$(BINDIR)
+ $(INSTALL) -m 755 $(INSTALL_OPTS) @icingastats_name@ $(DESTDIR)$(BINDIR)
diff --git a/net-mgmt/icinga/files/patch-module-idoutils-src-Makefile.in b/net-mgmt/icinga/files/patch-module-idoutils-src-Makefile.in
index cd351c24bfba..2980baf56a2f 100644
--- a/net-mgmt/icinga/files/patch-module-idoutils-src-Makefile.in
+++ b/net-mgmt/icinga/files/patch-module-idoutils-src-Makefile.in
@@ -1,6 +1,6 @@
---- module/idoutils/src/Makefile.in.orig 2012-05-20 22:27:17.000000000 +0200
-+++ module/idoutils/src/Makefile.in 2012-05-20 22:27:40.000000000 +0200
-@@ -112,8 +112,8 @@
+--- module/idoutils/src/Makefile.in.orig 2013-05-10 10:17:03.000000000 +0200
++++ module/idoutils/src/Makefile.in 2013-05-10 10:17:26.000000000 +0200
+@@ -112,8 +112,8 @@ install:
@echo "Going to uninstall old idomod.o in $(DESTDIR)$(BINDIR)/idomod.o ..."
rm -f $(DESTDIR)$(BINDIR)/idomod.o
@echo "Resuming with install..."
@@ -8,6 +8,6 @@
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(LIBDIR)
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(BINDIR)
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(LIBDIR)
- $(INSTALL) -m 774 $(INSTALL_OPTS) ido2db $(DESTDIR)$(BINDIR)
- $(INSTALL) -m 774 $(INSTALL_OPTS) log2ido $(DESTDIR)$(BINDIR)
- $(INSTALL) -m 774 $(INSTALL_OPTS) idomod.so $(DESTDIR)$(LIBDIR)
+ $(INSTALL) -m 755 $(INSTALL_OPTS) ido2db $(DESTDIR)$(BINDIR)
+ $(INSTALL) -m 755 $(INSTALL_OPTS) log2ido $(DESTDIR)$(BINDIR)
+ $(INSTALL) -m 755 $(INSTALL_OPTS) idomod.so $(DESTDIR)$(LIBDIR)
diff --git a/net-mgmt/icinga/pkg-plist b/net-mgmt/icinga/pkg-plist
index 306c586b6335..98abbac7ffa8 100644
--- a/net-mgmt/icinga/pkg-plist
+++ b/net-mgmt/icinga/pkg-plist
@@ -38,6 +38,7 @@ libexec/icinga/eventhandlers/submit_check_result
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/config/idoutils.cfg-sample
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/config/idoutils.cfg-sample.in
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/config/updates/ido2db.cfg_added_1.7_to_1.8.cfg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/config/updates/ido2db.cfg_added_1.8_to_1.9.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/mysql.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-0.8.3.sql
@@ -53,6 +54,7 @@ libexec/icinga/eventhandlers/submit_check_result
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.6.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.7.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.8.0.sql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.9.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/create_icinga_objects_oracle.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/create_oracle_sys.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/icinga_defines.sql
@@ -69,6 +71,7 @@ libexec/icinga/eventhandlers/submit_check_result
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/upgrade/oracle-upgrade-1.6.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/upgrade/oracle-upgrade-1.7.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/upgrade/oracle-upgrade-1.8.0.sql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/upgrade/oracle-upgrade-1.9.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/upgrade/oracle_alter_icinga13_numbers.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/upgrade/oracle_alter_icinga13_objects.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/upgrade/oracle_recreate_icinga13_functions.sql
@@ -82,6 +85,7 @@ libexec/icinga/eventhandlers/submit_check_result
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/pgsql/upgrade/pgsql-upgrade-1.6.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/pgsql/upgrade/pgsql-upgrade-1.7.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/pgsql/upgrade/pgsql-upgrade-1.8.0.sql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/pgsql/upgrade/pgsql-upgrade-1.9.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/queries/comment_history.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/queries/comments.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/queries/contact_notification_methods.sql
@@ -242,8 +246,6 @@ libexec/icinga/eventhandlers/submit_check_result
%%ICINGAWWWDIR%%/docs/de/recurring_downtimes.html
%%ICINGAWWWDIR%%/docs/de/redundancy.html
%%ICINGAWWWDIR%%/docs/de/reporting.html
-%%ICINGAWWWDIR%%/docs/de/reporting_1.6.html
-%%ICINGAWWWDIR%%/docs/de/reporting_1.8.html
%%ICINGAWWWDIR%%/docs/de/security.html
%%ICINGAWWWDIR%%/docs/de/servicechecks.html
%%ICINGAWWWDIR%%/docs/de/stalking.html
@@ -363,8 +365,6 @@ libexec/icinga/eventhandlers/submit_check_result
%%ICINGAWWWDIR%%/docs/en/recurring_downtimes.html
%%ICINGAWWWDIR%%/docs/en/redundancy.html
%%ICINGAWWWDIR%%/docs/en/reporting.html
-%%ICINGAWWWDIR%%/docs/en/reporting_1.6.html
-%%ICINGAWWWDIR%%/docs/en/reporting_1.8.html
%%ICINGAWWWDIR%%/docs/en/security.html
%%ICINGAWWWDIR%%/docs/en/servicechecks.html
%%ICINGAWWWDIR%%/docs/en/stalking.html
@@ -380,6 +380,55 @@ libexec/icinga/eventhandlers/submit_check_result
%%ICINGAWWWDIR%%/docs/en/volatileservices.html
%%ICINGAWWWDIR%%/docs/en/whatsnew.html
%%ICINGAWWWDIR%%/docs/images/Architecture_1.5_800px.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_BusinessProcess-150x150.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_BusinessProcess.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_Commands-150x150.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_Commands.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_CronkBuilder-150x150.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_CronkBuilder.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_Cronk_Configuration-150x150.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_Cronk_Configuration.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_Cronk_HostFiltered-150x150.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_Downtimes-150x150.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_Downtimes.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_HostStatus_Events-150x150.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_HostStatus_Events.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_Host_filtered-150x150.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_Host_filtered.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_LogViewer-150x150.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_LogViewer.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_OpenProblems-150x150.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_OpenProblems.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_Portal2-150x150.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_Portal2.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_Reporting-150x150.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_Reporting.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_Search-150x150.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_Search.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_StatusMap-150x150.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_StatusMap.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_TacticalOverview-150x150.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_TacticalOverview.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_UserAdmin-150x150.png
+%%ICINGAWWWDIR%%/docs/images/IcingaWeb_UserAdmin.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_CGIConfig-150x150.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_CGIConfig.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_Commands-150x150.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_Commands.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_DatePicker-150x150.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_DatePicker.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_Downtimes-150x150.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_Downtimes.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_HostGroup-150x150.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_HostGroup.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_PaginationLogs-150x150.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_PaginationLogs.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_ServiceStatus-150x150.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_ServiceStatus.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_TacticalOverview-150x150.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_TacticalOverview.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_Trending-150x150.png
+%%ICINGAWWWDIR%%/docs/images/Icinga_Classic_Trending.png
%%ICINGAWWWDIR%%/docs/images/MyServiceStatus.png
%%ICINGAWWWDIR%%/docs/images/activechecks.png
%%ICINGAWWWDIR%%/docs/images/cachedcheckgraphs.png
@@ -454,6 +503,7 @@ libexec/icinga/eventhandlers/submit_check_result
%%ICINGAWWWDIR%%/docs/images/icinga-reporting_1.6.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-admin_groups1.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-admin_groups1_1.6.png
+%%ICINGAWWWDIR%%/docs/images/icinga-web-admin_groups1_1.9.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-admin_groups2.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-admin_groups2_1.6.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-admin_logs1.png
@@ -461,6 +511,7 @@ libexec/icinga/eventhandlers/submit_check_result
%%ICINGAWWWDIR%%/docs/images/icinga-web-admin_tasks.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-admin_users1.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-admin_users1_1.6.png
+%%ICINGAWWWDIR%%/docs/images/icinga-web-admin_users1_1.9.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-admin_users2.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-admin_users2_1.6.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-commands_hst.png
@@ -471,16 +522,19 @@ libexec/icinga/eventhandlers/submit_check_result
%%ICINGAWWWDIR%%/docs/images/icinga-web-commands_svc_1.3.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-commands_svc_1.5.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-commands_svc_1.6.png
+%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks-settings_1.9.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks1.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks1_1.3.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks1_1.5.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks1_1.6.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks1_1.7.png
+%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks1_1.9.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks2.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks2_1.3.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks2_1.5.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks2_1.6.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks2_1.7.png
+%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks2_1.9.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks2a.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks2a_1.6.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks2a_1.7.png
@@ -489,12 +543,20 @@ libexec/icinga/eventhandlers/submit_check_result
%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks3_1.5.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks3_1.6.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks3_1.7.png
+%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks3_1.9.png
+%%ICINGAWWWDIR%%/docs/images/icinga-web-cronks4_1.9.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-filter1.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-filter1_1.3.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-filter1_1.6.png
+%%ICINGAWWWDIR%%/docs/images/icinga-web-filter1_1.9.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-filter2.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-filter2_1.3.png
+%%ICINGAWWWDIR%%/docs/images/icinga-web-filter2_1.9.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-filter3.png
+%%ICINGAWWWDIR%%/docs/images/icinga-web-filter3_1.9.png
+%%ICINGAWWWDIR%%/docs/images/icinga-web-filter4_1.9.png
+%%ICINGAWWWDIR%%/docs/images/icinga-web-filter5_1.9.png
+%%ICINGAWWWDIR%%/docs/images/icinga-web-filter6_1.9.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-host-obj.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-host-obj1.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-host_1.5.png
@@ -520,6 +582,7 @@ libexec/icinga/eventhandlers/submit_check_result
%%ICINGAWWWDIR%%/docs/images/icinga-web-overview_1.6.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-overview_1.7.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-overview_1.8.png
+%%ICINGAWWWDIR%%/docs/images/icinga-web-overview_1.9.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-search1.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-search1_1.3.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-search1_1.6.png
@@ -542,6 +605,8 @@ libexec/icinga/eventhandlers/submit_check_result
%%ICINGAWWWDIR%%/docs/images/icinga-web-topmenu1_1.7.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-topmenu2.png
%%ICINGAWWWDIR%%/docs/images/icinga-web-topmenu2_1.3.png
+%%ICINGAWWWDIR%%/docs/images/icinga-web-topmenuadmin1_1.9.png
+%%ICINGAWWWDIR%%/docs/images/icinga-web-user-prefs-logout.png
%%ICINGAWWWDIR%%/docs/images/idoutils.png
%%ICINGAWWWDIR%%/docs/images/important.gif
%%ICINGAWWWDIR%%/docs/images/important.png
@@ -711,32 +776,32 @@ libexec/icinga/eventhandlers/submit_check_result
%%ICINGAWWWDIR%%/images/zoom1.gif
%%ICINGAWWWDIR%%/images/zoom2.gif
%%ICINGAWWWDIR%%/index.html
-%%ICINGAWWWDIR%%/jquery-ui/jquery.ui.core.min.js
-%%ICINGAWWWDIR%%/jquery-ui/jquery.ui.datepicker.min.js
-%%ICINGAWWWDIR%%/jquery-ui/jquery.ui.mouse.min.js
-%%ICINGAWWWDIR%%/jquery-ui/jquery.ui.slider.min.js
-%%ICINGAWWWDIR%%/jquery-ui/jquery.ui.timepicker-addon.min.js
-%%ICINGAWWWDIR%%/jquery-ui/jquery.ui.widget.min.js
-%%ICINGAWWWDIR%%/jquery-ui/theme/images/ui-bg_flat_0_aaaaaa_40x100.png
-%%ICINGAWWWDIR%%/jquery-ui/theme/images/ui-bg_flat_75_ffffff_40x100.png
-%%ICINGAWWWDIR%%/jquery-ui/theme/images/ui-bg_glass_55_fbf9ee_1x400.png
-%%ICINGAWWWDIR%%/jquery-ui/theme/images/ui-bg_glass_65_ffffff_1x400.png
-%%ICINGAWWWDIR%%/jquery-ui/theme/images/ui-bg_glass_75_dadada_1x400.png
-%%ICINGAWWWDIR%%/jquery-ui/theme/images/ui-bg_glass_75_e6e6e6_1x400.png
-%%ICINGAWWWDIR%%/jquery-ui/theme/images/ui-bg_glass_95_fef1ec_1x400.png
-%%ICINGAWWWDIR%%/jquery-ui/theme/images/ui-bg_highlight-soft_75_cccccc_1x100.png
-%%ICINGAWWWDIR%%/jquery-ui/theme/images/ui-icons_222222_256x240.png
-%%ICINGAWWWDIR%%/jquery-ui/theme/images/ui-icons_2e83ff_256x240.png
-%%ICINGAWWWDIR%%/jquery-ui/theme/images/ui-icons_454545_256x240.png
-%%ICINGAWWWDIR%%/jquery-ui/theme/images/ui-icons_888888_256x240.png
-%%ICINGAWWWDIR%%/jquery-ui/theme/images/ui-icons_cd0a0a_256x240.png
-%%ICINGAWWWDIR%%/jquery-ui/theme/jquery.ui.all.css
-%%ICINGAWWWDIR%%/jquery-ui/theme/jquery.ui.base.css
-%%ICINGAWWWDIR%%/jquery-ui/theme/jquery.ui.core.css
-%%ICINGAWWWDIR%%/jquery-ui/theme/jquery.ui.datepicker.css
-%%ICINGAWWWDIR%%/jquery-ui/theme/jquery.ui.slider.css
-%%ICINGAWWWDIR%%/jquery-ui/theme/jquery.ui.theme.css
-%%ICINGAWWWDIR%%/jquery-ui/theme/jquery.ui.timepicker-addon.css
+%%ICINGAWWWDIR%%/jquery-ui-addon/jquery.ui.timepicker-addon.css
+%%ICINGAWWWDIR%%/jquery-ui-addon/jquery.ui.timepicker-addon.min.js
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/images/ui-bg_flat_0_aaaaaa_40x100.png
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/images/ui-bg_flat_75_ffffff_40x100.png
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/images/ui-bg_glass_55_fbf9ee_1x400.png
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/images/ui-bg_glass_65_ffffff_1x400.png
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/images/ui-bg_glass_75_dadada_1x400.png
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/images/ui-bg_glass_75_e6e6e6_1x400.png
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/images/ui-bg_glass_95_fef1ec_1x400.png
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/images/ui-bg_highlight-soft_75_cccccc_1x100.png
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/images/ui-icons_222222_256x240.png
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/images/ui-icons_2e83ff_256x240.png
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/images/ui-icons_454545_256x240.png
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/images/ui-icons_888888_256x240.png
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/images/ui-icons_cd0a0a_256x240.png
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/jquery.ui.all.css
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/jquery.ui.base.css
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/jquery.ui.core.css
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/jquery.ui.datepicker.css
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/jquery.ui.slider.css
+%%ICINGAWWWDIR%%/jquery-ui/themes/base/jquery.ui.theme.css
+%%ICINGAWWWDIR%%/jquery-ui/ui/jquery.ui.core.js
+%%ICINGAWWWDIR%%/jquery-ui/ui/jquery.ui.datepicker.js
+%%ICINGAWWWDIR%%/jquery-ui/ui/jquery.ui.mouse.js
+%%ICINGAWWWDIR%%/jquery-ui/ui/jquery.ui.slider.js
+%%ICINGAWWWDIR%%/jquery-ui/ui/jquery.ui.widget.js
%%ICINGAWWWDIR%%/js/checkbox_functions.js
%%ICINGAWWWDIR%%/js/jquery-1.8.0.min.js
%%ICINGAWWWDIR%%/js/jquery.dd.js
@@ -773,8 +838,11 @@ libexec/icinga/eventhandlers/submit_check_result
@dirrm %%ICINGAWWWDIR%%/media
@dirrm %%ICINGAWWWDIR%%/log
@dirrm %%ICINGAWWWDIR%%/js
-@dirrm %%ICINGAWWWDIR%%/jquery-ui/theme/images
-@dirrm %%ICINGAWWWDIR%%/jquery-ui/theme
+@dirrm %%ICINGAWWWDIR%%/jquery-ui/ui
+@dirrm %%ICINGAWWWDIR%%/jquery-ui/themes/base/images
+@dirrm %%ICINGAWWWDIR%%/jquery-ui/themes/base
+@dirrm %%ICINGAWWWDIR%%/jquery-ui/themes
+@dirrm %%ICINGAWWWDIR%%/jquery-ui-addon
@dirrm %%ICINGAWWWDIR%%/jquery-ui
@dirrm %%ICINGAWWWDIR%%/images/logos
@dirrm %%ICINGAWWWDIR%%/images