aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icinga
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2015-03-30 21:32:43 +0000
committerLars Engels <lme@FreeBSD.org>2015-03-30 21:32:43 +0000
commite267d4a0b8bbfcd6e2315c81156591104f84eb5a (patch)
treeeefa54b5767dfb77417f79a9b7f93630abec663e /net-mgmt/icinga
parentd9280b2e58584154061bfd2447c01056d1b6c9ee (diff)
downloadports-e267d4a0b8bbfcd6e2315c81156591104f84eb5a.tar.gz
ports-e267d4a0b8bbfcd6e2315c81156591104f84eb5a.zip
Update to 1.13.0
Notes
Notes: svn path=/head/; revision=382741
Diffstat (limited to 'net-mgmt/icinga')
-rw-r--r--net-mgmt/icinga/Makefile2
-rw-r--r--net-mgmt/icinga/distinfo4
-rw-r--r--net-mgmt/icinga/files/patch-Makefile.in48
-rw-r--r--net-mgmt/icinga/files/patch-base-Makefile.in13
-rw-r--r--net-mgmt/icinga/files/patch-configure.in10
-rw-r--r--net-mgmt/icinga/files/patch-module-idoutils-Makefile.in31
-rw-r--r--net-mgmt/icinga/pkg-plist12
7 files changed, 79 insertions, 41 deletions
diff --git a/net-mgmt/icinga/Makefile b/net-mgmt/icinga/Makefile
index 56ad4a154100..dc87020c235d 100644
--- a/net-mgmt/icinga/Makefile
+++ b/net-mgmt/icinga/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= icinga
-PORTVERSION= 1.12.2
+PORTVERSION= 1.13.0
CATEGORIES= net-mgmt
MASTER_SITES= https://github.com/Icinga/${PORTNAME}-core/releases/download/v${PORTVERSION}/
diff --git a/net-mgmt/icinga/distinfo b/net-mgmt/icinga/distinfo
index 41f614a6b14b..7578e4b1d584 100644
--- a/net-mgmt/icinga/distinfo
+++ b/net-mgmt/icinga/distinfo
@@ -1,2 +1,2 @@
-SHA256 (icinga-1.12.2.tar.gz) = 3eb3e623070996fffe8ba1d5c0fe8081d3074bca5109de4ee597a9515507a4cc
-SIZE (icinga-1.12.2.tar.gz) = 18745366
+SHA256 (icinga-1.13.0.tar.gz) = a87fcafd38b97d605b313ce52fee49751ff58ae2fa100efcfd7efa930a39178b
+SIZE (icinga-1.13.0.tar.gz) = 18736922
diff --git a/net-mgmt/icinga/files/patch-Makefile.in b/net-mgmt/icinga/files/patch-Makefile.in
index 9807e93de3cd..dcdb1817d704 100644
--- a/net-mgmt/icinga/files/patch-Makefile.in
+++ b/net-mgmt/icinga/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2014-05-28 23:00:23.000000000 +0200
-+++ Makefile.in 2014-05-30 14:58:20.687021540 +0200
-@@ -138,16 +138,16 @@ none:
+--- Makefile.in.orig 2015-03-30 10:38:53.000000000 +0200
++++ Makefile.in 2015-03-30 23:20:40.445568000 +0200
+@@ -139,16 +139,16 @@ none:
###############################
all:
@@ -22,7 +22,7 @@
fi
@echo ""
-@@ -215,7 +215,7 @@ all:
+@@ -216,7 +216,7 @@ all:
@echo ""
icinga:
@@ -31,7 +31,7 @@
config:
@echo "Sample config files are automatically generated once you run the"
-@@ -223,11 +223,11 @@ config:
+@@ -224,11 +224,11 @@ config:
@echo "system by using the 'make install-config' command."
cgis:
@@ -45,7 +45,7 @@
else \
echo "" ;\
echo "Sorry, IDOUtils not enabled!" ;\
-@@ -236,13 +236,13 @@ idoutils:
+@@ -237,13 +237,13 @@ idoutils:
fi
html:
@@ -62,7 +62,7 @@
classicui-standalone: cgis
-@@ -256,31 +256,31 @@ classicui-standalone: cgis
+@@ -257,31 +257,31 @@ classicui-standalone: cgis
###############################
clean:
@@ -112,9 +112,18 @@
+ $(MAKE) -C $(SRC_IDOUTILS) $@
+ $(MAKE) -C $(SRC_T) $@
- rm -f sample-config/*.cfg sample-config/*.conf sample-config/template-object/*.cfg
+ rm -f sample-config/*.cfg sample-config/*.conf sample-config/template-object/*.cfg sample-config/modules/*.cfg
rm -f daemon-init pkginfo rc.ido2db ido2db-systemd icinga-systemd sysconfig-env
-@@ -314,8 +314,8 @@ create-docs: copy-docs-style
+@@ -301,7 +301,7 @@ test:
+ $(MAKE) test-perl
+
+ test-perl: icinga cgis
+- cd t && $(MAKE) test
++ $(MAKE) -C t test
+
+ ###############################
+ # Package
+@@ -315,8 +315,8 @@ create-docs: copy-docs-style
#${MAKE} submodule-init
#${MAKE} submodule-update
#${MAKE} submodule-update-latest
@@ -125,7 +134,7 @@
cp ${SRC_DOCBOOK_IMAGES}/*.png ${SRC_DOCS_IMAGES}/
@echo "updated docs :)"
-@@ -352,37 +352,33 @@ submodule-update-latest:
+@@ -349,37 +349,33 @@ submodule-update-latest:
install-html:
@@ -184,7 +193,7 @@
install-config: install-cgiconf
-@@ -434,17 +430,17 @@ install-config: install-cgiconf
+@@ -434,22 +430,21 @@ install-config: install-cgiconf
$(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/objects
$(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/conf.d
$(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/modules
@@ -199,6 +208,11 @@
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/windows.cfg $(DESTDIR)$(CFGDIR)/objects/windows.cfg
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/printer.cfg $(DESTDIR)$(CFGDIR)/objects/printer.cfg
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/switch.cfg $(DESTDIR)$(CFGDIR)/objects/switch.cfg
+- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/modules/livestatus.cfg $(DESTDIR)$(CFGDIR)/modules/livestatus.cfg
+- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/modules/mod_gearman.cfg $(DESTDIR)$(CFGDIR)/modules/mod_gearman.cfg
+- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/modules/pnp4nagios.cfg $(DESTDIR)$(CFGDIR)/modules/pnp4nagios.cfg
+- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/modules/flapjack.cfg $(DESTDIR)$(CFGDIR)/modules/flapjack.cfg
+-
+ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/icinga.cfg $(DESTDIR)$(CFGDIR)/icinga.cfg.sample
+ $(INSTALL) -b -m 660 $(INSTALL_OPTS) sample-config/resource.cfg $(DESTDIR)$(CFGDIR)/resource.cfg.sample
+ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/templates.cfg $(DESTDIR)$(CFGDIR)/objects/templates.cfg.sample
@@ -210,10 +224,14 @@
+ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/windows.cfg $(DESTDIR)$(CFGDIR)/objects/windows.cfg.sample
+ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/printer.cfg $(DESTDIR)$(CFGDIR)/objects/printer.cfg.sample
+ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/switch.cfg $(DESTDIR)$(CFGDIR)/objects/switch.cfg.sample
-
++ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/modules/livestatus.cfg $(DESTDIR)$(CFGDIR)/modules/livestatus.cfg.sample
++ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/modules/mod_gearman.cfg $(DESTDIR)$(CFGDIR)/modules/mod_gearman.cfg.sample
++ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/modules/pnp4nagios.cfg $(DESTDIR)$(CFGDIR)/modules/pnp4nagios.cfg.sample
++ $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/modules/flapjack.cfg $(DESTDIR)$(CFGDIR)/modules/flapjack.cfg.sample
@echo ""
@echo "*** Config files installed ***"
-@@ -462,7 +458,7 @@ install-testconfig:
+ @echo ""
+@@ -466,7 +461,7 @@ install-testconfig:
install-webconf:
$(MKDIR) -p -m 775 $(DESTDIR)$(HTTPD_CONF)
@@ -222,7 +240,7 @@
@if [ x$(APACHE24_DEBIAN) = xyes ]; then \
echo " Debian Apache 2.4 detected. " ;\
echo " Run 'a2enconf icinga' and 'service apache2 reload'" ;\
-@@ -475,7 +471,7 @@ install-webconf:
+@@ -479,7 +474,7 @@ install-webconf:
install-webconf-auth:
$(MKDIR) -p -m 775 $(DESTDIR)$(HTTPD_CONF)
@@ -231,7 +249,7 @@
@echo ""
@echo "*** Icinga http auth file installed ***"
-@@ -484,7 +480,7 @@ install-webconf-auth:
+@@ -488,7 +483,7 @@ install-webconf-auth:
install-idoutils:
@if [ x$(USE_IDOUTILS) = xyes ]; then \
diff --git a/net-mgmt/icinga/files/patch-base-Makefile.in b/net-mgmt/icinga/files/patch-base-Makefile.in
deleted file mode 100644
index 0dcc1d0693c4..000000000000
--- a/net-mgmt/icinga/files/patch-base-Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- base/Makefile.in.orig 2014-03-13 11:46:50.000000000 +0100
-+++ base/Makefile.in 2014-03-13 21:46:18.324313068 +0100
-@@ -191,8 +191,8 @@ install-unstripped:
- $(MAKE) install-basic
-
- install-basic:
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(BINDIR)
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(LIBDIR)
-+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(BINDIR)
-+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(LIBDIR)
- $(INSTALL) -m 755 $(INSTALL_OPTS) @icinga_name@ $(DESTDIR)$(BINDIR)
- $(INSTALL) -m 755 $(INSTALL_OPTS) @icingastats_name@ $(DESTDIR)$(BINDIR)
-
diff --git a/net-mgmt/icinga/files/patch-configure.in b/net-mgmt/icinga/files/patch-configure.in
index 18f07d91a769..3877d692ce90 100644
--- a/net-mgmt/icinga/files/patch-configure.in
+++ b/net-mgmt/icinga/files/patch-configure.in
@@ -1,5 +1,5 @@
---- configure.in.orig 2014-03-13 11:46:50.000000000 +0100
-+++ configure.in 2014-03-13 21:46:18.329313645 +0100
+--- configure.in.orig 2015-03-30 10:38:53.000000000 +0200
++++ configure.in 2015-03-30 23:20:17.372353000 +0200
@@ -6,7 +6,6 @@ define([AC_CACHE_SAVE],)
AC_INIT(base/icinga.c)
@@ -7,7 +7,7 @@
-AC_PREFIX_DEFAULT(/usr/local/icinga)
PKG_NAME=icinga-core
- PKG_VERSION="1.11.0"
+ PKG_VERSION="1.13.0"
@@ -144,6 +143,15 @@ AC_TRY_COMPILE([#include <stdlib.h>
dnl Test for pthreads support - taken from ICU FreeBSD Port configure script
THREADLIBS=""
@@ -40,7 +40,7 @@
AC_SUBST(INSTALL_OPTS)
AC_ARG_WITH(command_user,AC_HELP_STRING([--with-command-user=<user>],[sets user name for command access]),command_user=$withval,command_user=$icinga_user)
-@@ -495,7 +503,7 @@ dnl Location of the embedded perl p1.pl
+@@ -503,7 +511,7 @@ dnl Location of the embedded perl p1.pl
P1FILELOC=no
AC_ARG_WITH(p1-file-dir,AC_HELP_STRING([--with-p1-file-dir=<path>],[sets path to embedded perl p1.pl directory]),P1FILELOC=$withval,P1FILELOC=no)
if test x$P1FILELOC = xno; then
@@ -49,7 +49,7 @@
fi
AC_SUBST(P1FILELOC)
-@@ -1126,6 +1134,9 @@ if test x$USEPERL = xyes; then
+@@ -1134,6 +1142,9 @@ if test x$USEPERL = xyes; then
AC_DEFINE_UNQUOTED(EMBEDDEDPERL,,[Is embedded Perl being compiled in?])
PERLLIBS="`perl -MExtUtils::Embed -e ldopts`"
diff --git a/net-mgmt/icinga/files/patch-module-idoutils-Makefile.in b/net-mgmt/icinga/files/patch-module-idoutils-Makefile.in
index 6f238e2e170b..ae0245e383a0 100644
--- a/net-mgmt/icinga/files/patch-module-idoutils-Makefile.in
+++ b/net-mgmt/icinga/files/patch-module-idoutils-Makefile.in
@@ -1,6 +1,31 @@
---- module/idoutils/Makefile.in.orig 2014-09-24 21:24:54.580929462 +0200
-+++ module/idoutils/Makefile.in 2014-09-24 21:25:56.330324547 +0200
-@@ -57,8 +57,8 @@
+--- module/idoutils/Makefile.in.orig 2015-03-30 10:38:53.000000000 +0200
++++ module/idoutils/Makefile.in 2015-03-30 23:20:17.394563000 +0200
+@@ -32,16 +32,16 @@ endif
+
+ all:
+ if [ x$(USE_IDOUTILS) = xyes ]; then \
+- cd $(SRC_BASE) && $(MAKE); \
++ $(MAKE) -C $(SRC_BASE); \
+ fi;
+
+ clean:
+- cd $(SRC_BASE) && $(MAKE) $@
++ $(MAKE) -C $(SRC_BASE) $@
+ rm -f core
+ rm -f *~ */*~
+
+ distclean: clean
+- cd $(SRC_BASE) && $(MAKE) $@
++ $(MAKE) -C $(SRC_BASE) $@
+ rm -f config.log config.status config.cache $(SRC_INCLUDE)/config.h
+ rm -f Makefile
+ rm -f init-script.suse subst
+@@ -53,12 +53,12 @@ devclean: distclean
+ install-idoutils: install
+
+ install:
+- cd $(SRC_BASE) && $(MAKE) $@
++ $(MAKE) -C $(SRC_BASE) $@
$(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)
$(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/objects
$(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/modules
diff --git a/net-mgmt/icinga/pkg-plist b/net-mgmt/icinga/pkg-plist
index ab01281a6cd2..b57634040d0d 100644
--- a/net-mgmt/icinga/pkg-plist
+++ b/net-mgmt/icinga/pkg-plist
@@ -8,6 +8,10 @@ bin/icingastats
@sample %%IDOUTILS%%%%ETCDIR%%/ido2db.cfg.sample
@sample %%IDOUTILS%%%%ETCDIR%%/idomod.cfg.sample
@sample %%IDOUTILS%%%%ETCDIR%%/modules/idoutils.cfg.sample
+@sample %%ETCDIR%%/modules/flapjack.cfg.sample
+@sample %%ETCDIR%%/modules/livestatus.cfg.sample
+@sample %%ETCDIR%%/modules/mod_gearman.cfg.sample
+@sample %%ETCDIR%%/modules/pnp4nagios.cfg.sample
@sample %%ETCDIR%%/objects/commands.cfg.sample
@sample %%ETCDIR%%/objects/contacts.cfg.sample
@sample %%IDOUTILS%%%%ETCDIR%%/objects/ido2db_check_proc.cfg.sample
@@ -37,6 +41,7 @@ libexec/icinga/eventhandlers/submit_check_result
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/config/idomod.cfg-sample.in
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/config/idoutils.cfg-sample
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/config/idoutils.cfg-sample.in
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/config/updates/ido2db.cfg_added_1.12_to_1.13.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/config/updates/ido2db.cfg_added_1.7_to_1.8.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/config/updates/ido2db.cfg_added_1.8_to_1.9.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/config/updates/ido2db.cfg_added_1.9_to_1.10.cfg
@@ -54,9 +59,11 @@ libexec/icinga/eventhandlers/submit_check_result
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.0rc.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.10.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.11.0.sql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.11.3.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.11.6.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.11.7.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.12.0.sql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.13.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.3.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.4.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.5.0.sql
@@ -64,9 +71,8 @@ libexec/icinga/eventhandlers/submit_check_result
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.7.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.8.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.9.0.sql
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/mysql/upgrade/mysql-upgrade-1.11.3.sql
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/create_oracle_sys.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/create_icinga_objects_oracle.sql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/create_oracle_sys.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/icinga_defines.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/oracle-delete.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/oracle-drop.sql
@@ -81,6 +87,7 @@ libexec/icinga/eventhandlers/submit_check_result
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/upgrade/oracle-upgrade-1.11.6.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/upgrade/oracle-upgrade-1.11.7.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/upgrade/oracle-upgrade-1.12.0.sql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/upgrade/oracle-upgrade-1.13.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/upgrade/oracle-upgrade-1.3.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/upgrade/oracle-upgrade-1.4.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/oracle/upgrade/oracle-upgrade-1.5.0.sql
@@ -101,6 +108,7 @@ libexec/icinga/eventhandlers/submit_check_result
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/pgsql/upgrade/pgsql-upgrade-1.11.6.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/pgsql/upgrade/pgsql-upgrade-1.11.7.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/pgsql/upgrade/pgsql-upgrade-1.12.0.sql
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/pgsql/upgrade/pgsql-upgrade-1.13.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/pgsql/upgrade/pgsql-upgrade-1.3.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/pgsql/upgrade/pgsql-upgrade-1.4.0.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idoutils/db/pgsql/upgrade/pgsql-upgrade-1.5.0.sql