aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icingaweb2-module-generictts/Makefile
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2017-03-08 11:49:40 +0000
committerLars Engels <lme@FreeBSD.org>2017-03-08 11:49:40 +0000
commit5b616787057d7e634c69f0c7ba3119a472c933c3 (patch)
tree54af2512897acebef6c686fbebf9bf37eb94eca3 /net-mgmt/icingaweb2-module-generictts/Makefile
parent0239e18ae0475359ba92e04376c6d29e1f21309e (diff)
downloadports-5b616787057d7e634c69f0c7ba3119a472c933c3.tar.gz
ports-5b616787057d7e634c69f0c7ba3119a472c933c3.zip
Notes
Diffstat (limited to 'net-mgmt/icingaweb2-module-generictts/Makefile')
-rw-r--r--net-mgmt/icingaweb2-module-generictts/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-mgmt/icingaweb2-module-generictts/Makefile b/net-mgmt/icingaweb2-module-generictts/Makefile
new file mode 100644
index 000000000000..a7c141914b4a
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-generictts/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= icingaweb2-module-generictts
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.0.0
+CATEGORIES= net-mgmt www
+
+MAINTAINER= lme@FreeBSD.org
+COMMENT= Generic ticket system integration into Icinga web 2
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= icingaweb2>=2.4.1:net-mgmt/icingaweb2
+
+USE_GITHUB= yes
+GH_ACCOUNT= icinga
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+WWWDIR?= ${PREFIX}/www/icingaweb2/modules/${PORTNAME:C/^.*-//}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+
+.include <bsd.port.mk>