aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/iog/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-09-25 20:24:41 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-09-25 20:24:41 +0000
commitfa8b34d548e55179c98a1f3d8f89e60ca8e6cb9c (patch)
treed065befec6fd701fc24c5246e099888549ac1897 /net-mgmt/iog/Makefile
parent42d4e1b7c0308f6b491700adaaae065cb2fc2ced (diff)
downloadports-fa8b34d548e55179c98a1f3d8f89e60ca8e6cb9c.tar.gz
ports-fa8b34d548e55179c98a1f3d8f89e60ca8e6cb9c.zip
- Use ports framework to create iog user
- Bump portrevision as both configuration file and sample configuration file were packaged
Notes
Notes: svn path=/head/; revision=369292
Diffstat (limited to 'net-mgmt/iog/Makefile')
-rw-r--r--net-mgmt/iog/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/net-mgmt/iog/Makefile b/net-mgmt/iog/Makefile
index 11f58e63fc62..0eb29c1f7888 100644
--- a/net-mgmt/iog/Makefile
+++ b/net-mgmt/iog/Makefile
@@ -3,7 +3,7 @@
PORTNAME= iog
PORTVERSION= 1.03
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt
MASTER_SITES= http://www.dynw.com/iog/
@@ -13,19 +13,15 @@ COMMENT= Graphs Byte Counts for switches/routers/etc
NO_BUILD= yes
USES= perl5 tar:tgz
PLIST_SUB= VERSION=${PORTVERSION}
-IOG_USER= iog
-IOG_GROUP= www
+USERS= iog
IOGDIR= ${PREFIX}/iog/iog-${PORTVERSION}
do-install:
- PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
+ ${FIND} ${WRKSRC} -name '*.bak' -or -name '*.orig' -delete
${MKDIR} -m 755 ${STAGEDIR}${IOGDIR}
- ${CHMOD} 0600 ${WRKSRC}/iog.cfg
- ${CP} ${WRKSRC}/iog.cfg ${WRKSRC}/iog.cfg.sample
+ ${INSTALL} ${COPY} -m 0600 ${WRKSRC}/iog.cfg ${WRKSRC}/iog.cfg.sample
${CP} -R ${WRKSRC}/* ${STAGEDIR}${IOGDIR}
- ${CP} ${STAGEDIR}${IOGDIR}/iog.cfg.sample ${STAGEDIR}${IOGDIR}/iog.cfg
- ${FIND} ${STAGEDIR}${IOGDIR} -name '*.bak' -or -name '*.orig' -delete
${LN} -sf ${IOGDIR} ${STAGEDIR}${PREFIX}/iog/iog
.include <bsd.port.mk>