aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/irrtoolset
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-12-10 21:22:32 +0000
committerSteve Price <steve@FreeBSD.org>1999-12-10 21:22:32 +0000
commit1e31fd959cf7ffd1c9afcdd56b52bd6000245631 (patch)
tree511bd1bcf822dde42c8800e9a81fd54e351fd6f6 /net-mgmt/irrtoolset
parentd71620fd04131f7dd4e28a320b4262bb7c9c9782 (diff)
downloadports-1e31fd959cf7ffd1c9afcdd56b52bd6000245631.tar.gz
ports-1e31fd959cf7ffd1c9afcdd56b52bd6000245631.zip
Revert back to 3.5.8.
Notes
Notes: svn path=/head/; revision=23768
Diffstat (limited to 'net-mgmt/irrtoolset')
-rw-r--r--net-mgmt/irrtoolset/Makefile24
-rw-r--r--net-mgmt/irrtoolset/distinfo2
-rw-r--r--net-mgmt/irrtoolset/files/patch-aa45
-rw-r--r--net-mgmt/irrtoolset/files/patch-ab20
-rw-r--r--net-mgmt/irrtoolset/files/patch-ac208
-rw-r--r--net-mgmt/irrtoolset/files/patch-ad11
-rw-r--r--net-mgmt/irrtoolset/files/patch-ae11
-rw-r--r--net-mgmt/irrtoolset/files/patch-af10
-rw-r--r--net-mgmt/irrtoolset/files/patch-ag11
-rw-r--r--net-mgmt/irrtoolset/files/patch-ah20
-rw-r--r--net-mgmt/irrtoolset/files/patch-ai11
-rw-r--r--net-mgmt/irrtoolset/files/patch-aj6
-rw-r--r--net-mgmt/irrtoolset/files/patch-ak6
-rw-r--r--net-mgmt/irrtoolset/files/patch-al11
-rw-r--r--net-mgmt/irrtoolset/files/patch-am11
-rw-r--r--net-mgmt/irrtoolset/pkg-plist12
16 files changed, 395 insertions, 24 deletions
diff --git a/net-mgmt/irrtoolset/Makefile b/net-mgmt/irrtoolset/Makefile
index d5c500e69e3c..63c8b78c52a9 100644
--- a/net-mgmt/irrtoolset/Makefile
+++ b/net-mgmt/irrtoolset/Makefile
@@ -1,13 +1,13 @@
# New ports collection makefile for: RAToolSet
-# Version required: 4.5.0
+# Version required: 3.5.8
# Date created: May 4th 1997
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $FreeBSD$
#
-DISTNAME= RAToolSet-4.5.0
-PKGNAME= ratoolset-4.5.0
+DISTNAME= RAToolSet-3.5.8
+PKGNAME= ratoolset-3.5.8
CATEGORIES= net tk82
MASTER_SITES= ftp://ftp.isi.edu/ra/RAToolSet/
@@ -15,18 +15,16 @@ MAINTAINER= jfitz@FreeBSD.org
LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
-USE_NEWGCC= YES
-USE_GMAKE= YES
-GNU_CONFIGURE= YES
-CONFIGURE_ENV= TCL_TK_INCLUDE_DIR="${LOCALBASE}/include/tcl8.2:${LOCALBASE}/include/tk8.2" \
- TCL_TK_LIBRARY_DIR=${LOCALBASE}/lib \
- TCL_LIBRARY=${LOCALBASE}/lib/tcl8.2 \
- TK_LIBRARY=${LOCALBASE}/lib/tk8.2 \
+GNU_CONFIGURE= Yes
+CONFIGURE_ENV= TCL_TK_INCLUDE_DIR="${PREFIX}/include/tcl8.2:${PREFIX}/include/tk8.2" \
+ TCL_TK_LIBRARY_DIR=${PREFIX}/lib \
+ TCL_LIBRARY=${PREFIX}/lib/tcl8.2 \
+ TK_LIBRARY=${PREFIX}/lib/tk8.2 \
LD_TCL_TK_LIBS="-ltk82 -ltcl82"
-MAN1= CIDRAdvisor.1 RtConfig.1 aoe.1 peval.1 prpath.1 \
- prtraceroute.1 roe.1 rpslcheck.1
-MAN8= prtraceroute.8
+MAN1= CIDRAdvisor.1 aoe.1 pmatch.1 prpath.1 RtConfig.1 peval.1 \
+ prcheck.1 roe.1
+MAN8= prtraceroute.8 relayd.8
ALL_TARGET= depend all
diff --git a/net-mgmt/irrtoolset/distinfo b/net-mgmt/irrtoolset/distinfo
index 41108e03c3bb..bf0f43d9ff9e 100644
--- a/net-mgmt/irrtoolset/distinfo
+++ b/net-mgmt/irrtoolset/distinfo
@@ -1 +1 @@
-MD5 (RAToolSet-4.5.0.tar.gz) = a875f79f81c08e2f3d1b23d50f04f55c
+MD5 (RAToolSet-3.5.8.tar.gz) = 4c7a04539a878ba3bcc5a6de3d12ac38
diff --git a/net-mgmt/irrtoolset/files/patch-aa b/net-mgmt/irrtoolset/files/patch-aa
new file mode 100644
index 000000000000..b4052b639c36
--- /dev/null
+++ b/net-mgmt/irrtoolset/files/patch-aa
@@ -0,0 +1,45 @@
+--- src/misc/net.hh.orig Wed Jan 28 17:40:42 1998
++++ src/misc/net.hh Sat Nov 27 18:11:23 1999
+@@ -86,12 +86,12 @@
+ int bind (...);
+ int listen (...);
+ int accept (...);
+-int recvfrom(...);
++ssize_t recvfrom(...);
+ int gethostname (...);
+ int setsockopt (...);
+ int select (...);
+-int sendto (...);
+-int send (...);
++ssize_t sendto (...);
++ssize_t send (...);
+ int gettimeofday (...);
+ }
+
+@@ -132,7 +132,7 @@
+ class Timer {
+ struct timeval tv;
+ struct timezone tz;
+- init_time () {
++ void init_time () {
+ bzero ((char *) &tv, sizeof (struct timeval));
+ ::gettimeofday (&tv, &tz);
+ }
+@@ -256,7 +256,7 @@
+ return ptr;
+ }
+ u_long getInaddr () { return hexaddr; }
+- print () { printf ("%s\n%s\n0x%x\n", hostname, dottedaddr, hexaddr); }
++ void print () { printf ("%s\n%s\n0x%x\n", hostname, dottedaddr, hexaddr); }
+
+ Error error;
+ };
+@@ -331,7 +331,7 @@
+ error.warn("listen");
+ return error();
+ }
+- accept () {
++ int accept () {
+ //u_long addrlen;
+ int addrlen = sizeof (struct sockaddr);
+ bzero ((char *) &socknew, sizeof (socknew));
diff --git a/net-mgmt/irrtoolset/files/patch-ab b/net-mgmt/irrtoolset/files/patch-ab
new file mode 100644
index 000000000000..6566ed2b1af4
--- /dev/null
+++ b/net-mgmt/irrtoolset/files/patch-ab
@@ -0,0 +1,20 @@
+--- src/dbase/Route.hh.orig Sat Nov 27 18:08:21 1999
++++ src/dbase/Route.hh Sat Nov 27 18:08:41 1999
+@@ -92,7 +92,7 @@
+ clear();
+ }
+
+- clear () {
++ void clear () {
+ pix = NULL;
+ _dontcare = 0;
+ }
+@@ -248,7 +248,7 @@
+ pref = 0;
+ }
+
+- set (Pix asn, int p) {
++ void set (Pix asn, int p) {
+ asno = asn;
+ pref = p;
+ }
diff --git a/net-mgmt/irrtoolset/files/patch-ac b/net-mgmt/irrtoolset/files/patch-ac
new file mode 100644
index 000000000000..ca2b0e1d8f1f
--- /dev/null
+++ b/net-mgmt/irrtoolset/files/patch-ac
@@ -0,0 +1,208 @@
+--- src/dbase/Node.h.orig Sat Nov 27 18:11:57 1999
++++ src/dbase/Node.h Sat Nov 27 18:16:21 1999
+@@ -101,7 +101,7 @@
+ protected:
+ virtual void print(ostream &os) = 0;
+ public:
+- virtual operator== (Node &b) = 0;
++ virtual int operator== (Node &b) = 0;
+ virtual void InOrderPrint() = 0;
+ virtual void PostOrderPrint() { InOrderPrint(); }
+ virtual ~Node() {};
+@@ -144,7 +144,7 @@
+ virtual void print(ostream &os) = 0;
+
+ public:
+- virtual Execute(Route &r) = 0;
++ virtual void Execute(Route &r) = 0;
+ virtual ActionNode *FindFirst(Node_t _type) = 0;
+ int operator< (ActionNode &b);
+ friend ostream &operator<<(ostream &os, ActionNode *an) {
+@@ -172,7 +172,7 @@
+ type = T_ANDNode;
+ }
+
+- virtual operator== (Node& b) {
++ virtual int operator== (Node& b) {
+ return b.type == T_ANDNode
+ && left == ((ANDNode&) b).left
+ && right == ((ANDNode&) b).right;
+@@ -200,7 +200,7 @@
+ type = T_ORNode;
+ }
+
+- virtual operator== (Node& b) {
++ virtual int operator== (Node& b) {
+ return b.type == T_ORNode
+ && left == ((ORNode&) b).left
+ && right == ((ORNode&) b).right;
+@@ -227,7 +227,7 @@
+ type = T_NotNode;
+ }
+
+- virtual operator== (Node& b) {
++ virtual int operator== (Node& b) {
+ return b.type == T_NotNode
+ && left == ((NotNode&) b).left;
+ }
+@@ -256,7 +256,7 @@
+ type = T_AssignNode;
+ }
+
+- virtual operator== (Node& b) {
++ virtual int operator== (Node& b) {
+ return b.type == T_AssignNode
+ && val == ((AssignNode&) b).val
+ && left == ((AssignNode&) b).left;
+@@ -281,7 +281,7 @@
+ type = T_ANYNode;
+ }
+
+- virtual operator== (Node& b) {
++ virtual int operator== (Node& b) {
+ return b.type == T_ANYNode;
+ }
+
+@@ -305,7 +305,7 @@
+ type = T_ASNode;
+ }
+
+- virtual operator== (Node& b) {
++ virtual int operator== (Node& b) {
+ return b.type == T_ASNode
+ && val == ((ASNode&) b).val;
+ }
+@@ -330,7 +330,7 @@
+ type = T_ASMacroNode;
+ }
+
+- virtual operator== (Node& b) {
++ virtual int operator== (Node& b) {
+ return b.type == T_ASMacroNode
+ && val == ((ASMacroNode&) b).val;
+ }
+@@ -355,7 +355,7 @@
+ type = T_CommNode;
+ }
+
+- virtual operator== (Node& b) {
++ virtual int operator== (Node& b) {
+ return b.type == T_CommNode
+ && val == ((CommNode&) b).val;
+ }
+@@ -382,7 +382,7 @@
+ cidr_root = NULL;
+ }
+
+- virtual operator== (Node& b) {
++ virtual int operator== (Node& b) {
+ return b.type == T_NetListNode
+ && nets == ((NetListNode&) b).nets;
+ }
+@@ -391,7 +391,7 @@
+ virtual NormalExpression *Evaluate(int expand);
+ virtual int match(Route &r, char dontcare);
+ virtual int match_exact_or_more_specific(Route &r, char dontcare);
+- add(Pix pi) { nets.add(pi); }
++ void add(Pix pi) { nets.add(pi); }
+ };
+
+ ////////////////////////////// ASPathNode //////////////////////////////
+@@ -412,7 +412,7 @@
+ type = T_ASPathNode;
+ }
+
+- virtual operator== (Node& b) {
++ virtual int operator== (Node& b) {
+ ASSERT(0);
+ return 0;
+ }
+@@ -438,7 +438,7 @@
+ type = T_RegisterNode;
+ }
+
+- virtual operator== (Node& b) {
++ virtual int operator== (Node& b) {
+ return b.type == T_RegisterNode
+ && val == ((RegisterNode&) b).val;
+ }
+@@ -460,13 +460,13 @@
+ type = T_PrefNode;
+ }
+
+- virtual operator== (Node& b) {
++ virtual int operator== (Node& b) {
+ return b.type == T_PrefNode
+ && val == ((PrefNode&) b).val;
+ }
+
+ virtual void InOrderPrint();
+- virtual Execute(Route &r) {
++ virtual void Execute(Route &r) {
+ }
+ virtual ActionNode *FindFirst(Node_t _type) {
+ if (type == _type)
+@@ -492,13 +492,13 @@
+ type = T_MEDNode;
+ }
+
+- virtual operator== (Node& b) {
++ virtual int operator== (Node& b) {
+ return b.type == T_MEDNode
+ && val == ((MEDNode&) b).val;
+ }
+
+ virtual void InOrderPrint();
+- virtual Execute(Route &r) {
++ virtual void Execute(Route &r) {
+ }
+ virtual ActionNode *FindFirst(Node_t _type) {
+ if (type == _type)
+@@ -524,13 +524,13 @@
+ type = T_DPANode;
+ }
+
+- virtual operator== (Node& b) {
++ virtual int operator== (Node& b) {
+ return b.type == T_DPANode
+ && val == ((DPANode&) b).val;
+ }
+
+ virtual void InOrderPrint();
+- virtual Execute(Route &r) {
++ virtual void Execute(Route &r) {
+ }
+ virtual ActionNode *FindFirst(Node_t _type) {
+ if (type == _type)
+@@ -552,12 +552,12 @@
+ type = T_NoopNode;
+ }
+
+- virtual operator== (Node& b) {
++ virtual int operator== (Node& b) {
+ return b.type == T_NoopNode;
+ }
+
+ virtual void InOrderPrint();
+- virtual Execute(Route &r) {}
++ virtual void Execute(Route &r) {}
+ virtual ActionNode *FindFirst(Node_t _type) {
+ if (type == _type)
+ return this;
+@@ -581,14 +581,14 @@
+ }
+ virtual ~ComposeNode();
+
+- virtual operator== (Node& b) {
++ virtual int operator== (Node& b) {
+ return b.type == T_ComposeNode
+ && left == ((ComposeNode&) b).left
+ && right == ((ComposeNode&) b).right;
+ }
+
+ virtual void InOrderPrint();
+- virtual Execute(Route &r) {}
++ virtual void Execute(Route &r) {}
+ virtual ActionNode *FindFirst(Node_t _type) {
+ ActionNode *r;
+ if (type == _type)
diff --git a/net-mgmt/irrtoolset/files/patch-ad b/net-mgmt/irrtoolset/files/patch-ad
new file mode 100644
index 000000000000..d0560a973b2a
--- /dev/null
+++ b/net-mgmt/irrtoolset/files/patch-ad
@@ -0,0 +1,11 @@
+--- src/misc/Error.hh.orig Sat Nov 27 18:17:24 1999
++++ src/misc/Error.hh Sat Nov 27 18:17:31 1999
+@@ -378,7 +378,7 @@
+ reset();
+ }
+
+- reset() {
++ void reset() {
+ errno = 0;
+ level_ = ErrorNone;
+ messages_.clear();
diff --git a/net-mgmt/irrtoolset/files/patch-ae b/net-mgmt/irrtoolset/files/patch-ae
new file mode 100644
index 000000000000..8c3005236be0
--- /dev/null
+++ b/net-mgmt/irrtoolset/files/patch-ae
@@ -0,0 +1,11 @@
+--- src/peval/xx_lexer.y.orig Sat Nov 27 18:18:56 1999
++++ src/peval/xx_lexer.y Sat Nov 27 18:19:07 1999
+@@ -94,7 +94,7 @@
+ NULL, ERROR_TKN
+ };
+
+-static inline strtoupper(char *c) {
++static inline void strtoupper(char *c) {
+ for (; *c; c++)
+ if (isascii(*c) && isalpha(*c))
+ *c = toupper(*c);
diff --git a/net-mgmt/irrtoolset/files/patch-af b/net-mgmt/irrtoolset/files/patch-af
new file mode 100644
index 000000000000..50022888976a
--- /dev/null
+++ b/net-mgmt/irrtoolset/files/patch-af
@@ -0,0 +1,10 @@
+--- src/misc/net.cc.orig Sat Nov 27 18:20:31 1999
++++ src/misc/net.cc Sat Nov 27 18:21:15 1999
+@@ -215,6 +215,7 @@
+ init_server (p);
+ }
+
++int
+ TCP::init_server (int p) {
+ setLocalPort (p);
+ bind();
diff --git a/net-mgmt/irrtoolset/files/patch-ag b/net-mgmt/irrtoolset/files/patch-ag
new file mode 100644
index 000000000000..f5519df2a198
--- /dev/null
+++ b/net-mgmt/irrtoolset/files/patch-ag
@@ -0,0 +1,11 @@
+--- src/dbase/irr_lexer.y.orig Sat Nov 27 18:22:22 1999
++++ src/dbase/irr_lexer.y Sat Nov 27 18:22:44 1999
+@@ -73,7 +73,7 @@
+
+ #include <cctype>
+
+-static inline strtoupper(char *c) {
++static inline void strtoupper(char *c) {
+ for (; *c; c++)
+ if (isascii(*c) && isalpha(*c))
+ *c = toupper(*c);
diff --git a/net-mgmt/irrtoolset/files/patch-ah b/net-mgmt/irrtoolset/files/patch-ah
new file mode 100644
index 000000000000..4278782c08ab
--- /dev/null
+++ b/net-mgmt/irrtoolset/files/patch-ah
@@ -0,0 +1,20 @@
+--- src/dbase/irr_parser.y.orig Sat Nov 27 18:23:53 1999
++++ src/dbase/irr_parser.y Sat Nov 27 18:25:00 1999
+@@ -90,7 +90,7 @@
+ char *error_while_expecting = NULL;
+
+ static regexp_symbol *re_symbol;
+-static insert_or_update_filter_action(ListHead<Filter_Action> &l,
++static void insert_or_update_filter_action(ListHead<Filter_Action> &l,
+ ActionNode *action, FilterNode *filter);
+ static ASPolicy *find_or_insert_peer_as(Pix peer);
+ static InterASPolicy *find_or_insert_peering(ASPolicy *p, Pix laddr, Pix raddr);
+@@ -635,7 +635,7 @@
+ return(0);
+ }
+
+-static insert_or_update_filter_action(ListHead<Filter_Action> &l,
++static void insert_or_update_filter_action(ListHead<Filter_Action> &l,
+ ActionNode *action, FilterNode *filter) {
+ Filter_Action *fap, *fap2;
+
diff --git a/net-mgmt/irrtoolset/files/patch-ai b/net-mgmt/irrtoolset/files/patch-ai
new file mode 100644
index 000000000000..18de9569197e
--- /dev/null
+++ b/net-mgmt/irrtoolset/files/patch-ai
@@ -0,0 +1,11 @@
+--- src/roe/roe_config.hh.orig Sat Nov 27 18:35:37 1999
++++ src/roe/roe_config.hh Sat Nov 27 18:36:14 1999
+@@ -42,7 +42,7 @@
+
+ class Configure {
+ public:
+- const int size = 12;
++ static const int size = 12;
+
+ class DBUpdate {
+ public:
diff --git a/net-mgmt/irrtoolset/files/patch-aj b/net-mgmt/irrtoolset/files/patch-aj
index 9616035989de..6d190fb677b6 100644
--- a/net-mgmt/irrtoolset/files/patch-aj
+++ b/net-mgmt/irrtoolset/files/patch-aj
@@ -1,6 +1,6 @@
---- src/aoe/TclApp.cc.orig Thu Apr 23 21:52:07 1998
-+++ src/aoe/TclApp.cc Mon Nov 29 09:12:33 1999
-@@ -191,9 +191,9 @@
+--- src/aoe/TclApp.cc.orig Sat Nov 27 18:38:25 1999
++++ src/aoe/TclApp.cc Sat Nov 27 18:43:51 1999
+@@ -186,9 +186,9 @@
// Call Tcl function to create a Tcl command
if (Tcl_CreateCommand(ptInterp,
pcCommand->getName(),
diff --git a/net-mgmt/irrtoolset/files/patch-ak b/net-mgmt/irrtoolset/files/patch-ak
index 9ede78d1a48a..05060ae5f711 100644
--- a/net-mgmt/irrtoolset/files/patch-ak
+++ b/net-mgmt/irrtoolset/files/patch-ak
@@ -1,6 +1,6 @@
---- src/aoe/TclLabel.cc.orig Thu Apr 23 21:52:07 1998
-+++ src/aoe/TclLabel.cc Mon Nov 29 09:15:11 1999
-@@ -45,7 +45,7 @@
+--- src/aoe/TclLabel.cc.orig Sat Nov 27 18:45:09 1999
++++ src/aoe/TclLabel.cc Sat Nov 27 18:45:24 1999
+@@ -47,7 +47,7 @@
#include "TclLabel.hh"
#include "TclApp.hh"
diff --git a/net-mgmt/irrtoolset/files/patch-al b/net-mgmt/irrtoolset/files/patch-al
new file mode 100644
index 000000000000..49b068f99199
--- /dev/null
+++ b/net-mgmt/irrtoolset/files/patch-al
@@ -0,0 +1,11 @@
+--- src/prtraceroute/netraw.hh.orig Sat Nov 27 18:46:27 1999
++++ src/prtraceroute/netraw.hh Sat Nov 27 18:46:49 1999
+@@ -121,7 +121,7 @@
+ rawIP (int protocol = IPPROTO_RAW);
+ rawIP (char *hostname, int protocol = IPPROTO_RAW);
+
+- setIpaddresses (); // can be used for incoming packets.
++ void setIpaddresses (); // can be used for incoming packets.
+
+ int write (){return rawPacket::write ((char *) ip_hdr, ip_hdr->ip_len);}
+ int send (){return rawPacket::send ((char *) ip_hdr, ip_hdr->ip_len);}
diff --git a/net-mgmt/irrtoolset/files/patch-am b/net-mgmt/irrtoolset/files/patch-am
new file mode 100644
index 000000000000..70e7cb9572ed
--- /dev/null
+++ b/net-mgmt/irrtoolset/files/patch-am
@@ -0,0 +1,11 @@
+--- src/prtraceroute/prtraceroute.hh.orig Sat Nov 27 18:47:35 1999
++++ src/prtraceroute/prtraceroute.hh Sat Nov 27 18:47:45 1999
+@@ -121,7 +121,7 @@
+ u_int flags;
+ void _add (ipAddr *ipaddr);
+
+- _hop () {
++ void _hop () {
+ ipaddr = (ipAddr *) NULL;
+ autnum = NULL;
+ route = new Route();
diff --git a/net-mgmt/irrtoolset/pkg-plist b/net-mgmt/irrtoolset/pkg-plist
index bb60af699c49..a56f950cdc49 100644
--- a/net-mgmt/irrtoolset/pkg-plist
+++ b/net-mgmt/irrtoolset/pkg-plist
@@ -1,7 +1,11 @@
-bin/CIDRAdvisor
-bin/RtConfig
bin/peval
+bin/pmatch
bin/prpath
-bin/prtraceroute
+bin/RtConfig
+bin/CIDRAdvisor
+bin/prcheck
+bin/irrstat
bin/roe
-bin/rpslcheck
+bin/aoe
+bin/relayd
+bin/prtraceroute