aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/kismet
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-05 15:25:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-05 15:25:51 +0000
commitbce96a194807490a2b7a4eeef19bc49593ff41c3 (patch)
tree6c46ec37eac6eac556f821fdb3a4dea62dc4390c /net-mgmt/kismet
parent4c21b98f3fbb2d2e399271c0faf35de5f3b050f5 (diff)
downloadports-bce96a194807490a2b7a4eeef19bc49593ff41c3.tar.gz
ports-bce96a194807490a2b7a4eeef19bc49593ff41c3.zip
Notes
Diffstat (limited to 'net-mgmt/kismet')
-rw-r--r--net-mgmt/kismet/Makefile62
-rw-r--r--net-mgmt/kismet/distinfo2
-rw-r--r--net-mgmt/kismet/pkg-descr13
-rw-r--r--net-mgmt/kismet/pkg-plist18
4 files changed, 95 insertions, 0 deletions
diff --git a/net-mgmt/kismet/Makefile b/net-mgmt/kismet/Makefile
new file mode 100644
index 000000000000..d3c5b288e0fc
--- /dev/null
+++ b/net-mgmt/kismet/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: kismet
+# Date created: 3 May 2004
+# Whom: Thomas Spreng <spreng@socket.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kismet
+PORTVERSION= 200404.r1
+CATEGORIES= net-mgmt
+MASTER_SITES= http://www.kismetwireless.net/code/
+DISTNAME= kismet-2004-04-R1
+
+MAINTAINER= spreng@socket.ch
+COMMENT= 802.11 layer2 wireless network detector, sniffer, and IDS
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+CONFIGURE_ARGS+= --enable-syspcap
+
+.ifdef DISABLE_CURSES
+CONFIGURE_ARGS+= --disable-curses
+.endif
+
+.ifdef DISABLE_PANEL
+CONFIGURE_ARGS+= --disable-panel
+.endif
+
+.ifdef DISABLE_SETUID
+CONFIGURE_ARGS+= --disable-setuid
+.endif
+
+MAN1= kismet.1 kismet_drone.1
+MAN5= kismet.conf.5 kismet_drone.conf.5 kismet_ui.conf.5
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 502000
+BROKEN= "Does not compile on FreeBSD ${OSVERSION}"
+.endif
+
+pre-fetch:
+ @${ECHO_MSG} ""
+.ifndef DISABLE_CURSES
+ @${ECHO_MSG} " define DISABLE_CURSES to build without ncurses interface"
+.endif
+.ifndef DISABLE_PANEL
+ @${ECHO_MSG} " define DISABLE_PANEL to build without libpanel interface"
+.endif
+.ifndef DISABLE_SETUID
+ @${ECHO_MSG} " define DISABLE_SETUID to disable setuid/privdrop ability (not reccomended)"
+.endif
+ @${ECHO_MSG} ""
+ @${TRUE}
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/conf/kismet.conf ${PREFIX}/etc/kismet.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/conf/kismet_drone.conf ${PREFIX}/etc/kismet_drone.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/conf/kismet_ui.conf ${PREFIX}/etc/kismet_ui.conf.sample
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/kismet/distinfo b/net-mgmt/kismet/distinfo
new file mode 100644
index 000000000000..f4bbf4457b40
--- /dev/null
+++ b/net-mgmt/kismet/distinfo
@@ -0,0 +1,2 @@
+MD5 (kismet-2004-04-R1.tar.gz) = bd9fad469b3d9ca35c51734e58e406d0
+SIZE (kismet-2004-04-R1.tar.gz) = 757689
diff --git a/net-mgmt/kismet/pkg-descr b/net-mgmt/kismet/pkg-descr
new file mode 100644
index 000000000000..26bb47643f17
--- /dev/null
+++ b/net-mgmt/kismet/pkg-descr
@@ -0,0 +1,13 @@
+Kismet is an 802.11 layer2 wireless network detector, sniffer, and intrusion
+detection system. Kismet will work with any wireless card which supports raw
+monitoring (rfmon) mode, and can sniff 802.11b, 802.11a, and 802.11g traffic.
+
+Kismet identifies networks by passively collecting packets and detecting
+standard named networks, detecting (and given time, decloaking) hidden
+networks, and infering the presence of nonbeaconing networks via data traffic.
+
+Known supported cards: Atheros, Prism2, WSP100, Drone, wtapfile, pcapfile.
+Kismet also supports the radiotap headers and should work with current FreeBSD
+systems.
+
+WWW: http://www.kismetwireless.net/
diff --git a/net-mgmt/kismet/pkg-plist b/net-mgmt/kismet/pkg-plist
new file mode 100644
index 000000000000..42a87d895888
--- /dev/null
+++ b/net-mgmt/kismet/pkg-plist
@@ -0,0 +1,18 @@
+bin/kismet
+bin/kismet_client
+bin/kismet_drone
+bin/kismet_server
+etc/ap_manuf
+etc/client_manuf
+@unexec if cmp -s %D/etc/kismet.conf %D/etc/kismet.conf.sample; then rm -f %D/etc/kismet.conf; fi
+etc/kismet.conf.sample
+@unexec if cmp -s %D/etc/kismet_drone.conf %D/etc/kismet_drone.conf.sample; then rm -f %D/etc/kismet_drone.conf; fi
+etc/kismet_drone.conf.sample
+@unexec if cmp -s %D/etc/kismet_ui.conf %D/etc/kismet_ui.conf.sample; then rm -f %D/etc/kismet_ui.conf; fi
+etc/kismet_ui.conf.sample
+share/kismet/wav/alert.wav
+share/kismet/wav/junk_traffic.wav
+share/kismet/wav/new_network.wav
+share/kismet/wav/traffic.wav
+@dirrm share/kismet/wav
+@dirrm share/kismet