aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/libsmi/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-01-29 22:30:48 +0000
committerSteve Price <steve@FreeBSD.org>2000-01-29 22:30:48 +0000
commit083010304d2dfb16375cbf7e5887e402705415e1 (patch)
treeed8deb88ff6d674f71da72cecf19511213117026 /net-mgmt/libsmi/Makefile
parent12c51196c38a22e3dccc30b11189ac0afbccf555 (diff)
downloadports-083010304d2dfb16375cbf7e5887e402705415e1.tar.gz
ports-083010304d2dfb16375cbf7e5887e402705415e1.zip
Notes
Diffstat (limited to 'net-mgmt/libsmi/Makefile')
-rw-r--r--net-mgmt/libsmi/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-mgmt/libsmi/Makefile b/net-mgmt/libsmi/Makefile
new file mode 100644
index 000000000000..9cad04a4e193
--- /dev/null
+++ b/net-mgmt/libsmi/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libsmi
+# Version required: 0.1.8
+# Date created: Tue Jan 27 2000
+# Whom: Marcin Cieslak <saper@system.pl>
+#
+# $FreeBSD$
+#
+
+DISTNAME= libsmi-0.1.8
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.ibr.cs.tu-bs.de/pub/local/libsmi/
+
+MAINTAINER= saper@system.pl
+
+#LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+
+#USE_X_PREFIX= yes
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MIBDIR= ${PREFIX}/share/smi/mibs
+CONFIGURE_ARGS+=--with-data-dir=${PREFIX}/share/smi \
+ --with-mibdir=${MIBDIR} \
+ --with-smipath=${MIBDIR}/ietf:${MIBDIR}/iana:${MIBDIR}/irtf:${MIBDIR}/site
+
+MAN1= smiquery.1 smilint.1 smidump.1 smistrip.1
+MAN3= libsmi.3 smi_config.3 smi_module.3 smi_macro.3 smi_node.3 smi_type.3
+
+.include <bsd.port.mk>