aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/macroscope/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-07-21 21:42:59 +0000
committerJohn Marino <marino@FreeBSD.org>2013-07-21 21:42:59 +0000
commit71792e6231c091d6b1912961abe697008172f481 (patch)
tree01539fd8edf6435f7a308cbcea712de20f994218 /net-mgmt/macroscope/Makefile
parent843ff6bc092178473023c763c63e59412043477f (diff)
downloadports-71792e6231c091d6b1912961abe697008172f481.tar.gz
ports-71792e6231c091d6b1912961abe697008172f481.zip
Notes
Diffstat (limited to 'net-mgmt/macroscope/Makefile')
-rw-r--r--net-mgmt/macroscope/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/net-mgmt/macroscope/Makefile b/net-mgmt/macroscope/Makefile
index ed3cff99939e..c55d5f543ddd 100644
--- a/net-mgmt/macroscope/Makefile
+++ b/net-mgmt/macroscope/Makefile
@@ -21,10 +21,8 @@ USE_BZIP2= yes
USE_DOS2UNIX= yes
USES= cmake
-OPTIONS_DEFINE= MYSQL FIREBIRD DOCS
-MYSQL_DESC= With MySQL support
-FIREBIRD_DESC= With Firebird support
-OPTIONS_DEFAULT= MYSQL
+OPTIONS_DEFINE= FIREBIRD DOCS #MYSQL
+OPTIONS_DEFAULT= FIREBIRD
.include <bsd.port.pre.mk>
@@ -32,18 +30,19 @@ OPTIONS_DEFAULT= MYSQL
CMAKE_ARGS+= -DCMAKE_NOT_INSTALL_DOC:BOOL=ON
.endif
-.if ${PORT_OPTIONS:MMYSQL}
-WANT_MYSQL_VER= 50
-USE_MYSQL= yes
-.endif
+# ${WRKSRC}/include/adicpp/myapi appears to be hardcoded for MySQL 5.0
+# Disable option completely until support for later versions added
+# Firebird 2.0 support doesn't build on amd64, so version 2.5 is required
+#.if ${PORT_OPTIONS:MMYSQL}
+#WANT_MYSQL_VER= 50
+#USE_MYSQL= yes
+#.endif
.if ${PORT_OPTIONS:MFIREBIRD}
-WITH_FIREBIRD_VER= 2
+WITH_FIREBIRD_VER= 25
USE_FIREBIRD= yes
.endif
-.include "${PORTSDIR}/Mk/bsd.database.mk"
-
.if ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BROKEN= Does not compile on this architecture
.endif