aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/mk-livestatus
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2010-11-10 21:25:22 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2010-11-10 21:25:22 +0000
commit337699123c78e7987d1882cf00f167389345fc82 (patch)
tree4dca8b803d707f3cb1835d17d52f3027cbc47c14 /net-mgmt/mk-livestatus
parent1b9a387c3d3d323312c150b8ce6133c5b8270590 (diff)
downloadports-337699123c78e7987d1882cf00f167389345fc82.tar.gz
ports-337699123c78e7987d1882cf00f167389345fc82.zip
Notes
Diffstat (limited to 'net-mgmt/mk-livestatus')
-rw-r--r--net-mgmt/mk-livestatus/Makefile36
-rw-r--r--net-mgmt/mk-livestatus/distinfo5
-rw-r--r--net-mgmt/mk-livestatus/files/pkg-message.in15
-rw-r--r--net-mgmt/mk-livestatus/pkg-descr5
-rw-r--r--net-mgmt/mk-livestatus/pkg-message10
5 files changed, 54 insertions, 17 deletions
diff --git a/net-mgmt/mk-livestatus/Makefile b/net-mgmt/mk-livestatus/Makefile
index 633cde4c0615..353772fba5e3 100644
--- a/net-mgmt/mk-livestatus/Makefile
+++ b/net-mgmt/mk-livestatus/Makefile
@@ -6,20 +6,50 @@
#
PORTNAME= mk-livestatus
-PORTVERSION= 1.1.3
+PORTVERSION= 1.1.8
CATEGORIES= net-mgmt
MASTER_SITES= http://mathias-kettner.de/download/
-MAINTAINER= cowbert@gmail.com
-COMMENT= Mathias Kettner's mk-livestatus plugin for nagios
+MAINTAINER= ohauer@FreeBSD.org
+COMMENT= Nagios event broker module
+
+LICENSE= GPLv2
USE_GMAKE= yes
GNU_CONFIGURE= yes
PLIST_FILES= lib/mk-livestatus/unixcat lib/mk-livestatus/livestatus.o
PLIST_DIRS= lib/${PORTNAME}
+SUB_FILES= pkg-message
+SUB_LIST= PREFIX=${PREFIX}
+
+PORTEXAMPLES= *
+EXAMPLE_FILES= api/python/example_multisite.py \
+ api/python/example.py \
+ api/python/livestatus.py \
+ api/python/make_nagvis_map.py \
+ api/python/README
+
+# parameter "command_file" from nagios.cfg
+COMMAND_FILE?= /var/spool/nagios/rw/live
+
+post-patch:
+.for i in ${EXAMPLE_FILES}
+ @${REINPLACE_CMD} -i '' -e 's|/usr/bin/python|${LOCALBASE}/bin/python|g' \
+ -e 's|/var/lib/nagios/rw/live|${COMMAND_FILE}|g' \
+ -e 's|/var/run/nagios/rw/live|${COMMAND_FILE}|g' ${WRKSRC}/$i
+.endfor
+ @${REINPLACE_CMD} -i '' -e 's|/usr/local/nagios/var/rw/live|${COMMAND_FILE}|' \
+ ${WRKSRC}/src/livestatus.h
post-install:
+.if !defined(NOPORTEXAMPLES)
+# do not install the outdated perl api!
+ ${MKDIR} ${EXAMPLESDIR}/api/python
+. for i in ${EXAMPLE_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/$i ${EXAMPLESDIR}/$i
+. endfor
+.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/net-mgmt/mk-livestatus/distinfo b/net-mgmt/mk-livestatus/distinfo
index 0dfff44d2d07..59742e6222f0 100644
--- a/net-mgmt/mk-livestatus/distinfo
+++ b/net-mgmt/mk-livestatus/distinfo
@@ -1,3 +1,2 @@
-MD5 (mk-livestatus-1.1.3.tar.gz) = df32a163a8663c1784afd1fa329732a0
-SHA256 (mk-livestatus-1.1.3.tar.gz) = 8882b52332038d081b52ef7d0d16084ee184e07f536f227cad7da2c266f8e0c9
-SIZE (mk-livestatus-1.1.3.tar.gz) = 318465
+SHA256 (mk-livestatus-1.1.8.tar.gz) = b9f3449664625a5b23a24dfd015f2ad1e3b5829d45a3b9502051f9121c0da17d
+SIZE (mk-livestatus-1.1.8.tar.gz) = 323754
diff --git a/net-mgmt/mk-livestatus/files/pkg-message.in b/net-mgmt/mk-livestatus/files/pkg-message.in
new file mode 100644
index 000000000000..42af36e61d30
--- /dev/null
+++ b/net-mgmt/mk-livestatus/files/pkg-message.in
@@ -0,0 +1,15 @@
+=============================================================================
+
+Notes:
+
+ * See the documentation at http://mathias-kettner.de/checkmk_livestatus.html
+
+ * Requires that net-mgmt/nagios be built with WITH_EVENT_BROKER=yes or
+ livestatus.o will never be loaded...
+
+ * unixcat (for use with reading from the socket and/or inetd(8) support)
+ moved from %%PREFIX%%/bin
+ to %%PREFIX%%/lib/mk-livestatus
+ in order to avoid a conflict with sysutils/ucspi-unix
+
+=============================================================================
diff --git a/net-mgmt/mk-livestatus/pkg-descr b/net-mgmt/mk-livestatus/pkg-descr
index 0bcd7d8d7b1d..eb098f8a7f12 100644
--- a/net-mgmt/mk-livestatus/pkg-descr
+++ b/net-mgmt/mk-livestatus/pkg-descr
@@ -1,4 +1,6 @@
-MKLivestatus is a very simple and smart Nagios eventbroker module.
+MK Livestatus - a Nagios event broker module that allows quick,
+direct and comfortable access to your status data.
+
Livestatus is concepted and tuned to reduce disk, memory and cpu loads
caused by live-data processing on the Nagios system. Just as NDO,
Livestatus makes use of the Nagios Event Broker API and loads a binary
@@ -7,4 +9,5 @@ actively write out data e.g. to the disk. Instead, it opens a socket for
external applications to connect to and fetch the current status
information from Nagios.
+
WWW: http://mathias-kettner.de/checkmk_livestatus.html
diff --git a/net-mgmt/mk-livestatus/pkg-message b/net-mgmt/mk-livestatus/pkg-message
deleted file mode 100644
index e903833984bd..000000000000
--- a/net-mgmt/mk-livestatus/pkg-message
+++ /dev/null
@@ -1,10 +0,0 @@
-Notes:
-
- * See the documentation at http://mathias-kettner.de/checkmk_livestatus.html
-
- * Requires that net-mgmt/nagios be built with WITH_EVENT_BROKER=yes or
- livestatus.o will never be loaded...
-
- * unixcat (for use with reading from the socket and/or inetd(8) support)
- moved to $LOCALBASE/lib/mk-livestatus from $LOCALBASE/bin in
- order to avoid a conflict with sysutils/ucspi-unix