aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios-check_mysql_slave/Makefile
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2011-05-29 01:45:26 +0000
committerWesley Shields <wxs@FreeBSD.org>2011-05-29 01:45:26 +0000
commitf509d17ab40b7cc3d96966976f939e406dd65bc2 (patch)
tree4afa645653a8e914e87667e472736943a5286b17 /net-mgmt/nagios-check_mysql_slave/Makefile
parentdc179b2937b9cbc51e57c1eb523fba46345ff04a (diff)
downloadports-f509d17ab40b7cc3d96966976f939e406dd65bc2.tar.gz
ports-f509d17ab40b7cc3d96966976f939e406dd65bc2.zip
Notes
Diffstat (limited to 'net-mgmt/nagios-check_mysql_slave/Makefile')
-rw-r--r--net-mgmt/nagios-check_mysql_slave/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-mgmt/nagios-check_mysql_slave/Makefile b/net-mgmt/nagios-check_mysql_slave/Makefile
new file mode 100644
index 000000000000..03ec343a774e
--- /dev/null
+++ b/net-mgmt/nagios-check_mysql_slave/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: nagios-check_mysql_slave
+# Date created: 15 May 2011
+# Whom: Ryan Steinmetz
+#
+# $FreeBSD$
+
+PORTNAME= check_mysql_slave
+PORTVERSION= 0.1.1
+CATEGORIES= net-mgmt
+MASTER_SITES= http://buhacoff.net/2009/products/check_mysql_slave/archive/ \
+ http://people.rit.edu/rpsfa/
+PKGNAMEPREFIX= nagios-
+
+MAINTAINER= rpsfa@rit.edu
+COMMENT= Nagios Plugin to monitor MySQL replication on a slave
+
+RUN_DEPENDS= p5-DBI>=1.60.7:${PORTSDIR}/databases/p5-DBI \
+ p5-DBD-mysql>0:${PORTSDIR}/databases/p5-DBD-mysql
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+DOC_FILES= check_mysql_slave.html check_mysql_slave.pod
+
+do-install:
+ @${MKDIR} ${PREFIX}/libexec/nagios
+ ${INSTALL_SCRIPT} ${WRKSRC}/check_mysql_slave ${PREFIX}/libexec/nagios/
+ ${INSTALL_SCRIPT} ${WRKSRC}/check_mysql_slave_epn ${PREFIX}/libexec/nagios/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/docs/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>