aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios-devel
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-01-19 19:44:28 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-01-19 19:44:28 +0000
commita6cf48b729ae33cc0ec4865755bb5eff072fb9dd (patch)
tree2c36f9a7d3a4eb3df4423f13c81d3faed39bc3c2 /net-mgmt/nagios-devel
parent85f0e6088d2b538c2c823788644dfcfdc4505b7a (diff)
downloadports-a6cf48b729ae33cc0ec4865755bb5eff072fb9dd.tar.gz
ports-a6cf48b729ae33cc0ec4865755bb5eff072fb9dd.zip
Notes
Diffstat (limited to 'net-mgmt/nagios-devel')
-rw-r--r--net-mgmt/nagios-devel/Makefile1
-rw-r--r--net-mgmt/nagios-devel/files/patch-configure.in44
2 files changed, 40 insertions, 5 deletions
diff --git a/net-mgmt/nagios-devel/Makefile b/net-mgmt/nagios-devel/Makefile
index 8bfdf7c77f24..dc0bbd7e44b4 100644
--- a/net-mgmt/nagios-devel/Makefile
+++ b/net-mgmt/nagios-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nagios
DISTVERSION= 3.0rc1
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= nagios
diff --git a/net-mgmt/nagios-devel/files/patch-configure.in b/net-mgmt/nagios-devel/files/patch-configure.in
index e5bd8f11569a..58ac6002360c 100644
--- a/net-mgmt/nagios-devel/files/patch-configure.in
+++ b/net-mgmt/nagios-devel/files/patch-configure.in
@@ -1,5 +1,5 @@
---- configure.in.orig Thu Nov 1 04:05:38 2007
-+++ configure.in Thu Nov 1 19:33:42 2007
+--- configure.in.orig 2007-12-18 04:21:51.000000000 +1030
++++ configure.in 2008-01-02 12:15:05.000000000 +1030
@@ -6,7 +6,6 @@
AC_INIT(base/nagios.c)
@@ -7,8 +7,32 @@
-AC_PREFIX_DEFAULT(/usr/local/nagios)
PKG_NAME=nagios
- PKG_VERSION="3.0b7"
-@@ -196,7 +195,7 @@
+ PKG_VERSION="3.0rc1"
+@@ -119,7 +118,15 @@
+ dnl Test for pthreads support - taken from ICU FreeBSD Port configure script
+ THREADLIBS=""
+ have_pthreads="no"
++have_thr="no"
+
++dnl Prefer libthr(3) over libpthread(3) due to serious process hanging issues
++AC_CHECK_LIB(thr,pthread_create)
++if test $ac_cv_lib_thr_pthread_create = yes; then
++ THREADLIBS="-lthr"
++ have_pthreads="yes"
++ have_thr="yes"
++else
+ dnl FreeBSD: Try ports/linuxthreads first - Mammad Zadeh <mammad@yahoo-inc.com>
+ dnl FreeBSD -pthread check - Jonathan McDowell <noodles@earth.li>
+ AC_DEFUN(AC_PTHREAD_FREEBSD,[
+@@ -180,6 +187,7 @@
+ if test $have_pthreads = "no"; then
+ AC_PTHREAD_FREEBSD
+ fi
++fi
+
+ AC_SUBST(THREADLIBS)
+
+@@ -196,7 +204,7 @@
AC_SUBST(nagios_grp)
AC_DEFINE_UNQUOTED(DEFAULT_NAGIOS_USER,"$nagios_user")
AC_DEFINE_UNQUOTED(DEFAULT_NAGIOS_GROUP,"$nagios_grp")
@@ -17,7 +41,7 @@
AC_SUBST(INSTALL_OPTS)
AC_ARG_WITH(command_user,--with-command-user=<user> sets user name for command access,command_user=$withval,command_user=$nagios_user)
-@@ -520,9 +519,9 @@
+@@ -520,9 +528,9 @@
fi
dnl Try and locate glib
@@ -29,3 +53,13 @@
AC_SUBST(GLIB_LIBS)
if test x$GLIB_LIBS != x; then
AC_DEFINE_UNQUOTED(HAVE_GLIB)
+@@ -667,6 +675,9 @@
+
+ AC_DEFINE_UNQUOTED(EMBEDDEDPERL)
+ PERLLIBS="`perl -MExtUtils::Embed -e ldopts`"
++ if test x$have_thr = xyes; then
++ PERLLIBS="`echo $PERLLIBS | sed 's#pthread #lthr #'`"
++ fi
+ PERLDIR="`perl -MConfig -e 'print $Config{installsitearch}'`"
+ CFLAGS="${CFLAGS} `perl -MExtUtils::Embed -e ccopts`"
+ USEPERL=yes