aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios-plugins
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-05-20 21:29:57 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-05-20 21:29:57 +0000
commitadab9c11179499ed9656a3afa45a60d880c96839 (patch)
tree27b0174779c3ea0fa48dd70b0c493a2e44570d2b /net-mgmt/nagios-plugins
parent9f70f886b8c08f25b2f4ab418e3317bf835c4d8a (diff)
downloadports-adab9c11179499ed9656a3afa45a60d880c96839.tar.gz
ports-adab9c11179499ed9656a3afa45a60d880c96839.zip
Update to 2.0.2.
Notes
Notes: svn path=/head/; revision=354692
Diffstat (limited to 'net-mgmt/nagios-plugins')
-rw-r--r--net-mgmt/nagios-plugins/Makefile3
-rw-r--r--net-mgmt/nagios-plugins/distinfo4
-rw-r--r--net-mgmt/nagios-plugins/files/patch-configure.ac36
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins__check_pgsql.c8
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins__check_ssh.c8
5 files changed, 29 insertions, 30 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 198ecdc7b33a..455bc2c051ab 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nagios-plugins
-PORTVERSION= 2.0.1
-PORTREVISION= 2
+PORTVERSION= 2.0.2
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= https://www.nagios-plugins.org/download/ \
diff --git a/net-mgmt/nagios-plugins/distinfo b/net-mgmt/nagios-plugins/distinfo
index 694def7b2be8..d4a6129099a1 100644
--- a/net-mgmt/nagios-plugins/distinfo
+++ b/net-mgmt/nagios-plugins/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nagios-plugins-2.0.1.tar.gz) = 1fb63cf8e917397c745f9a30b3eac6178d832df80f914e2498e8171408c9172a
-SIZE (nagios-plugins-2.0.1.tar.gz) = 2651400
+SHA256 (nagios-plugins-2.0.2.tar.gz) = 2d788d4af529ab708bbbee4f9cd73991e6165042e91cf1b681d28b9ed6ff89e1
+SIZE (nagios-plugins-2.0.2.tar.gz) = 2653815
diff --git a/net-mgmt/nagios-plugins/files/patch-configure.ac b/net-mgmt/nagios-plugins/files/patch-configure.ac
index aee53fed28ae..49984c5ea361 100644
--- a/net-mgmt/nagios-plugins/files/patch-configure.ac
+++ b/net-mgmt/nagios-plugins/files/patch-configure.ac
@@ -1,5 +1,5 @@
---- ./configure.ac.orig 2014-03-04 20:21:36.000000000 +0100
-+++ ./configure.ac 2014-04-14 10:22:50.000000000 +0200
+--- ./configure.ac.orig 2014-05-20 21:15:34.000000000 +0200
++++ ./configure.ac 2014-05-20 23:08:10.000000000 +0200
@@ -13,8 +13,6 @@
RELEASE=1
AC_SUBST(RELEASE)
@@ -17,7 +17,7 @@
AM_PROG_CC_C_O
-@@ -215,8 +214,8 @@
+@@ -216,8 +215,8 @@
AC_CHECK_LIB(crypt,main)
if test "$ac_cv_lib_crypt_main" = "yes" -a "x$PGSQL" != "xno"; then
if test -n "$PGSQL"; then
@@ -28,33 +28,33 @@
fi
AC_CHECK_LIB(pq,PQsetdbLogin,,,-lcrypt)
if test "$ac_cv_lib_pq_PQsetdbLogin" = "yes"; then
-@@ -260,10 +259,10 @@
+@@ -261,10 +260,10 @@
dnl Check for DBI libraries
AS_IF([test "x$with_dbi" != "xno"], [
_SAVEDLIBS="$LIBS"
- AC_CHECK_LIB(dbi,dbi_initialize)
+ AC_CHECK_LIB(dbi,dbi_initialize,,,-L${LOCALBASE}/lib)
if test "$ac_cv_lib_dbi_dbi_initialize" = "yes"; then
- EXTRAS="$EXTRAS check_dbi"
+ EXTRAS="$EXTRAS check_dbi\$(EXEEXT)"
- DBILIBS="-ldbi"
+ DBILIBS="-L${LOCALBASE}/lib -ldbi"
AC_SUBST(DBILIBS)
else
AC_MSG_WARN([Skipping dbi plugin])
-@@ -277,22 +276,17 @@
+@@ -278,22 +277,17 @@
dnl Check for radius libraries
AS_IF([test "x$with_radius" != "xno"], [
_SAVEDLIBS="$LIBS"
- AC_CHECK_LIB(radiusclient,rc_read_config)
- if test "$ac_cv_lib_radiusclient_rc_read_config" = "yes"; then
-- EXTRAS="$EXTRAS check_radius"
+- EXTRAS="$EXTRAS check_radius\$(EXEEXT)"
- RADIUSLIBS="-lradiusclient"
- AC_SUBST(RADIUSLIBS)
- else
- AC_CHECK_LIB(radiusclient-ng,rc_read_config)
+ AC_CHECK_LIB(radiusclient-ng,rc_read_config,,,-L${LOCALBASE}/lib)
if test "$ac_cv_lib_radiusclient_ng_rc_read_config" = "yes"; then
- EXTRAS="$EXTRAS check_radius"
+ EXTRAS="$EXTRAS check_radius\$(EXEEXT)"
- RADIUSLIBS="-lradiusclient-ng"
+ RADIUSLIBS="-L${LOCALBASE}/lib -lradiusclient-ng"
+ RADIUSINCLUDE="-I${LOCALBSE}/include"
@@ -68,7 +68,7 @@
LIBS="$_SAVEDLIBS"
])
-@@ -301,12 +295,13 @@
+@@ -302,12 +296,13 @@
dnl Check for LDAP libraries
AS_IF([test "x$with_ldap" != "xno"], [
_SAVEDLIBS="$LIBS"
@@ -84,9 +84,9 @@
AC_SUBST(LDAPINCLUDE)
+ LIBS="-L${LOCALBASE}/lib $LIBS"
AC_CHECK_FUNCS(ldap_set_option)
- EXTRAS="$EXTRAS check_ldap"
+ EXTRAS="$EXTRAS check_ldap\$(EXEEXT)"
AC_CHECK_FUNCS(ldap_init ldap_set_option ldap_get_option ldap_start_tls_s)
-@@ -746,22 +741,10 @@
+@@ -755,22 +750,10 @@
dnl ac_cv_ps_cols=8
dnl AC_MSG_RESULT([$ac_cv_ps_command])
@@ -112,7 +112,7 @@
then
ac_cv_ps_varlist="[procstat,&procuid,&procpid,&procppid,&procvsz,&procrss,&procpcpu,procprog,&pos]"
ac_cv_ps_command="$PATH_TO_PS -axwo 'stat uid pid ppid vsz rss pcpu comm args'"
-@@ -769,9 +752,8 @@
+@@ -778,9 +761,8 @@
ac_cv_ps_cols=9
AC_MSG_RESULT([$ac_cv_ps_command])
@@ -124,7 +124,7 @@
elif ps -axwo 'stat uid pid ppid vsz rss pcpu ucomm command' 2>/dev/null | \
egrep -i ["^ *STAT +UID +PID +PPID +VSZ +RSS +%CPU +UCOMM +COMMAND"] > /dev/null
then
-@@ -781,209 +763,6 @@
+@@ -790,209 +772,6 @@
ac_cv_ps_cols=9
AC_MSG_RESULT([$ac_cv_ps_command])
@@ -334,7 +334,7 @@
else
AC_MSG_WARN([unable to find usable ps syntax - check_procs and check_nagios will not be compiled])
fi
-@@ -1371,6 +1150,8 @@
+@@ -1391,6 +1170,8 @@
AC_MSG_WARN([Get smbclient from Samba.org to monitor SMB shares])
fi
@@ -343,7 +343,7 @@
AC_PATH_PROG(PATH_TO_SNMPGET,snmpget)
AC_ARG_WITH(snmpget_command,
ACX_HELP_STRING([--with-snmpget-command=PATH],
-@@ -1401,7 +1182,10 @@
+@@ -1421,7 +1202,10 @@
else
AC_MSG_WARN([Tried $PERL - install Net::SNMP perl module if you want to use the perl snmp plugins])
fi
@@ -354,7 +354,7 @@
AC_PATH_PROG(PATH_TO_QUAKESTAT,quakestat)
AC_PATH_PROG(PATH_TO_QSTAT,qstat)
AC_ARG_WITH(qstat_command,
-@@ -1426,7 +1210,10 @@
+@@ -1446,7 +1230,10 @@
AC_DEFINE_UNQUOTED(PATH_TO_QSTAT,"$ac_cv_path_to_qstat",
[path to qstat/quakestat])
fi
@@ -365,7 +365,7 @@
AC_PATH_PROG(PATH_TO_FPING,fping)
AC_PATH_PROG(PATH_TO_FPING6,fping6)
-@@ -1447,6 +1234,7 @@
+@@ -1467,6 +1254,7 @@
else
AC_MSG_WARN([Get fping from http://www.fping.com in order to make check_fping plugin])
fi
@@ -373,7 +373,7 @@
AC_PATH_PROG(PATH_TO_SSH,ssh)
AC_ARG_WITH(ssh_command,
-@@ -1517,32 +1305,12 @@
+@@ -1537,32 +1325,12 @@
dnl end if for PATH_TO_SWAP
fi
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins__check_pgsql.c b/net-mgmt/nagios-plugins/files/patch-plugins__check_pgsql.c
index 37eac96d0e16..160db0fb7662 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins__check_pgsql.c
+++ b/net-mgmt/nagios-plugins/files/patch-plugins__check_pgsql.c
@@ -1,10 +1,10 @@
---- plugins/check_pgsql.c.orig 2008-01-30 11:17:46.000000000 +0100
-+++ plugins/check_pgsql.c 2008-01-30 11:18:00.000000000 +0100
-@@ -43,6 +43,7 @@
+--- ./plugins/check_pgsql.c.orig 2014-04-16 00:19:03.000000000 +0200
++++ ./plugins/check_pgsql.c 2014-05-20 23:08:11.000000000 +0200
+@@ -36,6 +36,7 @@
#include "utils.h"
#include "netutils.h"
+#include "pg_config_manual.h"
#include <libpq-fe.h>
+ #include <pg_config_manual.h>
- #define DEFAULT_DB "template1"
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins__check_ssh.c b/net-mgmt/nagios-plugins/files/patch-plugins__check_ssh.c
index f68032e1640e..bb6bb28dee10 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins__check_ssh.c
+++ b/net-mgmt/nagios-plugins/files/patch-plugins__check_ssh.c
@@ -1,6 +1,6 @@
---- plugins/check_ssh.c.orig 2012-06-27 21:32:47.000000000 +0400
-+++ plugins/check_ssh.c 2013-09-25 17:03:01.000000000 +0400
-@@ -250,6 +250,7 @@ ssh_connect (char *haddr, int hport, cha
+--- ./plugins/check_ssh.c.orig 2014-03-04 22:41:57.000000000 +0100
++++ ./plugins/check_ssh.c 2014-05-20 23:08:11.000000000 +0200
+@@ -255,6 +255,7 @@
printf
(_("SSH WARNING - %s (protocol %s) version mismatch, expected '%s'\n"),
ssh_server, ssh_proto, remote_version);
@@ -8,7 +8,7 @@
close(sd);
exit (STATE_WARNING);
}
-@@ -260,6 +261,7 @@ ssh_connect (char *haddr, int hport, cha
+@@ -273,6 +274,7 @@
(_("SSH OK - %s (protocol %s) | %s\n"),
ssh_server, ssh_proto, fperfdata("time", elapsed_time, "s",
FALSE, 0, FALSE, 0, TRUE, 0, TRUE, (int)socket_timeout));