aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios-plugins
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-02 06:49:34 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-02 06:49:34 +0000
commit7c700529d2178266a7f739c8c250d1d7df5ce2a2 (patch)
treefd6d1163ae65e31f6fe36c4eaecac00f386bdfc0 /net-mgmt/nagios-plugins
parent524caafd20f7f3116c07cd394c967ca7ea6574f8 (diff)
downloadports-7c700529d2178266a7f739c8c250d1d7df5ce2a2.tar.gz
ports-7c700529d2178266a7f739c8c250d1d7df5ce2a2.zip
Notes
Diffstat (limited to 'net-mgmt/nagios-plugins')
-rw-r--r--net-mgmt/nagios-plugins/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 7bd8eae59998..434047ea5754 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -42,7 +42,7 @@ NAGIOSCGIURL?= ${NAGIOSHTMURL}/cgi-bin
NAGIOSPOLLIP?= 127.0.0.1
NAGIOSPOLLIP6?= ::1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
CONFIGURE_ARGS= --with-nagios-user=${NAGIOSUSER} \
--with-nagios-group=${NAGIOSGROUP} \
@@ -128,12 +128,12 @@ PLIST_SUB+= SUB_LDAP=""
PLIST_SUB+= SUB_LDAP="@comment "
.endif
-.if empty(PORT_OPTIONS:MNLS)
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
.endif
# Restore check_users from 1.4.15 for hosts without getutxent(3)
@@ -153,4 +153,4 @@ post-patch:
@${REINPLACE_CMD} -e 's# ::1 # ${NAGIOSPOLLIP6} #g' ${WRKSRC}/configure.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>