aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios-plugins
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-01-19 17:52:56 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-01-19 17:52:56 +0000
commit07ae7bc7148370e9527486164d60ddbe01a8fdd2 (patch)
tree70d23c77dacbb805fc3a6707bc95e8efc43c0331 /net-mgmt/nagios-plugins
parent98e4cc405c59f4a3bbadf2db80eac7c71ab77c65 (diff)
Fix check_dig on > 10 with IPv6
PR: 196725 Submitted by: brd Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=377447
Diffstat (limited to 'net-mgmt/nagios-plugins')
-rw-r--r--net-mgmt/nagios-plugins/Makefile2
-rw-r--r--net-mgmt/nagios-plugins/files/extra-patch-dig-to-drill.diff4
2 files changed, 3 insertions, 3 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index a1d09d8a14a3..88c657ae3c65 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nagios-plugins
PORTVERSION= 2.0.3
-PORTREVISION= 6
+PORTREVISION= 7
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= https://www.nagios-plugins.org/download/ \
diff --git a/net-mgmt/nagios-plugins/files/extra-patch-dig-to-drill.diff b/net-mgmt/nagios-plugins/files/extra-patch-dig-to-drill.diff
index 3a75840e5221..21a8df54c690 100644
--- a/net-mgmt/nagios-plugins/files/extra-patch-dig-to-drill.diff
+++ b/net-mgmt/nagios-plugins/files/extra-patch-dig-to-drill.diff
@@ -1,13 +1,13 @@
--- plugins/check_dig.c.orig 2014-03-04 21:41:57 UTC
+++ plugins/check_dig.c
-@@ -94,8 +94,8 @@
+@@ -94,8 +94,8 @@ main (int argc, char **argv)
timeout_interval_dig = ceil((double) timeout_interval / (double) number_tries);
/* get the command to run */
- xasprintf (&command_line, "%s @%s -p %d %s -t %s %s %s +tries=%d +time=%d",
- PATH_TO_DIG, dns_server, server_port, query_address, record_type, dig_args, query_transport, number_tries, timeout_interval_dig);
+ xasprintf (&command_line, "%s %s @%s -z -p %d %s %s %s",
-+ PATH_TO_DIG, dig_args, dns_server, server_port, query_address, record_type, query_transport);
++ PATH_TO_DIG, dig_args, dns_server, server_port, query_transport, query_address, record_type);
alarm (timeout_interval);
gettimeofday (&tv, NULL);