aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios-plugins
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-01-08 13:38:55 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-01-08 13:38:55 +0000
commit0ef198c1972339df8611f4648356621c40f4e207 (patch)
tree0a985c229d64ceebf107e74cc34a5ee7442623e8 /net-mgmt/nagios-plugins
parent6c060282c436d5d49f9bae82044a925dfbc75d67 (diff)
downloadports-0ef198c1972339df8611f4648356621c40f4e207.tar.gz
ports-0ef198c1972339df8611f4648356621c40f4e207.zip
Notes
Diffstat (limited to 'net-mgmt/nagios-plugins')
-rw-r--r--net-mgmt/nagios-plugins/Makefile2
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-check_ntp_time.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 81f05262db81..68c4260afd14 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nagios-plugins
PORTVERSION= 2.2.1
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= https://www.nagios-plugins.org/download/ \
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-check_ntp_time.c b/net-mgmt/nagios-plugins/files/patch-plugins-check_ntp_time.c
new file mode 100644
index 000000000000..daa43daf30be
--- /dev/null
+++ b/net-mgmt/nagios-plugins/files/patch-plugins-check_ntp_time.c
@@ -0,0 +1,15 @@
+Obtained from:
+https://github.com/nagios-plugins/nagios-plugins/commit/df485c74f582708d6ce37cdf99880fe75215498a
+
+--- plugins/check_ntp_time.c.orig 2018-01-04 12:59:01.422087000 -0800
++++ plugins/check_ntp_time.c 2018-01-04 13:05:56.317152000 -0800
+@@ -415,6 +415,9 @@
+ }
+ }
+ /* lather, rinse, repeat. */
++ /* break if we have one response but other ntp servers doesn't response */
++ /* greater than timeout_interval/2 */
++ if (servers_completed && now_time-start_ts > timeout_interval/2) break;
+ }
+
+ if (one_read == 0) {