aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios-plugins
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-04-16 09:46:29 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-04-16 09:46:29 +0000
commite140c225054cac277b11e951fee739071eb82017 (patch)
treec275106e387d0edc08f815ac0ed2f5468d2f5feb /net-mgmt/nagios-plugins
parent891e69b5e4e6627f658a55d192dc49a1fbd206ad (diff)
downloadports-e140c225054cac277b11e951fee739071eb82017.tar.gz
ports-e140c225054cac277b11e951fee739071eb82017.zip
Notes
Diffstat (limited to 'net-mgmt/nagios-plugins')
-rw-r--r--net-mgmt/nagios-plugins/Makefile3
-rw-r--r--net-mgmt/nagios-plugins/distinfo4
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in13
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins__Makefile.am16
4 files changed, 22 insertions, 14 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index e06932e87bd1..c69f0169d8f9 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nagios-plugins
-PORTVERSION= 2.0
-PORTREVISION= 1
+PORTVERSION= 2.0.1
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= https://www.nagios-plugins.org/download/
diff --git a/net-mgmt/nagios-plugins/distinfo b/net-mgmt/nagios-plugins/distinfo
index f00b4d328d3c..694def7b2be8 100644
--- a/net-mgmt/nagios-plugins/distinfo
+++ b/net-mgmt/nagios-plugins/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nagios-plugins-2.0.tar.gz) = ba1080648abd912f55c18b248e7065db77a87d0c72611ab16c17af8b65da7684
-SIZE (nagios-plugins-2.0.tar.gz) = 2501847
+SHA256 (nagios-plugins-2.0.1.tar.gz) = 1fb63cf8e917397c745f9a30b3eac6178d832df80f914e2498e8171408c9172a
+SIZE (nagios-plugins-2.0.1.tar.gz) = 2651400
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in b/net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in
index dacce592f3d0..d6a7d1fd86bb 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in
+++ b/net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in
@@ -1,5 +1,5 @@
---- ./plugins-scripts/subst.in.orig 2014-03-04 20:21:36.000000000 +0100
-+++ ./plugins-scripts/subst.in 2014-04-14 10:22:50.000000000 +0200
+--- ./plugins-scripts/subst.in.orig 2014-03-04 22:41:57.000000000 +0100
++++ ./plugins-scripts/subst.in 2014-04-16 11:38:35.000000000 +0200
@@ -1,7 +1,7 @@
#!/usr/bin/awk
@@ -9,3 +9,12 @@
if (system(cmd)==0) {
return c;
+@@ -53,7 +53,7 @@
+ # FIXME: Prepend executables with a substitution keyword instead.
+ #
+ /^[^#]/ && /(\/.*)?\/(bin|sbin|lib|libexec)\// {
+- match($0,/(\/.*)?\/(bin|sbin|lib|libexec)\/[-_a-zA-Z0-9]+/);
++ match($0,/(\/[^ ]*)?\/(bin|sbin|lib|libexec)\/[-_a-zA-Z0-9]+/);
+ c=substr($0,RSTART,RLENGTH);
+ sub(c,which(c,path));
+ }
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins__Makefile.am b/net-mgmt/nagios-plugins/files/patch-plugins__Makefile.am
index 77d6bd25095f..736057949b19 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins__Makefile.am
+++ b/net-mgmt/nagios-plugins/files/patch-plugins__Makefile.am
@@ -1,11 +1,11 @@
---- plugins/Makefile.am.orig Thu Jan 25 09:48:05 2007
-+++ plugins/Makefile.am Thu Feb 22 19:32:15 2007
-@@ -2,7 +2,7 @@
+--- ./plugins/Makefile.am.orig 2014-04-16 00:19:03.000000000 +0200
++++ ./plugins/Makefile.am 2014-04-16 11:38:18.000000000 +0200
+@@ -14,7 +14,7 @@
+ VPATH = $(top_srcdir) $(top_srcdir)/lib $(top_srcdir)/plugins $(top_srcdir)/plugins/t
- VPATH = $(top_srcdir) $(top_srcdir)/lib $(top_srcdir)/plugins $(top_srcdir)/plugins/t
+ AM_CPPFLAGS = -I.. -I$(top_srcdir)/lib -I$(top_srcdir)/gl -I$(top_srcdir)/intl \
+- @LDAPINCLUDE@ @PGINCLUDE@ @SSLINCLUDE@
++ @LDAPINCLUDE@ @PGINCLUDE@ @SSLINCLUDE@ @RADIUSINCLUDE@
--INCLUDES = -I.. -I$(top_srcdir)/lib -I$(top_srcdir)/gl -I$(top_srcdir)/intl @LDAPINCLUDE@ @PGINCLUDE@ @SSLINCLUDE@
-+INCLUDES = -I.. -I$(top_srcdir)/lib -I$(top_srcdir)/gl -I$(top_srcdir)/intl @LDAPINCLUDE@ @PGINCLUDE@ @SSLINCLUDE@ @RADIUSINCLUDE@
-
- datadir = @datadir@
localedir = $(datadir)/locale
+ # gettext docs say to use AM_CPPFLAGS, but per module_CPPFLAGS override this